The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > Developer > AppleScripting Omni Apps
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Problem attempting to move a row... Thread Tools Search this Thread Display Modes
Hi,

I am attempting to write a script that moves a selected row from one section to another in the same document (The document has two sections).

I have tried and failed using two possible constructs : the first using the duplicate command - failed attempting to filter based on Ancestor:
Code:
-- copy the checked items
	duplicate (every row of original whose state is checked and has subtopics of it is false and ancestor is first child of original) to end of children of LastRow
original is set to the front document

Next I tried doing a move from within a loop of all the rows in a section:
Code:
repeat with oneRow in rows of first child of original
if (state of oneRow is equal to checked) then
move oneRow of original to the end of children of LastRow
end if
end repeat
LastRow was set using :
Code:
set LastRow to make new child at end of rows of LastSection with properties {topic:dateString}

The first option is the most elegant as the duplication will duplicate all rows in one line of code.
I am unable to fathom the syntax, can anyone help?
best wishes
Simon
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bug # Move Xyzwolf OmniPlan for iPad 1 2012-07-23 05:08 AM
How to move project into folder? [A: Tap Edit, tap item, tap "move" button in Tbar.] Avis OmniFocus for iPhone 4 2010-07-07 11:27 AM
Move to project? hexsprite OmniFocus 1 for Mac 12 2008-11-21 06:05 AM
Could someone explain how to move OF to a new mac? As8 OmniFocus 1 for Mac 5 2008-01-17 12:33 PM
Hangs when attempting to use the Quicktime Plugin oleandros OmniWeb Bug Reports 3 2006-04-30 08:23 PM


All times are GMT -8. The time now is 05:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.