The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Other WebDAV
FAQ Members List Calendar Search Today's Posts Mark Forums Read

EMAILED: WebDAV Sync Failure Thread Tools Search this Thread Display Modes
UPDATE: It works now! See last few posts


First of all I want to compliment you guys on an awesome desktop GTD application. I just started using it yesterday, it took me about 3 hours to transfer all my text list based GTD info to Omingroup.

Today I purchased the iPhone application. I set up WebDAV on my server and I am able to upload my info to the server. Once this is done, I see a folder called "OmniFocus.ofocus" in my WebDAV folder which contains about 4 MB of zip files. My backup files are a bit over 6 MB. When I click "Sync" again on my desktop app it pops up the following dialog box:

Your database couldn't be synchronized, because the copy on the server has been reverted since the last sync.

This was most likely caused by restoring from a database backup. Which copy of the database would you like to use? The other database will be saved in your database backup folder.

Of course I tell it to "Use Local Copy" and then it uploads it again. Then when I click "Sync" the same thing happens again.

Now when I sync my iphone it just gets about 44 items in the Inbox and nothing else.


Any ideas on this one?


Last edited by eecue; 2008-07-25 at 06:21 PM.. Reason: It works now!
Ok a bit more info. In my server logs I am seeing this:

[Tue Jul 22 18:55:45 2008] [error] [client ***********] (2)No such file or directory: An error occurred while opening a resource. [500, #0]
[Tue Jul 22 18:55:47 2008] [error] [client *************] Unable to PUT new contents for /********/OmniFocus.ofocus-copy-in-progress-pjE52UN-GXf/ [403, #0]

That repeats a whole bunch of times during the sync.

I'm running Apache 2.2 on FreeBSD.


It looks like the folder on my server has 1608 files in it, whereas the folder when I Sync to disk has 1667 files.

Any idea on this one?
When you say "upload my info to the server" do you mean the first OmniFocus sync, or are you copying the file up there through some other method?
Also, can you copy a file with '=' and '+' in the file name directly to the WebDAV server (not through OmniFocus)?
What sort of server exactly do you have?
I am having exactly the same problem with my MacBook Air running the latest 'Sneak peak' version.
It happens on every sync with the 1.1 version on the iPhone and happens fairly frequently when the 1.0 version is on the iPhone.
I am using .Mac.

I have paid 12 for the iPhone version but this is putting me off paying 40 for the Mac version.

(This isn't meant to be a moan and I know sync is in Beta but there doesn't seem having an iPhone version unless it syncs)


Last edited by lilyblossom; 2008-07-23 at 12:58 AM..
I mean upload via the Sync to WebDAV feature, sorry if I was unclear.

I realize I posted this in the wrong forum.
Also I should mention that I set up syncing via Mobile Me and it works like a charm.

I have the same problem with mobileme (.mac)

Thank's for your assistance


PS : Omnifocus it's a very good application. Congratulations to the dev team
I just got the same message and I didn't restore as the message suggested. I'm using .mac (MobileMe) to sync between the Sneaky Peek revision 103214 and iPhone 1.1 (?). I'm afraid and don't know what to do. It seems I've been frequently losing info during syncs in general.

Specifically, I manually synced my phone, then closed the application on the phone. (The desktop version was not running.) I opened the desktop version, and synced. I got the message about having to reopen the local database (can't remember the exact msg. but this seems to always cause problems) then downloaded and installed the update. I started changing info, and it then came up with this message.

I didn't notice the errors right away. I'm going to have to be much more diligent on looking for these errors to give better feedback. I have been very diligent, however, about only having one program (either the iPhone or the local version) running at once and manually syncing after and before switching.

Last edited by jalarson; 2008-07-23 at 09:48 AM..

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sync Failure - Then it works? nickbarbosa Syncing via Omni Sync Server 1 2013-02-01 08:50 PM
Feature Request (emailed already): Due Counts MutantSquid OmniFocus for iPad 1 2010-07-31 12:36 AM
MobileMe sync failure in 1.7.2 leebu OmniFocus 1 for Mac 2 2009-09-06 11:29 PM
Sync failure for Office-iPhone-Home scenario chidmf OmniFocus Syncing 53 2008-08-06 04:12 PM
WebDAV sync problems Mark Lawrence Other WebDAV 30 2008-07-15 04:28 PM

All times are GMT -8. The time now is 06:58 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.