The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Cannot save to server Thread Tools Search this Thread Display Modes
I teach in a lab using Leopard 10.5.5 and I'm using Managed User accounts for students. Students save their files to a network account (Novell running Apple services.) As I was testing today in preparation for lessons next quarter, I discovered that I cannot save files to the server when I am using a Manager account. I get the error: The document "whatever" could not be saved as "whatever". You do not have appropriate access privileges. When I use the computer's Admin account I can save.

Using the computer's student account I can save to the computer's hard drive (not my chosen methodology but an option if need be). Obviously OG is attempting to save something to a directory that the managed account doesn't have permissions to but I cannot figure out what/where. At first I thought it might be something to do with the student/teacher Novell account but using the student computer account and my Novell admin account I still could not save. So the issue seems to be something being saved to the local computer and not the server at all.
 
A rough guess would be that OmniGraffle is attempting to save the file out as a package, which may not be understood by whatever's running the server.

In the Document Inspector there are settings to force a file to save as a "flat", monolithic file type, or as a package or wrapper, that sort of thing.

Hope that helps,
__________________
"Vroom! Vroom!!"
 
I'll give that a try, thanks.
 
Quote:
Originally Posted by Joel View Post
A rough guess would be that OmniGraffle is attempting to save the file out as a package, which may not be understood by whatever's running the server.

In the Document Inspector there are settings to force a file to save as a "flat", monolithic file type, or as a package or wrapper, that sort of thing.

Hope that helps,
That didn't solve it and now when I look at your answer again with fresh eyes I think you assumed what I originally did - that the problem lie with the server. I don't think that's it. Remember, using the computer's admin account I can save to the server whether I log onto the server using my teacher account, my student test account (access to fewer shares) or my Novell admin account. Saving to the server isn't the issue - saving under a Leopard managed account is the sticking point.
 
You did verify that other applications can successfully save when OmniGraffle cannot, right? How about OmniOutliner, which also saves packages in at least some cases? (You can download a trial copy for free if the school doesn't have a license) Obviously, testing a non-Omni, non-package-writing application (TextEdit seems like a fine choice) to make sure that the problem isn't seen there would help to show that the problem is one that Joel should be chasing. I apologize if you've already done the obvious and assumed we would know you did so before asking...
 
Quote:
Originally Posted by whpalmer4 View Post
You did verify that other applications can successfully save when OmniGraffle cannot, right? How about OmniOutliner, which also saves packages in at least some cases? (You can download a trial copy for free if the school doesn't have a license) Obviously, testing a non-Omni, non-package-writing application (TextEdit seems like a fine choice) to make sure that the problem isn't seen there would help to show that the problem is one that Joel should be chasing. I apologize if you've already done the obvious and assumed we would know you did so before asking...
Since I've done tech support I understand why you asked - Pages, Word, Teachtext, DrScheme, BlueJ, Photoshop, Photoshop Elements are just some of the programs we've used successfully since the start of the school year.

The issue is new to Leopard/OmniGraffle 5. Last year we were using Tiger and I hadn't yet upgraded to O5 and I had no trouble saving files using my managed user account. Naturally I've thrown OG4 away and don't have any computers with Tiger to isolate one from the other.

Just got the newest version of OO downloaded and with the Managed account I get the error "The document "test.oo3" could not be saved as "test". For the heck of it I changed the document name to test.oo3 but that did nothing other than change the error message.
 
At this point I'm idly wondering if there's some sort of permissions issue going on. No idea why it would differ between different applications, but something's amiss.
__________________
"Vroom! Vroom!!"
 
Quote:
Originally Posted by davidwb View Post
Since I've done tech support I understand why you asked - Pages, Word, Teachtext, DrScheme, BlueJ, Photoshop, Photoshop Elements are just some of the programs we've used successfully since the start of the school year.

The issue is new to Leopard/OmniGraffle 5. Last year we were using Tiger and I hadn't yet upgraded to O5 and I had no trouble saving files using my managed user account. Naturally I've thrown OG4 away and don't have any computers with Tiger to isolate one from the other.

Just got the newest version of OO downloaded and with the Managed account I get the error "The document "test.oo3" could not be saved as "test". For the heck of it I changed the document name to test.oo3 but that did nothing other than change the error message.
Ah, good man :-)

You can download a trial copy of OG4 (which should be sufficient to see if it has this same problem) from http://www.omnigroup.com/ftp/pub/software/MacOSX/10.4/. I suppose it is possible that Omni has caused this bug with a framework change (thus causing both OG5 and OO3.7 to fail) and that they might have done so just long enough ago to make the copy of OG4.2 you can download there fail but not long enough ago to make whatever OG4 version you previously had fail, thus obfuscating matters a bit more rather than providing clarity, but Joel seems like a clever enough chap, up for a bit of a challenge now and then :-)
 
Hmm, another possibility might be the Quick Look preview, which is a new feature to OmniGraffle 5, so you may want to experiment with turning that preview off.
__________________
"Vroom! Vroom!!"
 
Downloading OG 4 now and I'll try out turning off quicklook. Yep - this has me flummoxed too. After getting the new computers in I quickly configured one, got my software on it, and began testing. (I've come to both dread and look forward to new computers.) At the time OG was on my want list but hadn't made my must have list. (Sorry, had to be realistic and I could make do with other software that had serious suckage issues but didn't have a choice about things like Office and Photoshop.)

So when I got approval for OG last week I decided I'd better see if there were any issues with the network and managed accounts. Some programs do have serious issues...I won't mention any names...MS. So I was surprised to find a save issue.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please add Omni Sync Server support [A: iPhone app supports the server. See thread.] StateMachineJunkie OmniFocus for iPhone 4 2010-11-30 01:29 PM
Sync fails after initial sync on Windows Server 2008 [Server Bug] Shortie Other WebDAV 5 2009-07-16 09:20 AM
AutoFill 'Always save' vs AutoComplete 'Always save' Gregory OmniWeb Bug Reports 1 2008-07-31 09:05 PM
Save window size doesn't save position zottel OmniWeb Bug Reports 3 2006-08-29 02:33 PM
I can't save idpexec OmniPlan General 2 2006-07-26 10:00 PM


All times are GMT -8. The time now is 06:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.