The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > iDisk/MobileMe/.Mac Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
What's a "forbidden" or "403" error when syncing with MobileMe/iDisk? Thread Tools Search this Thread Display Modes
I just needed to switch my me.com account to a prestine new one. After changing the me.com username in the settings of either iPhone and Mac in OF I do get when syncing:

Unable to perfom WebDAV operation.
The idisk.me.com server returned "forbidden" (403) in response to a request to "PROPFIND /MYUSERNAME/Documents/OmniFocus.ofocus".

Any ideas?

Best
Oliver

Last edited by giessler; 2008-08-06 at 01:16 PM..
 
Are your settings in the MobileMe or the Advanced section?
Did you switch over your MobileMe account name in System Preferences also?
 
Quote:
Originally Posted by Lizard View Post
Are your settings in the MobileMe or the Advanced section?
MobileMe

Quote:
Originally Posted by Lizard View Post
Did you switch over your MobileMe account name in System Preferences also?
Yes
 
I have the exact same problem after I use a new username in mobile me. Any help is appreciated.

UPDATE: I think I was still able to sync after having a new username in me.com and the problem only really started after I downloaded the latest update in OMF>

Last edited by ommo; 2008-08-07 at 10:45 PM..
 
Can you put files on your iDisk directly from the Finder or the MobileMe website?

Also, check your keychain for any stored passwords for your old MobileMe account and remove them.
 
Lizard, thank you for the suggestion. I deleted anything in reference to my old user name in my me.com account appearing in Keychain and was able to sync OMFocus on iMac with me.com.

I then deleted OMF on my iPhone and re-installed it. When I tried to sync the OMF on my iPhone I still get the same message "Unable to synchronize database with server. Unable to perform WebDav Operation. The idisk.me.com server returned "forbidden" (40 in response to a request to "PROPFIND ..........etc."

So I guess the problem is something in the iPhone which prevents OMF to sync with my new user name me.com account.

OF on my iMac (at work) syncs with iDisk which in turns sync with my Mac Book Pro (at home) without problem. So the problem is not with iDisk but with the OF on iPhone.

Please HELP ! I have been spending way too much time on this at the expense of my work.

p.s. Just a thought - any point in erasing all content and settings of my iPhone by going to Settings - Reset - Erase all Content and Settings ?

Last edited by ommo; 2008-08-08 at 05:50 AM.. Reason: After thought
 
It appears that the user name and password that OmniFocus for iPhone uses can get stuck on a particular value. If you enter a typo or if your login information changes, OmniFocus gets stuck using the bad/old information.

We're going to add some code in our next update that manually prompts you for another user name and password combo when we get a "403 forbidden" response to a sync.

For the time being, though, we'll work around the problem by doing the following:
In OmniFocus' settings screen, scroll down to the sync settings.
Tap "advanced", then enter "http://demo.omnigroup.com" into the "Location" field.
Tap 'done', then tap the sync button.

Your phone will attempt to contact our server for a sync; we'll prompt the phone to ask you for a new login and password.

Type in random gibberish for the user name and password - the point here is that we want our server to send you a 'bad password' response. (Do not type in the user name and password of the *account you're actually trying to sync with; we could read that data.)

In any case, when the password sheet comes down a second time, tap 'cancel', then set the phone up with the correct sync address and start a sync.

You should be asked for the user name and password to your sync location. Enter the new information and you should be back up and running.
 
And once you do this, you'll want to rerun the CoalesceDatabase script that's posted several other places on the forums, because changing your sync settings in 1.0.2 causes your database to grow out of control until you smoosh your database.
 
And yes, once 1.0.3 is out, you won't need to manually coalesce your database nearly so often. And instead of getting a 403 error, you should get a chance to re-enter your username/password.

EDIT: That fix didn't make 1.0.3. So you'll need this workaround a little longer.

Last edited by Lizard; 2008-08-08 at 02:34 PM..
 
It works, it works !!!! Thank you sooooo much.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
MobileMe "Root Transactions" problems [SOLVED: caused by iDisk syncing, see sticky.] codog24 iDisk/MobileMe/.Mac Syncing 27 2009-09-01 06:21 PM
Solving MobileMe/iDisk "Root Transactions" problems Brian iDisk/MobileMe/.Mac Syncing 0 2009-05-13 06:38 PM
Sync: server returned an error 403 "forbidden" fishwind OmniFocus for iPhone 6 2008-08-08 01:16 PM
Unable to Sync - Error 403 "forbidden" fishwind OmniFocus Syncing 2 2008-07-17 02:10 AM
Error 403, "Forbidden" with Zimbra 5.0 braver OmniFocus Syncing 1 2008-07-13 04:42 AM


All times are GMT -8. The time now is 07:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.