The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Just FYI: OF for iPhone breaks with iOS7 beta Thread Tools Search this Thread Display Modes
Just thought I'd let you fine folks know that in testing iOS 7 beta, that OF for iPhone is not working properly. Specifically, pulling in sync'd data from OmniSync fails leaving the app empty without any data.

Of course we can't expect Omni Group to support the beta, so this is more of a letting you know, proceed with caution kind of thing.
I'm having the same problem. Came here to see if anyone else had trouble. Hoping this is solved quickly, otherwise a downgrade might be in my future...
I installed ios7 as well, but all my data is there. Are you installing fresh and trying to resync or did you restore your old data? I did the latter. It seems the update makes the apps see it as a "new" device.
Jjlucsy - Thanks for the advice...I deleted all of my clients on the sync pane in preferences, did a fresh sync with the iPhone, and all worked. Looks like I'll be sticking with IOS7 for a while longer...
Works OK here
No issue for me with iOS 7 on a private WebDAV server (Mountain Lion).
iOS7-B1 worked fine on my iPhone, unfortunately OF does not read the database on B2 for me. The database (6MB) is on my iPhone and iPad, I even tried loading it via iTunes, but no data shows up in either app. I went back to B1 on my iPhone, and the issue continued. My iPad was fine when I went back to iOS 6.
I am an iOS developer, and I too attempted to install OmniFocus for iPhone onto iOS 7 Beta 2. Typing in my Omni Sync password did not sync.

I followed the instructions on this thread: I opened Preferences in OmniFocus 1.1x on the desktop, and opened the Sync preferences view. I selected Show Clients and unregistered the phone I had updated to iOS 7.

I returned to the phone and a new sync worked perfectly.
I tried unregistering my devices, but that did not solve the problem. I even tried a clean iOS7 install, only installed OF on my iPad, unregistered all clients except the desktop, and tried to then synch OF iPad…no go. The database loads to my iPad, but it is not read by the app. I then unregistered all clients, rebuilt and compacted the db, re-synched the mac client, and same issue with iPad on iOS7.
Obviously this is working for some people and not for others. Staying away from details about iOS 7 and Mavericks (which are both still under NDA), let me talk a little about a free open source project, libxml2.

Libxml2 is a library which parses plain text XML files, and ships with Mac OS X and iOS. It's used by OmniFocus to read your tasks, which are stored as plain text XML in your OmniFocus database.

Libxml2 version 2.9.0 was released as open source last September, and introduced some default parser limits where there previously weren't any (other than available memory). These limits can be configured, of course—but if an app which was built against an earlier version of libxml2 were to find itself unexpectedly using 2.9 or later, it might very well accidently bump into these limits—particularly when asked to read large XML files.

That sort of change could explain why some people might have no trouble at all using an app, while other people find it stops working as soon as they try to load up a large dataset.

Hope this helps!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

All times are GMT -8. The time now is 02:09 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.