The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Assistance on backup recovery, please Thread Tools Search this Thread Display Modes
I'm attempting to recover my OF after a tragic crash last week, but my backup xml file is not recognized.

Specifically -- "Unrecognizable transaction file name 'B0A416EB-7833-4258-A047-59DEEFAF57E9C80989A8-CCC9-485E-AD42-C88AE8EE6D0F.xml'."

The backup file is attached in a zip - can anyone shed light onto what the problem might be?

Thanks!

Last edited by ramekin; 2007-12-03 at 12:13 AM..
 
You can use Show Package Contents on the .ofocus file and rename root=B0A416EB-7833-4258-A047-59DEEFAF57E9C80989A8-CCC9-485E-AD42-C88AE8EE6D0F.xml to root=B0A416EB-7833-4258-A047-59DEEFAF57E9C80989A8-CCC9-485E-AD42-C88AE8EE6D0F.xml to root=B0A416EB-7833-4258-A047-59DEEFAF57E9:C80989A8-CCC9-485E-AD42-C88AE8EE6D0F.xml

(note the ":" in the middle).

How did this file get in this state? If you can reproduce OmniFocus doing this, please let us know how as soon as possible.
__________________
CTO, The Omni Group
 
Trying this in Finder, I see that it won't let you do the rename there. Here is a fixed copy.

OmniFocus 2007-11-26 111406.ofocus 2.zip
__________________
CTO, The Omni Group

Last edited by Tim Wood; 2007-12-03 at 12:05 AM..
 
I was unable to add a colon in finder, but I used a slash and that worked for recovery! Thanks
 
As background:

- Originally, I was using 10.4 and backing up using Mozy.
- Upon replacing my HDD, I installed 10.5
- Restored backed up files from Mozy into 10.5, and none of the OF backup files have a colon in their xml file names.

Don't know if its a Mozy situation or a 10.5 situation, but hopefully that helps.
 
Ah; interesting! I'm guessing the round-trip through Mozy is the issue. The ":" was probably rejected by Finder for legacy OS9 HFS reasons (the "/" is turned into a ":" behind the scenes now).

Mozy may be doing some sort of "Mac-aware" file name mapping that is causing this. Of course, I'm only guessing this is the case -- I haven't tried Mozy, so you might try pushing your file through them and back again to see if it happens again. If so, I'd recommend asking them to fix the issue so other folks doing get hit by this.

Thanks for the extra details!
__________________
CTO, The Omni Group
 
I had exactly the same issue (leopard backup, leopard restore) using mozy to backup the documents folder which includes "Omni Focus Backups", thanks for the solution! i'm concerned about mozy now, that was scary! ~K
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Assistance creating templates DeaconPatrick OmniOutliner 3 for Mac 1 2011-05-29 10:02 AM
Looking for assistance on address bar search unixstudent OmniWeb General 2 2006-07-18 11:57 AM


All times are GMT -8. The time now is 11:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.