The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Bonjour sync
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Bonjour Sync Issue - Any Fix? Thread Tools Search this Thread Display Modes
was there any resolution to this problem as I am having the same thing...
I've been having the same issue ... I first noticed that the sync error would occur only when I had previously closed OmniFocus on my Mac. In my case, I can get sync working again on the iPhone (iOS 4) by activating the 'recently used apps' and closing OmniFocus. When I launch the app again, sync works fine. Seems to me the issue was introduced with Fast App Switching support. Maybe OmniFocus on the iPhone needs to check for any changes to the sync server when it is launched.

For what it's worth, I also tried syncing with the Cellular Data option turned on and off, but neither option allowed OmniFocus to resolve the sync server.
We do think that the application is holding onto some old or outdated information about the wireless network you're last synced over. If the wireless environment changes at all, we may lose our connection to the server.

We'll fix this in an update - don't have a release date for it yet - but in the meantime, folks can work around the problem with the following steps:

Double tap the round "home" button on your phone.
When the App Switcher tray appears, tap and hold on OmniFocus' icon until a red badge with a minus symbol appears.

Tap the red badge; OmniFocus will quit.
If you press the home button one more time and re-launch OmniFocus, that will force the application to re-connect to your wireless network. Sync should work now, but you may have to repeat this process later.

We're really sorry for the inconvenience this causes!

Last edited by Brian; 2010-07-09 at 03:19 PM.. Reason: copy-paste error.
OK, I was afraid that I could no longer sync and was experiencing whatever new issue everyone is discussing, but for me, it turned out to be a firewall issue:

I had Firewall ON and under Advanced had checked Block all incoming connections. The prevented me from synching OF with my iPhone. I turned it off and I could sync. Then, I turned on the firewall, but unchecked Block all incoming connections. Instead, I added OF to the list to Automatically allow signed software to receive incoming connections. Now I can sync.

This has never been a problem for me because till recently, I synched all my devices (laptop, iPhone, iPad) to my Mac Pro, but I then realized it made more sense to sync to my MacBook Pro since I would always have that with me at home or when I travelled. So, I switched where I kept the DB.

I hope this might help others. Let me know if I was too wordy and unclear. I could repost and add screenshots.

Happy Synching!


OmniFocus on iPhone also causing my wireless connection to fail during syncs. Followed your suggestion re airplane mode and manual reconnection of wireless. I can confirm that this method allows my OmniFocus on my iPhone to successfully sync. As soon as I turn airplane mode off, the iPhone drops wireless during sync and the sync fails.
Similar problems here. OmniFocus iPhone 1.7.2, OmniFocus desktop 1.7.5, OS X 10.6.4, Mac cabled into WiFi router.

First sync works fine but WiFi is dropped on the iPhone after. I can see this by the '3G' symbol instead of the 'WiFi Fan'. If I go into settings and reattach to my WiFi the next sync works fine, but, WiFi is dropped afterwards.

One strange thing for me though is that when I sync by pressing the sync button at the bottom of the iPhone screen it rarely drops the WiFi connection. It will do it every time when automatically syncing after a change.

I'm keenly looking for a fix.
I suspect this is just an issue of timing. We've observed that iOS tries to preserve battery life by shutting down wifi connections a little while after the phone goes idle - even if info is being sent. (This is not something OmniFocus is doing on purpose, in other words.)

Since OmniFocus' auto-sync behavior is also tied to the phone being idle, it's going to start closer to that "and now it's time to turn off WiFi" point. (Tapping the sync button resets the timer iOS is using to decide when to turn off the WiFi, so it gives you the maximum amount of time before that happens.)

We originally discovered this in iOS 3; it's possible that iOS 4 changed the behavior, but I haven't seen anything to suggest that it has.
Hi Brian,

Ok, I can see that if iOS drops the WiFi connection while OmniFocus is trying to sync, then the OmniFocus sync will fail. What still isn't clear to me is why the WiFi connection isn't re-established again when the phone is brought out of the idle state. The WiFi is re-established every other time the phone is brought out of idle, just not after OmniFocus sync has failed.

For me, I'm happy to turn of automatic sync and manually sync for now if means that I don't have to go into settings all the time to re-establish my WiFi connection before syncing. That is a suitable work around for me for the moment.

I'll keep an eye on this thread and I hope you can find a way through this because it's very frustrating and from a customer point of view my WiFi is being dropped ONLY when OmniFocus auto syncs.

Hello all!

I am experiencing a similar issue except I am running OF on an old 1st gen iPhone running iOS 3.1.3. I was syncing perfectly until today I attempted to sync after three days of not syncing. In an attempt to fix the problem I reset my database on my iPhone and was brought to the original splash screen asking me if I would like to "Set Up Sync" or "Make New Database." I have tried setting up sync just as I have done the first time and I have tried the work-around posted in the FAQ's page.

If I try to straight sync the device, it will recognize my Mac after clicking the "Share Settings" button, but when I tap on my username, it goes to the "Preparing to synchronize" screen and stays there for about five minutes with the gears spinning at the bottom. After the five minutes, it returns me to the "Sync with Mac" screen that I was at previously.

If I attempt to do the work around, it allows me to crate a new database, and it will detect the setting from my mac when shared, but when I leave settings and it attempts to sync I get the spinning gears at the bottom for another five minutes before a notification appears stating "Unable to synchronize database with server. timed out." Clicking retry leads to the same results.

Now, I have tried turning the iPhone airport off then on again. I have tried restarting both the iPhone and my Mac. I have uninstalled the app from my phone, restarted the phone, then reinstalled the app. I have reset all sync settings on my Mac and I have tried every combination of firewall allowances I could think of. None of this helped. Hopefully one of you can! Bellow is a list of what I am running. Thanks in advance!

Machine: Unibody MB Pro running Mac OS 10.6.4 and iTunes 10
OF for Mac: Version 1.7.5
iPhone 1: iOS 3.1.3
OF for iPhone: Version 1.7.2

Last edited by TheSophist87; 2010-09-09 at 12:01 AM..
Welcome to the forums, TheSophist!

These symptoms - the iPhone can see your Mac but can't actually sync with it - generally mean that the firewall on the Mac is letting OmniFocus send information, but is blocking incoming connections from the phone.

If you take a look at this thread in the Bonjour Sync forum, there are several tips which may help; if they don't, contact us via email or phone (800.315.6664) and we're happy to provide further assistance!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bonjour sync fail cdg@home Bonjour sync 2 2011-05-16 08:13 AM
Sync with Bonjour only without firewall!!?? Flashracer Bonjour sync 3 2011-04-19 01:11 PM
Cannot sync over Bonjour vsuri OmniFocus for iPhone 0 2010-10-07 10:24 AM
Can't get Bonjour sync working ghoti Bonjour sync 5 2010-05-13 04:51 PM
Sync Stopped Working Using Bonjour [SOLVED: Firewall on Mac blocking sync] ajgilbert Bonjour sync 4 2009-06-21 10:46 AM

All times are GMT -8. The time now is 04:38 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.