The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > iDisk/MobileMe/.Mac Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
MobileMe "Root Transactions" problems [SOLVED: caused by iDisk syncing, see sticky.] Thread Tools Search this Thread Display Modes
I'm using the latest build of OmniFocus (1.1 sneakypeek (v77.10.0.105369)) on my MacBook Pro and OmniFocus for my iPhone 3G. I'm syncing through MobileMe, and have my iDisk syncing with a local copy on each of (4) different Macs. At present, I'm only using OF on one of those Macs and my iPhone.

Every couple of days, the sync functionality in OmniFocus is getting hosed for some reason. I'll get the following error on the Mac:

Unable to read document.

No root transactions found in "https://idisk.me.com/<myusername>/Documents/OmniFocus/OmniFocus.ofocus/".


Note that <myusername> is used above to prevent broadcasting my MobileMe user name.

I can then go to my iDisk and delete or rename the OmniFocus.ofocus document, and then sync works again, but sooner or later it stops working.

I have read that some people have turned off local iDisk syncing, which seems to help, but I have yet to find a definitive post from the Omni folks that says, "you can't sync with MobileMe if you have iDisk sync turned on". Since I need to be able to sync with a local copy of my iDisk, I'd like to get to the bottom of this once and for all.

Why does sync break for me every few days?
Can I or can I not reliably sync between OF on my Mac and OF on my phone, and still have local iDisk sync functionality?

Thanks,

Adam
 
You might be able to help the discovery process along if you zip up your MobileMe OmniFocus.ofocus file after getting one of those errors and send it off to urgent@omnigroup.com along with an explanation of what you are sending them. My suspicion is that the file is getting clobbered by the MobileMe/iDisk sync mechanism in some fashion. There have been reported cases of the MobileMe/iDisk sync agent getting confused about which version of the file should be kept and asking the user for help; it doesn't seem beyond the realm of possibility that it might (incorrectly) proceed with confidence and squash your data in other cases.

Are you certain that you need the MobileMe/iDisk sync turned on? Do you need it because of the offline access it permits, or do you change the files it contains from multiple computers simultaneously?
 
Quote:
Originally Posted by codog24 View Post
I have read that some people have turned off local iDisk syncing, which seems to help, but I have yet to find a definitive post from the Omni folks that says, "you can't sync with MobileMe if you have iDisk sync turned on". Since I need to be able to sync with a local copy of my iDisk, I'd like to get to the bottom of this once and for all.
We would, too! What this error means is that the root transaction file (starting with "0000...") has been removed from your OmniFocus.ofocus folder on the server. OmniFocus doesn't do this itself (unless it writes a new root first), so something else is implicatedóbut we're not really sure what.

Some people are using local iDisk syncing without any trouble, and we haven't been able to reproduce this problem in our testing. But as far as I can tell everyone who has reported this sort of problem does have iDisk syncing turned on, so perhaps that is a factor. (But perhaps iDisk syncing is working fine, and there's something else causing the problem.)

We've reported the issue to Apple, but since nobody knows how to reproduce the problem it's not clear whether it's their bug or how they might fix it.

Oh, one more important note: before the root transaction gets removed, are you getting an iDisk sync conflict on any of your computers (similar to the one in the Warning from OMNI thread)? If so, be sure to always choose to keep the server copy rather than the local copy (despite what the dates and sizes in the dialog might say). OmniFocus never touches the local copy, so that's never the copy you want to keep. (Please read that thread for more details.)
 
I've been having this same problem on my iphone. I sent an email last week about it, but haven't got a response yet. I just tried to sync again (turning off idisk auto sync) and it still fails. I'm stuck. There's no way to sync my phone and my imac.
 
I had this exact same problem. A support ninja suggested I turn off my idisk sync function. I did, and since that point I have not had the problem reoccur. Something about idisk syncing with my local disk fouled up the omnifocus.ofocus file in MobileMe.

After turning off the idisk sync option, I backed up the Omnifocus database, moved the existing folder in MobileMe to a different location and initiated another sync in OmniFocus. I've been problem-free since.

I hope the good folks at OmniFocus can figure this one out so I can get back my sync functionality on idisk.

Robert
 
Quote:
Originally Posted by whpalmer4 View Post
Are you certain that you need the MobileMe/iDisk sync turned on? Do you need it because of the offline access it permits, or do you change the files it contains from multiple computers simultaneously?
Yes, I do need to be able to sync with local copies of my iDisk, as I do change the files from multiple computers, and in the case of my MBP, need offline access from time to time.
 
Quote:
Originally Posted by Ken Case View Post
Oh, one more important note: before the root transaction gets removed, are you getting an iDisk sync conflict on any of your computers (similar to the one in the Warning from OMNI thread)? If so, be sure to always choose to keep the server copy rather than the local copy (despite what the dates and sizes in the dialog might say). OmniFocus never touches the local copy, so that's never the copy you want to keep. (Please read that thread for more details.)
I do indeed get an iDisk Sync Conflict warning related to this file from time to time, and always choose to keep the server copy.

I guess I'll turn off local iDisk sync for the time being, but that's not a viable long term solution. Hoppefully, Omni can get this sorted sooner rather than later.

Thanks,

Adam
 
Quote:
Originally Posted by rsilber View Post
I had this exact same problem. A support ninja suggested I turn off my idisk sync function. I did, and since that point I have not had the problem reoccur. Something about idisk syncing with my local disk fouled up the omnifocus.ofocus file in MobileMe.

After turning off the idisk sync option, I backed up the Omnifocus database, moved the existing folder in MobileMe to a different location and initiated another sync in OmniFocus. I've been problem-free since.

I hope the good folks at OmniFocus can figure this one out so I can get back my sync functionality on idisk.

Robert
At the risk of sounding really dumb, could someone clarify what this means? In the desktop app, I'm looking at sync preferences and I see the option to sink with MobileMe and another option for Disk. Should I not use MobileMe and use the Disk option instead? The current location, which is giving me the error, is my idisk, in the documents folder.

What's the difference between MobileMe and Disk?
 
Do NOT use the Disk option to sync to a local copy of your iDisk. That is pretty much guaranteed to result in a corrupt database. OmniFocus needs to sync against the "master" copy of the database - iDisk syncing is just a basic "merge the list of files" sort of sync, which will result in clashing files ending up merged together.
 
I have not used the iSync disk problem at all and this error has just started happening to me.

When I watch my upload speed while the syncing is happening, the upload speeds are full bandwidth, until about a min into the sync. Then they drop down from 500kb to 100kb to 30kb. The syncing continues for about 30 min, at the end of the syncing I get an error:

Unable to perform WebDAV operation.

The idisk.me.com server returned "not found" (404) in response to a request to "MOVE /myusername/Documents/OF/OmniFocus.ofocus-copy-in-progress-oS6M_yyg61F".

(I replaced my real username with myusername in the above error)

If I try and sync again I get an error saying no root transactions found.

I checked the console and found this error right around the time my bandwidth dropped down.

10/4/08 3:24:48 PM OmniFocus[38556] Exception raised:
---------------------------
Mask: 0x00000100
Name: NSAccessibilityException
Reason: "AXSubrole" attribute unsupported by: <NSButtonCell: 0x178fad20>
Stack Trace:
NSExceptionHandlerExceptionRaiser (in ExceptionHandling) + 185
objc_exception_throw (in libobjc.A.dylib) + 40
-[NSException raise] (in CoreFoundation) + 17
NSAccessibilityAttributeValue (in AppKit) + 160
CopyAppKitUIElementAttributeValueNoCatch (in AppKit) + 81
CopyAttributeValue (in AppKit) + 492
_AXXMIGCopyAttributeValue (in HIServices) + 287
_XCopyAttributeValue (in HIServices) + 498
mshMIGPerform (in HIServices) + 517
CFRunLoopRunSpecific (in CoreFoundation) + 3896
CFRunLoopRunInMode (in CoreFoundation) + 88
RunCurrentEventLoopInMode (in HIToolbox) + 283
ReceiveNextEventCommon (in HIToolbox) + 374
BlockUntilNextEventMatchingListInMode (in HIToolbox) + 106
_DPSNextEvent (in AppKit) + 657
-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] (in AppKit) + 128
-[NSApplication _realDoModalLoopeek:] (in AppKit) + 563
-[NSApplication runModalForWindow:] (in AppKit) + 286
-[CredentialsPrompt promptForCredentialsModally] (in OmniFocus) + 117
+[SyncManager _mainThreadPromptForCredentialsWithProtectionSpace :resultHolder:] (in OmniFocus) + 159
-[OFIObjectSelectorObjectObject invoke] (in OmniFoundation) + 77
-[OFQueueProcessor processQueueUntilEmpty:forTime:] (in OmniFoundation) + 386
-[OFQueueProcessor processQueueUntilEmpty:] (in OmniFoundation) + 57
-[OFQueueProcessor processQueueUntilEmpty] (in OmniFoundation) + 41
-[OFRunLoopQueueProcessor processQueueUntilEmpty] (in OmniFoundation) + 99
__NSFireMachPort (in Foundation) + 339
__CFMachPortPerform (in CoreFoundation) + 117
CFRunLoopRunSpecific (in CoreFoundation) + 3896
CFRunLoopRunInMode (in CoreFoundation) + 88
RunCurrentEventLoopInMode (in HIToolbox) + 283
ReceiveNextEventCommon (in HIToolbox) + 374
BlockUntilNextEventMatchingListInMode (in HIToolbox) + 106
_DPSNextEvent (in AppKit) + 657
-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] (in AppKit) + 128
-[NSApplication run] (in AppKit) + 795
-[OAApplication run] (in OmniAppKit) + 386
NSApplicationMain (in AppKit) + 574
_start (in OmniFocus) + 216
start (in OmniFocus) + 41
0x2

---------------------------

Here is what I have tried to remedy the situation:
-Through the mobile me website, deleted all OF documents and re-synced.
-Through the mobile me website, created a new folder in the documents folder called /OF/ and attempted syncing to that folder.
-Turned off all syncing and signed out of mobile me. Logged back into mobile me and turned on OF syncing.
-deleted iDisk password in login keychain.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
What's a "forbidden" or "403" error when syncing with MobileMe/iDisk? giessler iDisk/MobileMe/.Mac Syncing 19 2011-06-21 07:33 PM
Error: "No root can reach all tail transactions" sgiovannini Bonjour sync 2 2011-02-23 08:10 AM
Solving MobileMe/iDisk "Root Transactions" problems Brian iDisk/MobileMe/.Mac Syncing 0 2009-05-13 05:38 PM
"No root transactions found" error: Once more with feeling kklein OmniFocus 1 for Mac 10 2009-04-22 12:03 PM
OmniFocus dies with "no root transactions..." dialog box drjamesincandenza OmniFocus 1 for Mac 1 2009-03-19 01:18 PM


All times are GMT -8. The time now is 01:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.