The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Clipping Service very slow Thread Tools Search this Thread Display Modes
Hi there

I've set up Mail with MailTags and am looking to invoke the Clipping service to send mail to the quick entry panel.

However when I do so, it takes perhaps 15-20 seconds to open the quick entry panel and populate it. This is with OmniFocus open. Same thing if I send to inbox instead of to Quick Entry.

Am I missing something? It is unworkable at present on my Macbook.
 
This isn't normal. There must be some kind of conflict as mine is nearly instantaneous.

I'm not using MailTags though, just the Clip-o-Tron 3000 and Leopard Mail.
 
Hi!
Over here it can be quite slow, too. I'm not using Mailtags but sometimes creating an action from a Mail entry can take up to 10secs on my MBP. Possibly related to size & content of the Email.
Cheers
Silvan
 
OK, now I see what you mean. I tried it on several very large emails in Mail and the Clip-O-Tron does seem to take up to 10-15 seconds for very long emails (i.e. not large attachments, but very long email bodies with lots of embedded email addresses).

Note that I do not see this delay for medium to small emails though. Still, I'll open a bug report with Omni Group so they're at least aware of the issue. You might want to do the same (Help -> Send Feedback in OmniFocus).
 
The mail clipping service operates by AppleScript, and there are performance limitations that have to do with scanning through the text of the email. I'm betting this is as fast as we can make it. 'Script is pretty awesome, but perfomance isn't one of it's strengths.

If folks can send sample emails that they're having trouble with to support@omnigroup.com, we can add this to our development database in case we think of ways to optimize this in the future.

Last edited by Brian; 2008-05-28 at 02:12 PM.. Reason: added support address
 
Quote:
Originally Posted by Toadling View Post
OK, now I see what you mean. I tried it on several very large emails in Mail and the Clip-O-Tron does seem to take up to 10-15 seconds for very long emails (i.e. not large attachments, but very long email bodies with lots of embedded email addresses).
If you select one of those messages in Mail and hit Copy (instead of using the clipping service), how long does it take? (Copying is a prerequisite to sending it to us, that this will isolate how much time is spent in Mail before OmniFocus is invoked from how much time is spent afterwards.)
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Omnioutliner pro - clipping service josedacruz OmniOutliner 3 for Mac 3 2012-07-30 11:15 AM
Omnifocus is slow, very slow. bushi OmniFocus 1 for Mac 22 2011-01-06 02:16 PM
Clipping service cannot be used leingang OmniFocus 1 for Mac 4 2010-07-31 05:14 AM
Clipping service - turn off Dotogdrasl OmniOutliner 3 for Mac 4 2008-09-09 01:51 PM
New clipping service ksrhee OmniFocus 1 for Mac 5 2007-10-10 08:44 AM


All times are GMT -8. The time now is 01:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.