The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Still having problems with printing on some websites Thread Tools Search this Thread Display Modes
Howdy folks,

Having tried to use the print button on some websites (in order to have a print-friendly result) after changing the ad-blocking setting, I am still having trouble getting a proper print. I have doubts about it being my ad-blocking setting anyway because the problem is happening on sites at which have printed successfully before.

I suspect that this has something to do with the latest Apple system update, one that I downloaded quite recently. The notes mentioned a change to java 'something' but I do not remember any details.

No matter what the cause I don't have, but really need, a solution.
Would appreciate any help or suggestions.

Thank you,
Hunter
G3 iBook, 10.4.8, 640 RAM
 
Got example?
 
Hi Forrest and anyone else who can help,

I'm not sure this will help. But...

When I'm doing my internet banking, I need to be able to use the print button because printing (or saving as a PDF) the resulting page/doc gives me everything on the page. When that doesn't work (nothing happens), I have to command-P, then print or save as PDF. And then I only get what is visible on the screen. I am using this to save or print my receipts for all the transactions in that particular session of banking. In the not too distant past I could use the site's print button in order to get a printer-friendly page that would print (or save) in its entirety.

I'm not sure what else to say, except that when the pointer is over the button the following comes up at the bottom of the page: java:self.print().

Thanks,
Hunter
 
It is a javascript issue - some others have reported problems with Print buttons on pages (they typically use javascript for their output). If it works in the current official release of Safari, then there has been a regression in the Javascript engine since that release that needs to be or has been fixed in WebKit. Potentially it should work when OmniWeb upgrades to an even newer version of WebKit than the one it is using with the 5.6 release (assuming they manage to do so). In the meantime, you could test to see if it is due to the version of WebKit being used and if it is corrected in a more recent nightly build.

N.B. send a bug report to OmniGroup using the Send Feedback option from the help menu so that they are made aware of your problem.
 
JKT,

Don't know why I didn't test with Safari before. Obvious thing to do. With Safari, the button does work; so at least I have a back up until it works with OmniWeb.

Thank you for helping.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
OF 1.7 Printing Problems curt.clifton OmniFocus 1 for Mac 1 2009-08-15 03:06 PM
Problems with printing caspersgrin OmniOutliner 3 for Mac 2 2008-08-27 02:05 PM
printing problems bpsArch OmniPlan General 1 2008-05-12 03:20 PM
Printing problems Onmi OmniPlan General 3 2007-04-03 04:16 PM


All times are GMT -8. The time now is 12:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.