The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Still "Untrusted Server certificate" Thread Tools Search this Thread Display Modes
Hi there,

I used the newest version (both Iphone and Mac) of omnifocus. I used my Webdav-Server of my provider and I got no problems syncing with the Desktop-OF. But the Iphone-App says "Untrusted server certificate". I read about the problems in the forum and thought this problem is gone since 1.1. ?!

Bastian
 
That is odd. Double-check that OmniFocus on the iPhone's version is 1.0.1. You can see this at the bottom of the Settings screen. (There was a problem with the App Store where some people thought they were downloading updates for OmniFocus but got version 1.0 again.)
 
I checked that before.....yes it is 1.0.1 (v77.6.0.102921).

I set it up via the email-link. The Desktop-Version is syncing without problems, but ask me about the untrusted server too. But with the Desktop-Version I can click on the yes/ok - Button...
 
I'm having the same error, I thought it was because the self signed certificate was expired, but I updated it and I'm still getting errors.

Here's the logs from successfull desktop sync
[25/Jul/2008:15:21:02 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:02 +0000] "PROPFIND /webdav/OmniFocus.ofocus/ HTTP/1.1" 207 456
[25/Jul/2008:15:21:02 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:03 +0000] "PROPFIND /webdav/OmniFocus.ofocus/ HTTP/1.1" 207 4591
[25/Jul/2008:15:21:03 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:03 +0000] "PROPFIND /webdav/OmniFocus.ofocus/ HTTP/1.1" 207 4591
[25/Jul/2008:15:21:04 +0000] "GET /webdav/OmniFocus.ofocus/20080725152101=iDNJbVGY25S.client HTTP/1.1" 200 998
[25/Jul/2008:15:21:04 +0000] "GET /webdav/OmniFocus.ofocus/20080725151539=iDNJbVGY25S.client HTTP/1.1" 200 998
[25/Jul/2008:15:21:04 +0000] "GET /webdav/OmniFocus.ofocus/20080725151419=iDNJbVGY25S.client HTTP/1.1" 200 998
[25/Jul/2008:15:21:04 +0000] "GET /webdav/OmniFocus.ofocus/20080725144014=iDNJbVGY25S.client HTTP/1.1" 200 998
[25/Jul/2008:15:21:04 +0000] "GET /webdav/OmniFocus.ofocus/20080725143149=agtzH79x5ez.client HTTP/1.1" 200 1002
[25/Jul/2008:15:21:04 +0000] "GET /webdav/OmniFocus.ofocus/20080725133144=agtzH79x5ez.client HTTP/1.1" 200 1002
[25/Jul/2008:15:21:04 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:05 +0000] "PROPFIND /webdav/OmniFocus.ofocus/ HTTP/1.1" 207 456
[25/Jul/2008:15:21:05 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:06 +0000] "PROPFIND /webdav/OmniFocus.ofocus/ HTTP/1.1" 207 4591

And the failed iPhone sync
[25/Jul/2008:15:21:27 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 406 -
[25/Jul/2008:15:21:29 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:32 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:34 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:37 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:40 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:43 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:46 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:49 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:51 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:54 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:56 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:21:58 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:22:01 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:22:04 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
[25/Jul/2008:15:22:06 +0000] "PROPFIND /webdav/OmniFocus.ofocus HTTP/1.1" 301 259
 
Hmm. It looks like your WebDAV server is redirecting requests from "/webdav/OmniFocus.ofocus" to "/webdav/OmniFocus.ofocus/" (with the trailing slash), and apparently the desktop is handling that properly while the phone is not. I'm not sure why that would be.

We'll try to figure that out, but in the meantime…

If there's some way to convince your web server to serve PROPFIND requests without redirecting them to include a trailing slash, that might work around the issue (and would make all your syncs go a little faster).
 
Success,

Looks like the Desktop App can handle 301 redirects and the iPhone App can not.

I added the following to my apache 2 http config file
BrowserMatch ^OmniFocus redirect-carefully
BrowserMatch ^CFNetwork redirect-carefully

and now I can sync from both the Desktop and iPhone
 
I hope, you'll keep my problem in mind too. I cannot play around with the apache-config, cause I use Webdav at my provider. I could send them an email to ask for changing something. But I don't know if my problem is the same as that of hwatkins...
 
Bastain, your original post referred to OmniFocus 1.1, which is a desktop version - the iPhone version of OmniFocus is 1.0.1, and it has a certificate fix in it, so please let us know if you are using 1.0.1 and still seeing the problem. (You can check the version at the bottom of the Settings screen - you'll need to scroll down to be able to see it.)
 
I posted already, that I'm using the newest versions for Desktop AND Iphone. I posted the version of my Iphone-Version too. I could not post more, than I've stated before. The sync is working with the desktop (although it is a untrusted certificate I can press ok) but not with the iphone.
 
Sorry, I see now - it was in the third post in this thread, which I somehow overlooked initially. I must have keyed off the original "latest versions" comment, and we have _many_ people who tell us they are using the latest versions yet it turns out they didn't realize there were more recent versions that what they had, so it's kind of reflexive to confirm exactly what versions they are using so that we can compare - you did post that info, and I just overlooked somehow, and I apologize.

I don't know the answer to your problem, I'm afraid. If you haven't already, please send email to omnifocus-iphone@omnigroup.com so that the issue will get tracked and responded to more authoritatively. Please include information like what service provider you're using to host the WebDAV share,
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
"The certificate for this server is invalid." santra Bonjour sync 2 2010-12-14 04:44 PM
"Untrusted Root Server" error on Bonjour sync santra Bonjour sync 18 2010-11-16 03:31 PM
untrusted server certificate GaryArdito OmniFocus for iPhone 1 2008-07-31 05:08 PM
untrusted server certificate! jeremydb OmniFocus Syncing 7 2008-07-19 09:59 AM


All times are GMT -8. The time now is 10:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.