The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > iCal Sync
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
iCal task url not functional Thread Tools Search this Thread Display Modes
Hello,

I really like the url OF puts in to the iCal task when it syncs, but they are not working for me. When I click on the link OmniFocus opens, but focuses on a completely wrong, other part of my database without a task even highlighted. (When this works it opens the proper project with the task highlighted, if I remember right.)

What is weird, is that some url's worked for me this morning (after not working yesterday), but now they all go to the same project no matter what project the tasks are actually in. (It was the same thing yesterday, but went to a different project all the time.)

Is something going on with this handy feature? Any ideas?
 
I have this problem too. Use Help --> Send Feedback to report the bug.
__________________
Cheers,

Curt
 
My suspicion is that the URL is actually fine, and you're tripping over a very annoying OF bug involving window creation when you've got a window focused on a project.

In my experience, if you do have a window in the stack somewhere that is focused on one or more projects, when you do a New Window command, either explicitly or implicitly (by opening a URL from Growl, iCal, etc.), you get a copy of that focused window, even if it isn't the top one on the stack. Murphy's Law pretty much ensures that the project you want will not be in the scope of that focused window, and so it won't be able to take you directly to the action in question -- you'll just get a window that leaves you wondering what is broken. I've been reporting this bug to Omni for months, and I find it quite demoralizing that it appears they may be willing to ship a second release of the product with this bug present.
 
That doesn't describe what I'm seeing. I have a single OF window open and not focused. Links to OF still fail to target the correct item.
__________________
Cheers,

Curt
 
Okay, then there are multiple ways to lose here. Job security for Omni engineers :-)

When I'm not having that bug I mentioned, the test links I put in work (I don't normally use the feature).

What happens if you copy a link from one of the offending items to something that will let you see what the URL is? Do you get a different URL than the one stuffed into the iCal event?
 
This is completely independent of iCal. I can Copy As Link from OF and paste into the Safari address bar, for example. Some links open the correct item, others don't. I haven't experimented with it much, link backs have been too buggy to bother with. I've reported bugs and not yet seen mention of fixes in the release notes, so I'm just waiting on it. Frankly I don't have much need for the feature, so I haven't been too bothered by it. Most annoying is that Growl notifications don't link back.
__________________
Cheers,

Curt
 
Quote:
Originally Posted by curt.clifton View Post
This is completely independent of iCal. I can Copy As Link from OF and paste into the Safari address bar, for example. Some links open the correct item, others don't. I haven't experimented with it much, link backs have been too buggy to bother with. I've reported bugs and not yet seen mention of fixes in the release notes, so I'm just waiting on it. Frankly I don't have much need for the feature, so I haven't been too bothered by it. Most annoying is that Growl notifications don't link back.
That's odd -- I have found linkbacks to projects and their actions to be 100% reliable except where that focus bug comes up. I use dozens of them each day from Growl. Links to Inbox items don't work properly, however.

Do your bad linkbacks select the wrong item, or not select anything at all?
 
Next time you have a bad linkback, try rebuilding your database and see if the bug persists. The linkback seems to be the task id in the XML file, so it is rather surprising that it could get it wrong...
 
Yes, its a little counter-intuitive to have to clear your focus when the point is to focus, but you have to make sure to do this before you try to use the link-backs, I have discovered. I have to make sure to clear the focus by invoking, "revert to default view" before attempting to use the links no matter what state OF is in.

Even when I have closed all the windows that utilized a focus this problem persists since opening a new window would reveal the focus is preserved. In fact, even if I invoke a different perspective (which you would think would clear the focus) the focus remains in the background and screws up the link back. If you see any focus in a window a link takes you to, this problem is present, I would think.

This is a known bug and omni ninjas have told me the are on it.

Now the good news, using perspectives does not seem to trigger this bug for me even when they involve a focus. So, if you just create a slew of perspectives to focus on those folders you commonly look at then you won't have problems with the linking. I normally do this anyway. So, I was very happy to see this bug did not effect perspectives.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
item counts - not functional in dock? JamesX OmniFocus 2 for Mac (Private Test) 1 2013-05-06 07:33 AM
Functional Significance of Parallel vs. Sequential Shotster OmniFocus 1 for Mac 6 2007-11-27 08:19 PM
functional questions mims OmniPlan General 6 2007-01-29 10:10 AM
UI glitch: shift-tab not functional in toolbar? urbanape OmniWeb Bug Reports 2 2006-05-25 03:32 PM
Fully Functional GMail darcy1b OmniWeb General 2 2006-04-03 12:09 AM


All times are GMT -8. The time now is 12:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.