The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

iPhone sync problem Thread Tools Search this Thread Display Modes
OF now rules my life but an upgrade to iphone firmware 2.2 has stopped my ability to sync. I'm on a MacBook pro and use webDav as a cloud sync database. Everything worked until i cleaned out my iphone and upgraded to 2.2 from 2.0, re synced with itunes and reloaded all my applications, including OF.

I can sync the mac to Swissdisk (50 mg free storage, great alternative to mobileme) as per before, but when iphone OF starts up I get the set up sync or make new database option. I can send the details from my Mac to the iphone, it shows my user name, chose that and the screen turns to a progress bar that says preparing to sync, then turns back to the set up 'sync with mac screen'. no sync.

I have re downloaded and re installed the iphone app, I have tried the manual option same result. I have checked that the mac is sync'ing with the webdav swissdisk, all good. I have run out of options and can't get back to my new found efficiency with GTD and OF on my mac AND iphone.

Desperately need help, thanks.
I'm really sorry for the trouble this is causing! It sounds like the iPhone OS upgrade nuked your OmniFocus data, which isn't supposed to happen - that's definitely not normal, but apologies nonetheless.

Based on what you're describing, my guess - and this is only a guess - is that there's a typo in the user name or password for your swissdisk login, and OmniFocus is stuck in a loop using the bad login info.

I think there's an easier way to un-stick things - the support ninjas would know for sure - but I believe the following steps should resolve it as well.

In OmniFocus' settings screen, scroll down to the sync settings.
Tap "advanced", then enter "" into the "Location" field.
Tap "Done", then tap the sync button.

Your phone will attempt to contact our server for a sync; we'll prompt the phone to ask you for a new login and password.

Type in random gibberish for the user name and password - the point here is that we want our server to send you a 'bad password' response. (Do not type in the user name and password of the account you're actually trying to sync with; we could read that data.)

In any case, when the password sheet comes down a second time, tap "Cancel".
Switch the sync settings back to their normal values and start a sync.

You will be asked for the user name and password; you can now enter the new info you want OmniFocus to use.

Please do me a favor and contact the support ninjas about this, even if the above fixes the problem for you; there's a feature request I'd like to attach your email to. (And if I guessed wrong about what's causing your problem, they'll be able to get you back up and running.)

Last edited by Brian; 2008-12-10 at 03:16 PM.. Reason: correct a typo
Thanks for that Brian, did that but instead of asking me for my username and password swissdisk kicked back a ...
returned "internal server error" (500) in response to a request to "PROPFIND /jamieburr/OmniFocus.ofocus".
Any last potential gems of wisdom before I try the support people. (appreciate your efforts)
update, totally removed iphone OF, re booted, removed copy from itunes, re booted, re downloaded OF, re installed OF on iphone and setting up sync asked me for the passwords. Yee haa, back in the world of all systems go, back on track, Houston rest easy!
Thanks for your help, it was the password that was incorrect somehow and it was looping. Just a total removal and reload removed the saved settings. Thanks.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sync Problem w/ iPad, iPhone okay Pfrazier OmniFocus Syncing 2 2011-08-17 10:51 AM
Sync Problem patjay68 OmniFocus for iPhone 3 2011-04-19 04:58 PM
Sync problem: Mac -> iPhone yes, iPhone -> Mac no miromosci OmniFocus Syncing 1 2009-09-14 10:05 AM
OF 1.7 Sync Problem? curt.clifton OmniFocus 1 for Mac 10 2009-08-29 12:10 PM
Sync with Mac problem DTSBYK OmniFocus Syncing 3 2008-10-05 02:52 PM

All times are GMT -8. The time now is 01:30 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.