The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > iDisk/MobileMe/.Mac Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

MobileMe "Root Transactions" problems [SOLVED: caused by iDisk syncing, see sticky.] Thread Tools Search this Thread Display Modes
Replying to my own post. I seem to have fixed things, so I wanted to share the result in case someone else is still having a problem.

First, I turned off sync on the desktop. Next, I copied the iDisk sync DB to a safe place and then deleted the original from the iDisk. I had to sync the iDisk to ensure that the old DB was really gone. Then I reset the DB on my iPhone (so it deleted that DB) and then used "rebuild database" from the file menu of the desktop version of OmniFocus. Finally, I turned on syncing on the desktop again, and everything appears to have worked.

Oh, then I went back to the iPhone and performed a sync. I may have made some changes when I was first messing with this, so the iPhone asked me if I wanted to use the local or server DB. I chose server, since I knew that was the one I had just fixed.

That's it.
I have yet to see any suggestion from Omni that they consider it a good idea to have MobileMe's iDisk sync feature turned on if you are using MobileMe as your WebDAV server. There have been problems reported in the past, and while it should work in theory, in practice, life hasn't always been so kind. OmniFocus communicates directly with the MobileMe WebDAV server, so as soon as a change is synced from OmniFocus, what MobileMe has and what your computer has are two different things, and a bug may cause overwriting new data with old.

If you don't really need to have a local copy of your iDisk stored on your computer (and if it is a desktop, you probably don't), you might give some consideration to turning that feature off.
Any progress? It is not 2009, April 23, and I am having this same problem. recurrently.
Originally Posted by jamesafoster View Post
Any progress? It is not 2009, April 23, and I am having this same problem. recurrently.
I think I found a fix.

Backup the database to a disk you can get at (not iDisk).

copy that .ofocus file over to iDisk.

Then sync to iDisk.

That repairs the corrupt folder and got me going again.
James, it sounds like you're having this problem. Check that post for more info on how to prevent the Apple's iDisk sync process from corrupting your OmniFocus database.
I installed and tested the new Apple iDisk app yesterday, and this morning, none of my devices can sync to MobileMe. I get this error:
Unable to synchronize database with server.

Unable to read document.

No usable root transaction found in[myusername]/Documents/OmniFocus.ofocus/.
This sounds like the issue that is caused when the iDisk sync is turned on, which I'm guessing the iDisk app does in some manner to the phone?

Still looking for a safe way to get my most recent db back...

I've got the iDisk application installed, and I saw this error message when I synced my phone this morning. I tapped OmniFocus' sync button again, though, and the sync completed just fine.

Just browsed my iDisk from the phone and was still able to sync OmniFocus. It looks like a one-time glitch to me (at least so far).

If you're still not able to sync, the steps from this thread should work just fine.
Still another one with what appears to be the same issue, but the sticky isn't resolving things for me.

I have two Macs and an iPhone, and my primary mac has 4 items in the Inbox (a couple added for testing purposes), and the other Mac/iPhone won't pick those items up.

Curiously, shifting to Bonjour, as someone else suggested, likewise didn't pick up the additional items in the Inbox, so this may be a different cause, though the effect is the same: I can't sync anything.

On iPhone, when I launch it, it creates a new, empty database, which I then set to sync, using the Server copy. At some point (seemingly after it syncs), the app crashes, and upon relaunch, it still contains the "old" version of the database (i.e. missing items in the inbox).

On the other Mac, I replace the database with the Bonjour-sync'd version and the additional items still don't appear.

At various times from various machines, I get errors like

Unable to synchronize database with server.
Cannot synchronize.
Client with identifier fIaV6aE33nD only refers to identifiers that are not locally reachable.

If I try adding an item to iPhone, I get an "unable to synchronize database with server. Unable to rad document. No root transactions found in..." etc. Canceling, quitting and restarting results in a new empty database, and round we go.

Curiously, rebuilding the "master" database, deleted those new items from the inbox. In fact, if I turn off sync, add a new item, quit OF (the item's still there) then "rebuild" the database, that item's now gone.

This is, as you can no doubt guess, rather frustrating, and I fear for my thousands of items. I have many previous backups, though it's worrisome that the more recent backups all are zero KB.

I need a guaranteed foolproof way to ensure my data is safe, at this point, and then I can worry about syncing.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
What's a "forbidden" or "403" error when syncing with MobileMe/iDisk? giessler iDisk/MobileMe/.Mac Syncing 19 2011-06-21 07:33 PM
Error: "No root can reach all tail transactions" sgiovannini Bonjour sync 2 2011-02-23 08:10 AM
Solving MobileMe/iDisk "Root Transactions" problems Brian iDisk/MobileMe/.Mac Syncing 0 2009-05-13 05:38 PM
"No root transactions found" error: Once more with feeling kklein OmniFocus 1 for Mac 10 2009-04-22 12:03 PM
OmniFocus dies with "no root transactions..." dialog box drjamesincandenza OmniFocus 1 for Mac 1 2009-03-19 01:18 PM

All times are GMT -8. The time now is 05:15 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.