The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Syncing Desktop Macs - Can't Get To First Base Thread Tools Search this Thread Display Modes
I'm having problems setting up syncing between two desktop macs. One doesn't seem to "take" the password, and the other doesn't see the shared dB over Bonjour.

Here's what I think I know:

1. According to Apple (Bonjour explanation), one doesn't have to "do" anything to get the macs talking via Bonjour. I network between them all day for many applications, with no issues. So the versions of Omnifocus should see each other over my LAN, without any input from me.

2. Both machines have active licenses. Probably not crippled in a trial version, but just fyi.

3. Sync Database Mac: When I go to Preferences/Sync/Bonjour/ "Keep the sync database on this mac" and attempt to enter a password in "set password," I press "OK" and immediately get a warning sound. "Set password" doesn't change . This suggests to me that the dB for syncing is not being built, which would explain why I can't see it from the networked machine I'm looking to sync to it (see below).

4. The networked machine, that I am looking to sync to the database, when I click the radio button to "Connect to an existing sync database" it gives no optons in the drop down. I think this is expalined by 3, above, and so this is expected behavior.

Both machines: ppc os x 10.4.9
OF 1.5 (release candidate 2)

Thanks
Kevin

Last edited by willard202; 2008-11-04 at 09:07 AM..
 
You may want to check and see if console.app has any additional information about what the error sound means. You'll find the app in your Utilities folder.

If you're having trouble getting your macs to see each other on Bonjor, you may want to check the firewall settings. Open System Preferences, select Security, and select the Firewall tab. You'll probably want to switch to "set access for specifc services and applications" and then use the Plus button to add OmniFocus to the list.

Once you've done that, set OmniFocus to "allow all incoming connections" - does that help?
 
Thanks for the response.

Console.app, didn't "report" an error. I recognise the sound as being a "whatever you just tried to do, didn't work" warning. That said OF has created a "Synchronization Data" folder, which is a sign of some movement by the application.

I'm in 10.4.9. There is no Firewall tab in preferences/security, but there is one in prefernces/sharing. So I think you are giving me directions for 10.5. I don't see any options for "Set Access for Specific Services and Applications." Firewall was actually off. :o

Any more thoughts or things to try would be much appreciated.
 
Hmmmm... yes, when you press the Set Password button, a sheet is supposed to slide down where you enter the password you'd like to enter. I misread your email earlier - you're not getting far enough into the process for anything to show up in bonjour, I think.

Question - is there a reason why you're running 10.4.9 instead of 10.4.11? It's possible that one of the changes added in the subsequent releases would cause this to start working correctly. (I have no actual information one way or the other, but it's a possibility.)
 
OK, so I am looking for the right behavior. A sheet does slide down, but the error comes after I enter the password and hit enter.

Just to correct my own report, I'm running 10.4.11 on the host database machine, but 10.4.9 on the syncing machine (the unreasonable loyalty to 10.4.9 is a concession to Digidesign's Protools which is running fine in that particular OS version on that particular machine and if it ain't broke don't fix it). But I do have other options for testing.

As you've confirmed, my main issue is not being able to build a dB to sync to, that narrows areas for investigation. I'll try in other machines with fresh OF documents. Maybe I have a corrupt application, need disk permissions or desktop repair etc. I'll report back my progress.

Thanks
 
Turns out it was a corrupt OmniFocus file. After I installed the app on a new machine and set sync in the preferences for a new blank default OF document, everything worked as expected.

I therefore went back to the original machine and master file and ran the various routines for fixing the file. This file began life in the OF Beta last year. My backups were 40k and the original file was 21mb, an indicator to me of an inherent issue with the file.

After running the "rebuild" and the "CoalesceDatabase.scpt", I still wasn't getting any joy with the sync. So I created a new file and re-imported my data via a revert to back-up - I think!! (This process is rather non intuitive). Suffice it to say, I got all my data back in.

Success. Seems like all is working fine. Thanks for the pointers.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Message: Replace data base and start syncing [A: contact support.] glen.saberton OmniFocus 1 for Mac 2 2012-10-09 03:32 PM
Not syncing from iPhone to desktop dustinschadt Syncing via Omni Sync Server 1 2012-07-17 09:32 AM
Syncing 11 Macs in one office? OmniCert OmniFocus Syncing 1 2011-08-08 04:45 PM
Desktop syncing? greybeard40 OmniFocus 1 for Mac 34 2008-07-19 09:41 AM
Iphone and desktop syncing can be done - LOOK here!!! greybeard40 OmniFocus Syncing 4 2008-07-13 02:48 AM


All times are GMT -8. The time now is 02:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.