The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Double @@ Signs Thread Tools Search this Thread Display Modes
When I sync to iCal, my tasks, for example @@Calls Foobar have double @@ signs. Why?
 
Hmmm... that's not something I remember seeing before, but I'm happy to help try and sort this out. To that end, can you provide a bit more detail on what you're seeing?

I'm guessing that you have "include each action's context in it's calendar item title" enabled in OmniFocus' iCal preferences. Normally, though, that setting takes the form of "Task Name [context name]" when exported.

If I'm reading your question correctly, you see the context name in front of the task name. I'm not sure why that's happening.

It may help if you can attach some before/after screenshots to the thread so we can see exactly what you're seeing.

The following would be helpful:
screenshot of an action in OmniFocus
one of the same action when synced to iCal.
one of the iCal pane of OmniFocus' preferences

Finally, can you look in the General pane of preferences and let me know if the "Show full hierarchy, using separator" box has been checked, and if so, what's entered in the text field to the right?
 
Brian:

I have attached the screenshots. I did not have the option Show Full Hierarchy checked. I do now with the ":" as the separator. Odd behavior.
Attached Thumbnails
Click image for larger version

Name:	context_screenshot.jpg
Views:	370
Size:	65.7 KB
ID:	1293   Click image for larger version

Name:	ical_screenshot.jpg
Views:	365
Size:	124.2 KB
ID:	1294   Click image for larger version

Name:	omnifocus_ical_pref.jpg
Views:	381
Size:	104.1 KB
ID:	1295  
 
Okay, I spent some time in our test lab and figured out what's going on here...

It turns out that the "include context" setting will automatically put an @ symbol at the start of the context. Presumably, this is meant to help differentiate the context from the action name, since iCal doesn't have a separate Context field for us to use.

In your case, since the context names actually start with an @, you end up with two of 'em when you export to iCal. I'm honestly a little surprised this wasn't uncovered/reported before, so thanks for letting us know about this!

I'll file a request against the iCal sync process. In theory, OmniFocus could check for context names like yours and not add the @ sign during export if one was there already.

In the meantime, though, the double @ signs may be unavoidable in iCal, unless the contexts are renamed in OmniFocus.

For what it's worth, I started off with my contexts named that way, but eventually removed the @ characters. Since OmniFocus has dedicated fields for action titles, project names, and contexts I found that I didn't need the extra character to remind me what was a context and what wasn't.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Double-click for Focus in New Window gone? [A: v1.9 changed to Option-Double Click.] bjornkri OmniFocus 1 for Mac 11 2012-05-17 10:52 AM
Project Folder Names have bad names (equal signs)?!?! dschargel OmniFocus 1 for Mac 3 2010-02-18 12:54 PM
Double click on tab bar = new tab? danielandrews OmniWeb Feature Requests 1 2009-03-09 10:20 AM
double spiral sharond OmniGraffle General 2 2008-01-28 09:28 AM
double helix sharond OmniGraffle General 3 2008-01-18 12:29 PM


All times are GMT -8. The time now is 01:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.