The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Bonjour sync
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Can't get OmniFocus to sync with iPhone [SOLVED] Thread Tools Search this Thread Display Modes
Web Disk is the right way to go. I think it has to go in public_html to be viewable to the outside world - typing in the path of my Web Disk in a browser doesn't make it show up.

I used https://yourdomain.com:2078/ in the sync settings. I found that the port was necessary.

I didn't copy any files to the Web Disk - OmniFocus did all that.
 
Fantastic. Well I now have my omnifocus database on my iphone which is a definite step forward. I put the Web Disk in the root directory, hopefully that isn't a problem (ie. on the same level as public_html, public_ftp, tmp, mail and etc folders)

So - the initial upload between OmniFocus on my iMac and the webDAV server went fine and the OmniFocus.ofocus file appeared on my webhost's server.

The iphone synced fine with the WebDAV server also, and all my lovely projects and lists appeared. So I made a couple of changes to the Omnifocus database on the iPhone, then synced it back to the WebDAV server.

However when I now try to sync these changes back to Omnifocus on my iMac - the orange "Sync" button in the top right hand side keeps on spinning round and round forever. >_<

Ah well - Looks like I will be waiting for Support to contact me.

Thanks for your help Jim :)
 
My hunch would be to try putting the Web Disk in public_html and seeing if that fixes the problem - the logic being that there must be a reason why it is set to that as default, and that the guys at cPanel wouldn't be so stupid as to make it unsecure.

Glad you're making some headway though.

I've had another email from OmniGroup:

Quote:
... we're seeing a lot of reports from users having trouble synching, and the only common thread so far is that they've all been using the 3GS. We're still investigating what would be causing this ...
So this looks like a problem with the iPhone app. Guess we have to wait and see - but now that I've got it set up, WebDAV is probably preferable to Bonjour syncing anyway.
 
OK, it turns out the problem isn't related to the 3GS, it's simply a bug with setting up syncing for the first time in OmniFocus 1.5 on iPhone OS 3.0. It doesn't happen all the time, but I was able to reproduce it in one out of three tries on my iPod touch.

The good news is that now that we've figured out how to reproduce the problem (at least once in a while), we've come up with a workaround (which we've also added to our FAQ):

Quote:
I'm having trouble setting up Synchronization in OmniFocus for iPhone 1.5 under iPhone OS 3.0. Can you help?

There's currently a bug in OmniFocus for iPhone that may prevent you from successfully entering your credentials when syncing. To get around it when setting up synchronization:

On the first launch screen, choose "Make New Database" (counter-intuitive, right?)
Go to settings and set up sync as normal.
Go back to the home screen, and if sync is spinning without prompting for a username and password, quit OmniFocus.
Relaunch OmniFocus, press sync and you should be prompted for a username/password.

Last edited by Ken Case; 2009-06-28 at 06:26 AM.. Reason: Noticed I'd missed a closing parenthesis
 
This workaround seems to be working for me. I'm a little frustrated I haven't managed to set up a fully functional webDAV server, but I'm sure bonjour syncing will be fine for my needs at the moment.

Thanks for the help guys. :)
 
Thank you for the fix. I, too, installed 1.5 on a new iPhone w/3.0 firmware and had the syncing problem. With the information from Ken's message, I was up and running in no time.

This forum thread was the #1 google match for "can't get omnifocus to sync with iphone", so it worked out very well :)

Thanks!
Doug
 
Hi there... I have tried everything from these forums and I can't seem to get sync still! I tried syncing then closing it down, then try syncing again...i get no prompt for password...and it keeps on spinning. I to have left it over night....I'm at whits end. This thread is as close to my problem as other ones....anyone else couldn't solve this?
 
Quote:
Originally Posted by Ken Case View Post
OK, it turns out the problem isn't related to the 3GS, it's simply a bug with setting up syncing for the first time in OmniFocus 1.5 on iPhone OS 3.0. It doesn't happen all the time, but I was able to reproduce it in one out of three tries on my iPod touch.

The good news is that now that we've figured out how to reproduce the problem (at least once in a while), we've come up with a workaround (which we've also added to our FAQ):
I tried this and it didn't work. The only consistent fix I've found is to turn the firewall completely off (allow all incoming connections) before attempting to sync using Bonjour/mac. I'd added OF to the exception list by clicking on the application found on the Mac - if there's another way to get the appropriate exception into the list, I don't know it, but would like to.

Edit: 4/30 - Now syncing fine, even w/o allowing "all access" at firewall, and without having to put iphone into Airplane Mode.

Edit: 5/5 - Once again, wouldn't sync until I allowed "all access" at firewall, then sync'd fine.

Last edited by macdaddy; 2010-05-05 at 08:56 AM..
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to sync w/Bonjour since iPhone Omnifocus update [SOLVED: Blocked by router.] Nutty87th OmniFocus Syncing 7 2010-04-29 01:44 AM
Sync issues on iPhone 3GS hardware [SOLVED] Brian OmniFocus for iPhone 4 2009-06-28 06:26 AM
>20MB OmniFocus File (4779 items) [SOLVED: iPhone hadn't synced] DamonC OmniFocus 1 for Mac 5 2009-05-15 01:32 PM
[SOLVED] Help! OmniFocus hangs; won't complete sync; etc. DragonDave OmniFocus Syncing 18 2008-09-04 01:57 PM
SOLVED: iPhone OmniFocus refuses to sync with WebDAV, authentication issue lazerfire OmniFocus for iPhone 0 2008-08-02 04:14 PM


All times are GMT -8. The time now is 10:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.