The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Email rule won't process Thread Tools Search this Thread Display Modes
The Apple email rule for creating new tasks from incoming messages is not processing although all my other three rules are processing correctly. The rule will process if it use the Message|Apply Rules command from the menu bar to correctly formatted messages. I have tried:

-changing the rule order
-uninstalling plugins
-deleting rule prefs
-recreating the rule from scratch using only the appleScript part

and nothing helps.
 
It's probably worth verifying that this is a problem on OmniFocus' side of the fence, so to speak. Remove the part of the rule that invokes the script and replace it with something that moves the message to a different folder or flags it or otherwise indicates that the rule was successfully invoked. If it still isn't happening, now you know it is a Mail issue and not something going wrong in the handoff to OmniFocus.

Is this something that used to work, and no longer does, or you've never had it working?
 
I guess it must be Mail because it won't process any rules for the subject line.

Any ideas while we are on the subject (I have never had it working). Could it have something to do with email mailed to myself???

Last edited by sgmiller; 2010-05-08 at 05:59 AM..
 
How exactly are you sending the email to yourself? Are you by any chance using an iPhone/iPod touch/iPad to do so? I have noticed that if you use one of those devices to send the email to yourself, and they are set up to read email for the account to and from which you are sending it, the mail rule will most likely not be triggered on the desktop. Apparently, this is because the sending device goes and checks for new mail while sending, and so the desktop Mail app is not the first to read the message and thus doesn't do any rule processing on it. What I have done to work around this is set up the mail processing on multiple accounts, and never mail to the account that I'm reading. You could also set up a gmail account that you don't read from the mobile device, only from the desktop, and send the email destined for processing there.
 
That was it....I created a new mail account just for receiving links sent from my Iphone and changed the OF rule so it would proc on all mail received to that account. The messages weren't being deleted from my Inbox so I changed the first part of the rule to "move message to Trash" rather than "Delete" and now it works great!

Thanks for the hand-holding.

Last edited by sgmiller; 2010-05-08 at 09:19 AM..
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
-- Ignore auto signature for email rule > Email @Help #Today $5min ccsimmons OmniFocus 1 for Mac 1 2010-06-11 10:16 AM
My way of processing email to OF on iPhone - inbox zero style (requires IMAP email) Casper TFG OmniFocus for iPhone 19 2010-04-18 01:40 PM
Thinking process for OF peteypolo Applying OmniFocus 1 2010-03-17 05:53 PM
Not seeing Actions created through Email rule dpowers OmniFocus 1 for Mac 3 2009-12-01 09:11 AM
Process vs. organize and dealing with your email inbox avernet OmniFocus 1 for Mac 6 2009-07-18 05:23 AM


All times are GMT -8. The time now is 05:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.