The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Launching OmniWeb brings up recent page, not designated Home Page Thread Tools Search this Thread Display Modes
[Moved from Bug Reports- sorry, I'm new here]
I've been using OmniWeb for Mac (OS 10.4.11) for about a month and love its ability to configure individual pages and its speed and superior page rendering ability. But yesterday a strange anomaly suddenly started happening.
Now when I launch OmniWeb instead of bringing up my home page, which has been the same site since I registered the browser, it keeps opening an eBay page that I was browsing for a time yesterday. Clicking the "Home" icon brings up the correct page. Is this a bug or is there an adjustment somewhere that would correct this?
 
Hello,
You can choose the startpage in preferences/general (command+,).
 
Quote:
Originally Posted by sangheeta View Post
Hello,
You can choose the startpage in preferences/general (command+,).
Thanks, Sangheeta; as I mentioned in my post, my start page is already set in Preferences.
With some noodling about I've located the source of the problem. While I was on the page that keeps coming up on launch yesterday I got curious about the "Workspace" option and managed to embed that page in Workspace. I even took a picture of it. Now I can't get rid of the entry. OmniWeb Help says you can delete Workspaces but the "Delete" button for Workspace is greyed out and I can't find another way to delete the page. There's nothing in Preferences that controls Workspace.
So now my question becomes: How do I delete an item in Workspace when the Delete button is greyed out (and why is it?)
 
You can try to create a new workspace and delete the previous.
 
Found the solution on my own:
Home->Library->Application Support->OmniWeb5->Workspace. Deleted "Default."
 
Hello,

Just thought I would mention that it sounds like you had a snapshot of your workspace taken. If you had closed all the open windows then selected "Take Snapshot" from the workspace menu things probably would have gone back to normal for you.
 
Quote:
Originally Posted by troyb View Post
Hello,

Just thought I would mention that it sounds like you had a snapshot of your workspace taken. If you had closed all the open windows then selected "Take Snapshot" from the workspace menu things probably would have gone back to normal for you.
Thanks for the tip. I'll keep it in mind in case I make the same mistake again.
 
This thread is close to what has been bothering me most about OW lately.

I am a very heavy user of Workspaces (apparently unlike the original poster). I almost always have one open that has at least 8 tabs. They sometimes take awhile to load, and there isn't much one can do with OW until they are mostly done loading.

This is a problem when one (re)starts OW and want to do something quickly. What one wants to do quick almost never has to do with what's in the Workspace that was open when OW closed, so waiting for the workspace to refresh is frustrating.

So, I want a global preference that says "when opening OW, always use 'start page = empty' (for fastest startup) no matter what the Workspace state was when it was last closed".

But, I can't seem to achieve this with any setting I've tried. I actually iterated with OW tech support on this awhile back, and their solution wasn't really a solution. (I don't think they fully understood the issue).
 
Quote:
Originally Posted by pgtratnyek View Post
So, I want a global preference that says "when opening OW, always use 'start page = empty' (for fastest startup) no matter what the Workspace state was when it was last closed".
This is entirely possible in OW, and there are two ways of accomplishing it, depending on if you have your Workspaces set to auto-save or not.

If they DO Auto-save:

When browsing, if you have a number of tabs open and you are going to quit OmniWeb, close all the windows before quitting. In other words, click the red button, (confirm that you want to close multiple tabs if OW asks) then when no windows are open, quit OmniWeb. The next time you start, it will open in a single window with just your homepage - where you can optionally set your homepage to blank in OW's preferences. The rule of thumb in this scenario is: If you quit with multiple tabs open then OW will open with those tabs the next time, but if you quit with no windows open OW will startup with only one tab open.

If you don't need OW to auto-save your workspaces:

Open OW's preferences, set the homepage to blank, start up a single window of OW and take a snapshot of the single blank page. Next, go to Workspaces > Show all workspaces and UNCHECK the option to auto-save workspaces. Then go back to OW's preferences and set the homepage back to where you want it. What you lose in OW saving your states between browsing sessions you gain in that no matter where you were when you quit, OW will start up with this single blank page.

Last edited by Brian; 2008-05-29 at 11:28 AM.. Reason: corrected a typo
 
Quote:
Originally Posted by owuser View Post
If the DO Auto-save:
Even if I used auto-save, this wouldn't be a real solution. Users rarely know, or have time to plan, what they will be doing next time they open their browser.

Quote:
Originally Posted by owuser View Post
If you don't need OW to auto-save your workspaces:
This sounds a lot like what support suggested, but it's pretty obscure, and doesn't work (for me, so far). Here's how I parsed the steps that owuser proposed:

1. Open OW's preferences, set the homepage to blank.
Check: This has always been my preference setting.
2. Start up a single window of OW and take a snapshot of the single blank page.
This isn't completely unambiguous, so I did what is most consistent with my workflow: With my current workspace active (two windows, 6-8 tabs each), I opened a new (blank) window and took a snap shot.
3. Next, go to Workspaces > Show all workspaces and UNCHECK the option to auto-save workspaces.
Check, this has always been my preference.
4. Then go back to OW's preferences and set the homepage back to where you want it.
No change here, I still want it to be blank.
Quote:
Originally Posted by owuser View Post
What you lose in OW saving your states between browsing sessions you gain in that no matter where you were when you quit, OW will start up with this single blank page.
Not surprisingly... When I restart I get the workspace I was working on, now with 3 windows, one blank one. :(

It seems to me that this is a fundamental interface design issue where OmniGroup and and users like myself are talking past each other. To me the most intuitive solution is that the start page preference setting should override ALL workspace settings.

Assuming not every one agrees, the obvious solution is the general preferences pane should have a check box option immediately below the start page radio buttons that allows one to specify which takes priority (the preference pane or the workspace settings).
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't set Home Page to a Blank Page Gopher OmniWeb General 2 2011-09-25 11:31 AM
How to set the home page? Omorfos OmniWeb General 5 2011-08-11 09:31 AM
Home page as soon as switched on Bruno de Malaisie OmniWeb Feature Requests 2 2009-08-02 11:07 PM
'Home page' preference? peterlemer OmniFocus 1 for Mac 11 2009-04-13 11:12 AM
Launching OmniWeb brings up recent page, not designated Home Page jwthomas OmniWeb Bug Reports 0 2008-05-26 11:36 AM


All times are GMT -8. The time now is 08:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.