The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

[SOLVED] Help! OmniFocus hangs; won't complete sync; etc. Thread Tools Search this Thread Display Modes
Can anyone help with this?

I've got OmniFocus on a desktop and an iPhone, with a local WebDav server setup (as per their instructions). Everything was working pretty good for quite a while UNTIL....

I got a recent update. Noticed that the iPhone sync was never completing. Then noticed that the sync on OmniFocus was trying to sync, but never seemed to start. Had to force quit OmniFocus, but then it would never restart (would just hang, gobbling up CPU).

Suspected that the DB was corrupt, so used Time Machine to pull one forward from a day or two ago. I also deleted the file from the WebDav area. OmniFocus started fine, and synced to WebDav fine. ONCE...

The second time I try to sync, the sync operation goes ALMOST to completion, then hangs. After that, I'm completely screwed again. I have to force quite OmniFocus, but then it won't restart again, and I have to recover the DB again.

Any suggestions? Weird voodoo magic incantations to do?
I've got the same problem, waiting for the next release..
LOL... Well, misery loves company, I guess. Just a shame it happened on a Friday. Probably no fix until at least Tuesday at the earliest. They should institute a "no releases on Friday in case we break something" policy...
Thank God you have the very same problem. :) This will be then hopefully fixed after all (but probably not before Tuesday indeed).

I have even dumped the preferences file and my perspectives, all the files from MobileMe, then reinstalled everything and restored from backup. The first sync went all right then the same thing happened: it got stuck just before the end.

However, before I restored my database from the backup I played with the sample database for a while. It synced perfectly to my iMac, MBP, iPhone, several times, including the changes I made. Maybe because this database was smaller?

I lost my trust in OmniFocus. It was like loosing a friend. A very sad experience. :(

Last edited by gaba; 2008-08-30 at 11:21 AM..
Also, it was quite strange that even the iPhone could not finish the sync. So maybe my database got corrupted somehow (this would explain why the sample database worked perfectly).

Going back to previous sneaky peek versions didn't help either.

I was even accusing MobileMe for a while, but I see now that DragonDave has the same problem on a local WebDAV server.

And the other thing: there is no way to quite OmniFocus once the sync started. There is only a [Don't Quit] button under the progress bar that represents the neverending sync. Unless there will be a [Quit Anyway] button there (which could gracefully kill the synchronization) the only way to quit OmniFocus now is to force quit it. Which probably doesn't help the integrity of the database either. :(
Everything was great until last nights download. It hung up loading the document and I had to force quit out. I then tried download various older versions, and they all do same thing. I found if I double click on a backup the program starts fine, but if I quit and try to start the program directly it hangs up again. I can't wait until Tuesday.
I don't think this applies to the problem we're seeing. I'm not only not syncing to the iPhone, but I've wiped out the file on the WebDav server and started completely fresh. So, I sync the first time, and it works fine. I sync again, and the sync locks up, preventing the app from shutting down. Which means I have to kill the app. Which seems to result in a corrupt OF DB, which means I have to restore from a backup....

Very frustrating....
Are you getting a beach ball of death? If the beach ball comes up, you can launch the Spin Control program (included with on your Developer Tools DVD) to take a sample of the program. Omni can use this sample to diagnose the problem.

Well, it's not really the beach ball of death. It's just that the sync never finishes (OF is still functioning for the most part). If you look in the OF preferences, it shows the progress bar for the sync operation. It's almost to the end, but never gets there.

And the logic within OF is that if the sync isn't finished, it won't let you quit the program. Seems reasonable, except that the sync never completes. You're stuck with having to force quit the program.

And once you do it, it seems like your DB is toast. When you start OF up, it gets completely locked up (now there is your beach ball of death), and never starts. That seems to be a more secondary problem, however (i.e. if they fixed the initial problem, we'd never get this far).

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
OmniFocus hangs during sync after updating to 1.9? carloszz8 OmniFocus 1 for Mac 4 2011-04-20 03:38 PM
Unable to sync w/Bonjour since iPhone Omnifocus update [SOLVED: Blocked by router.] Nutty87th OmniFocus Syncing 7 2010-04-29 01:44 AM
Can't get OmniFocus to sync with iPhone [SOLVED] jim0203 Bonjour sync 17 2010-04-28 11:07 AM
Sync Stopped Working Using Bonjour [SOLVED: Firewall on Mac blocking sync] ajgilbert Bonjour sync 4 2009-06-21 09:46 AM
SOLVED: iPhone OmniFocus refuses to sync with WebDAV, authentication issue lazerfire OmniFocus for iPhone 0 2008-08-02 04:14 PM

All times are GMT -8. The time now is 01:19 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.