The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Freezing and Force Quit Thread Tools Search this Thread Display Modes
Hi, All. I've been having trouble with OF freezing and then needing to use Force Quit before I can use it again. Is this a Lion issue?
 
Quote:
Originally Posted by OnliOmniFocus View Post
Hi, All. I've been having trouble with OF freezing and then needing to use Force Quit before I can use it again. Is this a Lion issue?
I've not seen this issue on Lion. You may wish to contact support.
 
It happens to me too, after starting up OF. I am convinced it's a Lion issue as it started happening only once I upgraded. Re-installing the app works for me as a temporary remedy, although I had my Mac database get corrupted once and luckily had a good copy on my server to restore. I sent Omni support a process sample a few weeks back, from the activity monitor when the app hung, I would recommend you sending in a process sample as well, the more info the better.
 
Thanks for your help.
 
I'm having the same problem almost every time I start OmniFocus: start up, force quit, start up 2nd time. After I force OmniFocus to quit, during the second startup I get a dialog box asking whether I want to restore the windows from my last session. I click no and then OF opens and works fine.

I began having this problem immediately after I installed Lion. I suspect it's due to Lion's Saved Application State.

Twice I tried closing all OmniFocus windows before quitting. Both times, the next time I opened it I had no problems. Also, one time I deleted the OmniFocus file in the Library>Saved Application State folder, and it subsequently opened without a problem.
 
I am seeing the exact same behavior OF hangs on the first attempt at opening, I force-quit it, I reopen it, it reopens asking me if I want to restore windows. I suspect it has something to do with having other apps in full-screen mode. I always have one or more apps in full-screen mode when I open OF. I think this is somehow confusing OF about how/where to open its windows. Just a hunch. I will try and investigate further.
 
We are trying hard to figure this out. The only pattern we've found so far is that some people can avoid it if they use "Quit and Discard Windows" instead of Quit. So it's likely something in OmniFocus fighting with Lion's attempt to restore windows.

If you are experiencing this, please contact our ninjas (omnifocus@omnigroup.com) so we can get more data to figure out why it's happening and how to fix it.

Thanks!
 
Just wondering if there has been any update on this problem? I tried the proposed solution of Quitting and Closing All Windows - didn't work. Here's the email I just sent to the support ninjas:

I just re-started using Omnifocus after a few years' hiatus (the to do list was never very long for a few years), and since starting up again I constantly run into hangs and delays - as if Omnifocus were frozen, but then I switch focus on windows or click the mouse around the OF window and eventually the program becomes responsive again (like 15-30 seconds later). I have only been using OF again since some time in February, and my backup database file is only 111 KB. I sync with my iPhone and iPad through Omni's free service, and those devices have basically not had any problems (one "could not execute xml" or similar error on the iPad, but a re-sync with the "overwrite local db with synced db" option fixed the problem). This hanging was happening 1-2 times a day, but since installing a new hard drive and reinstalling OF from scratch (everything was done manually - no Mac Migration Assistant) and syncing my db from Omni's free sync service, it seems to have become worse. I am running OS X 10.7.5, 8GB RAM on a 2.7 GHz i7 Macbook Pro with close to 200GB free on the HDD.

Any thoughts or tips? Thanks!
Jay
 
Do you typically have a number of OmniFocus windows open when this occurs? Have you sent the Omni support group the output of Sample Process in the Activity Monitor when OmniFocus is in this state?
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
v1.3 for iPad freezing freo73 OmniFocus for iPad 1 2011-06-13 05:14 AM
Freezing on open lori OmniWeb Bug Reports 3 2008-12-30 01:01 PM
OmniWeb Freezing xbandaidx OmniWeb General 2 2008-03-19 01:20 PM
Freezing, can't force quit. Chrelion OmniWeb Bug Reports 1 2007-02-10 03:11 PM
Force Quit + relaunch opened wrong workspace kballard OmniWeb Bug Reports 2 2006-05-12 02:38 PM


All times are GMT -8. The time now is 07:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.