The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > Other Omni Software > OmniPresence
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Issues connecting to Webdav Thread Tools Search this Thread Display Modes
Hi all, I'm very new to Omni and can't believe I hadn't found this software sooner!

I have setup OmniPresence which seems to working smoothly however, we have a webdev setup which we can access via https:// as well as via 'connect to server' but for some reason we get connection errors if we try connecting OmniPresence via the 'Pick a cloud location' service.

Has any one else had much luck with this?
 
It may be that your host doesn't fully support the WebDAV specification.

The specific error messages you're getting would be helpful. OmniPresence for Mac should be writing them to console.log, which you can access via the Console application in your Utilities folder.
 
Thanks dave_m, I will check this out. However, can you please tell me what the WebDAV specification is in the mean time?

Thanks
 
Metro, Wikipedia has some helpful info about WebDAV: http://en.wikipedia.org/wiki/WebDAV.

Note that there are many implementations of WebDAV, with varying levels of conformance to the spec. (I don't know that anyone completely covers the spec.) OmniPresence doesn't require the entirety of the WebDAV spec; the portions that we do require are fairly commonly - but not universally - supported. OmniPresence performs a compatibility test whenever a WebDAV account is added, to make sure it's actually compatible with what we need.
 
Thanks Andrew, I emailed support as well which they directed me to the guide for setting up WebDAV on OSX server but our department have a generic WebDAV setup on Window's.

Here are the logs if this can provide any help;-

NSLocalizedDescription = "WebDAV server failed conformance test.";
NSLocalizedRecoverySuggestion = "The webdav.domain.com
server returned \"not found\" (404) in response to a request to
\"MKCOL /files/username/OmniFileStore DAV Conformance
Tests/testReplacedCollectionUpdatesModificationDate:\". ";

Last edited by Brian; 2013-05-24 at 01:58 PM.. Reason: reduce quantity of quoted material for better readability
 
Sorry, but I don't know much at that level of detail; your best bet is to continue to email support.
 
Just to set clear expectations: the compatibility tests are intended to help a system administrator (or possibly a server software vendor) understand what's going wrong so they can address the issue on their server.

Our support folks will be happy to try and assist, but there are too many web servers out there (and too many ways those servers can be configured) for us to solve every problem.

If that's not possible, folks are welcome to set up an account on our server, or use one of the alternatives that are known to be compatible.
 
Quote:
Originally Posted by metro View Post
The webdav.domain.com
server returned \"not found\" (404) in response to a request to
\"MKCOL /files/username/OmniFileStore DAV Conformance
Tests/testReplacedCollectionUpdatesModificationDate:\". ";
Keeping the prior post in mind... at first glance, my guess is that "username" appearing in that error message means that OmniPresence is misconfigured. Unless the server you're trying to access actually has an account set up called "username", OmniPresence may be trying to access files in an account that doesn't exist.

(A 404 error is the server saying "I can't find the thing you asked me for"; accessing an account that doesn't exist could easily generate that response.)
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes



All times are GMT -8. The time now is 08:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.