The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
"Miscellaneous" project Thread Tools Search this Thread Display Modes
I searched a little and didn't see a definite answer to this issue, so hear it is:

I think I understand the idea of having a "Miscellaneous" category folder if I don't allocate a project name to a task (though I think it should be something I can turn off without affecting whether or not completed tasks in the Inbox get removed or not). The problem, however, is that if I create a new single task, the software is creating a new folder called "Miscellaneous" instead of just dropping the task in the already existing "Miscellaneous" category.

I'm attaching pics of the two folders and my data settings.

Thoughts?
Attached Thumbnails
Click image for larger version

Name:	Picture-1.jpg
Views:	331
Size:	33.7 KB
ID:	779   Click image for larger version

Name:	Picture-2-1.jpg
Views:	313
Size:	56.7 KB
ID:	780   Click image for larger version

Name:	Picture-3.jpg
Views:	298
Size:	66.7 KB
ID:	781  
 
You don't seem to have anything selected from the "Default List" pull-down. Have you tried selecting one of the lists there?
 
Quote:
Originally Posted by Lucas View Post
You don't seem to have anything selected from the "Default List" pull-down. Have you tried selecting one of the lists there?
You're right. I had changed the settings because of the problem with the duplicating "miscellaneous" folder. Below is a picture of what the settings were when I was having all the problems. Thanks.
Attached Thumbnails
Click image for larger version

Name:	Picture-1-1.jpg
Views:	294
Size:	50.5 KB
ID:	782  
 
Still happening. This is an example from today where I entered the task into my iPhone app under "none" for the project category, and it STILL syncs to my computer software as "miscellaneous". You can also see the screen shot of my software settings.

I'd love a straightforward answer as to how to solve this. I'm coming from Things software that just works... period. Hasn't been the case so far with Omni.

Help?
Attached Thumbnails
Click image for larger version

Name:	Picture-1-2.jpg
Views:	295
Size:	48.0 KB
ID:	783   Click image for larger version

Name:	Picture-2-2.jpg
Views:	291
Size:	45.6 KB
ID:	784  
 
I'm really confused about what you're trying to fix. I'm not sure if it is 1) you have two "miscellaneous" Single Action Lists and you're not sure why it is going in one or the other; or 2) when you enter something with no project, why it is going to miscellaneous.

If the problem is #2, then I'm quite sure that you want to select the "A Project" or "Both a Project and a Context" on the data tab of preferences.

If the problem is #1, then I would first merge the two Single Action Lists that are both named Miscellaneous. I have less than no idea why you have two Single Action Lists with the exact same name. AFTER doing that, I would double-check that you have the Miscellaneous Single Action List selected in the Data tab of Preferences.
 
If I am interpeting the original post correctly, I think holritzphotography is observing that a second list called “Miscellaneous” is being created when a task with no project is created. The new task is placed in this second “Miscellaneous” list, rather than into the project with the same name that holritzphotography had already created (in accordance with configurations in Preferences).

What type of projects are your two “Miscellaneous” projects? (Select the project, open the Inspector, and click the Project icon. The button for Sequential, Parallel, or Single Action List will be selected). If the “Miscellaneous” project you created is not a Single Action List, that would explain why OF is creating another folder entitled “Miscellaneous”—the default title for the default Single Action List that is created by OF unless another Single Action List is specified. The default project for single actions must be a Single Action List—notice that in the drop down menu in Preferences, only Single Action Lists are options—which makes sense for tasks with no project. To have OF acknowledge your “Miscellaneous” project as the default for single actions, change it from Sequential or Parallel to Single Action List.

[It sounds like the user was inputting non-project tasks into a Sequential or Parallel project called “Miscellaneous”. Not having a Single Action List specified for non-project tasks, OF was creating a Single Action List called “Miscellaneous”, which was being used during synching. This would explain the two lists/projects. If tasks from the “Miscellaneous” Single Action List were moved to the “Miscellaneous” Sequential/Parallel project and the “Miscellaneous” Single Action List deleted, the behavior would repeat since OF would consistently not find a qualified Single Action List to serve as a default.]

Edit: The images do indeed show that both “Miscellaneous” lists are designated as Single Action Lists. Thanks for the catch, Malisa.

Last edited by kaijin; 2008-11-17 at 07:19 PM..
 
From the picture you can tell that they are Single Action Lists (blue shoe boxes).

Does it stop at two? Or will it keep making them and keep making them? Not that I have any idea why it's doing what it's doing, it's just something I want to know.
 
Does this only occur when you sync?
 
Remember that this is just beta software at the moment, so you shouldn't be expecting perfection.

Other than that, try keeping the new Miscellaneous folder and deleting the old one (move all undone and completed items first into the other, to preserve them). Does OmniFocus still try to create a new one?
 
I'm sorry for the confusion this is causing! You can correct this problem by doing the following:

Consolidate all the actions under one Miscellaneous list.
Change the name of the consolidated list to "New Miscellaneous".
Delete the empty miscellaneous list.
In the "Data" tab of preferences, check that the Default list for single actions preference is set to "New Miscellaneous" and not "Create when next needed".

If you're synchronizing with another Mac or an iPhone, please do the following steps.
(If you're not synching, you can skip to the "Finally" step, below.)
Sync with your server.

On each of the other macs, do the following:
Sync with the server.
Move any actions in a "Miscellaneous" project to the "new miscellaneous" project.
Delete any "Miscellaneous" projects in the database.
Set the default single action list preference to use "new miscellaneous" instead of "miscellaneous" or "create when needed". (It's in the "data" panel.)
Sync with the server.

Finally, once you have all the machines using the "new miscellaneous" project, you can remove the "new" prefix.

There are two causes of this problem. One would be the Data pane preference got set back to 'create when next needed' accidentally. Another possibility would be that two machines each decided to create a new miscellaneous project. Once they both synced with the server, you had two, and some of your machines were using one project as the default, while other machines were using the other.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
UI prob: app prefs say "autocomplete", project inspector says "don't". Former wins. MichaelJohnston OmniFocus for iPhone 14 2010-03-25 11:49 AM
Toggle from "Contexts" to the "Project the Entry belongs to"?? jkrytus OmniFocus 1 for Mac 1 2008-01-17 01:46 PM
Project context menu: "Complete" vs. "Completed" vocaro OmniFocus 1 for Mac 6 2007-12-11 09:18 AM


All times are GMT -8. The time now is 03:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.