The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Can't sync via proxy Thread Tools Search this Thread Display Modes
I've upgraded to 1.5.3, and still can't sync if I use a proxy.

I have a satellite ISP and find it very useful to run a caching proxy (Squidman) on my Mac Pro. I used to have no problem syncing Omnifocus on my laptop to the desktop using the proxy, whereas the iPhone sync would fail.

Now, however, both the iPhone (1.5.3) sync and laptop (1.7.3) sync fail with "Unable to synchronize database with server: there was a problem communicating with the secure web proxy server (HTTPS)"

OS X 10.6.1 on both laptop and desktop, desktop holds the sync database, iPhone 3.1

Any ideas??

Regards,
David
 
Hello,

we have the same problem. In our company net we are using of course a proxy to access the internet. So this proxy is required to be filled in in iPhone network settings for the WLAN connection if we want to access the internet from iPhone.

As soon as this is done, the OF iPhone-Mac bonjour sync no longer works with your described error message on OF iPhone.

For any reason ??? OF on iPhone tries to access the Mac inside the LAN via the proxy.

As soon as you switch off the proxy setting on the iPhone, sync is working.

But this is no solution!!! I can't permenently switch on and off the proxy if I want to sync or want to access the internet from inside the company's LAN.

BTW: This was not a problem a while ago in one of the previous OF for iPhone versions :-(

Regards
Gerd

Last edited by Gerd; 2009-09-30 at 02:58 AM..
 
OmniFocus doesn't make any decision about whether to use a proxy server or not, unfortunately: OmniFocus connects to its sync server by asking the operating system to connect to the sync server's URL, and the operating system decides whether that URL needs to go through a proxy server or not. (So if the behavior changed recently, it seems most likely that it was caused by an update to the operating system or to the proxy configuration.)

I'm not sure what the rules are for manual proxy configurations (maybe everything goes through the proxy, including LAN traffic?), but if you use an automatic proxy configuration you could presumably solve this by adding an appropriate exclusion rule to the proxy auto-config (.pac) file, so it wouldn't send traffic intended for your local LAN through your Internet proxy server.

Hope this helps!
 
Hello Ken,

thanks for taking your time answering. Unfortunately there seems to be no way on the iPhone to define exceptions from the proxy access. However we'll give the automatic proxy settings a try.

Regards
Gerd
 
Hello Ken,

Unfortunately your reply is not consistent with my observations. Other apps on the iPhone can successfully work thru the proxy, at least for access to the WAN. For example, OzWeather (getting latest forecasts), Safari (browsing anywhere), Convert (getting latest currency info) and others.

In addition, OF on the Mac now has the problem, where it didn't before. While this also coincides with 10.6.1 on the Macs involved, I have had the iPhone problem well back into Leopard on the Macs, and 3.0 on the iPhone.

So I dunno what the problem is, but it happens only with OmniFocus.

Regards,
David
 
Quote:
Originally Posted by coldrick View Post
Unfortunately your reply is not consistent with my observations. Other apps on the iPhone can successfully work thru the proxy, at least for access to the WAN.
Oh, is your OmniFocus sync server on the WAN? If so, that's a different problem from the one Gerd was describing, where the sync server was on the LAN but its traffic was being directed through the WAN proxy server.

Are you able to access your sync server via Safari on the iPhone?
 
Going back to your original message…

Quote:
Originally Posted by coldrick View Post
I used to have no problem syncing Omnifocus on my laptop to the desktop using the proxy, whereas the iPhone sync would fail.

Now, however, both the iPhone (1.5.3) sync and laptop (1.7.3) sync fail with "Unable to synchronize database with server: there was a problem communicating with the secure web proxy server (HTTPS)"
Are there any additional details about the failure logged to the Console on the Mac? (You'll find Console.app in /Applications/Utilities.)

Are you still able to sync through the proxy server if you use an earlier release of OmniFocus? (You can download an earlier release from our Release Archive.) If so, it might help us pinpoint the problem if you could tell us the last release which worked / first release which didn't work.
 
Hello,

I guess we are not talking about the same thing. My Mac is in the internal LAN, my iPhone using WLAN also, so both could comunicate with each other without using a proxy. BUT for any reason OF on iPhone tries to access my mac via the proxy and uses the somewhat strange bonjour identifier, which is obviously unknown to the proxy and our firewall.

So I can understand that this is not necessarily related to OF and more a problem of iPhoneOS as Ken explained (I can't track down on my side if this problem starts with new release of OF or iPhone OS). And for this the workaround using .pac should be a solution. Unfortunately I wasn't able to convince my sysadmin setting this up until now...

However, many thanks for your support as I know it since ages. I still have my NeXTcube with your FrameMaker port in our showroom ;-))

Regards
Gerd
 
Sorry, I wasn't being clear. My sync server is on the LAN, not the WAN. So the problem is at least similar to Gerd's. I was trying to show that other iPhone apps have no problem going thru a proxy.

Corrected below - my bad:

For my laptop syncing to the desktop sync server, if I turn off the https: proxy, the sync works. If it's on, it fails. Note that the network pref has

"localhost, 127.0.0.1, 10.0.5.0/24" in the "Bypass proxy . . .". All network addresses are 10.0.5.x

The console error message if I don't turn off https:// proxying is below:

12/10/09 12:13:23 PM, 12 October 2009 OmniFocus[10055] sync terminated with error: {
code = 310;
domain = kCFErrorDomainCFNetwork;
userInfo = {
NSErrorFailingURLKey = "https://bigmac.local:49162/OmniFocus.ofocus";
NSErrorFailingURLStringKey = "https://bigmac.local:49162/OmniFocus.ofocus";
NSLocalizedDescription = "There was a problem communicating with the secure web proxy server (HTTPS).";
NSLocalizedRecoverySuggestion = "To change your proxy settings, open Network preferences, click Advanced, and then click Proxies. For help with this problem, contact your system administrator.";
};
}

Last edited by coldrick; 2009-10-11 at 05:26 PM..
 
Quote:
Originally Posted by coldrick View Post
Sorry, I wasn't being clear. My sync server is on the LAN, not the WAN. So the problem is at least similar to Gerd's. I was trying to show that other iPhone apps have no problem going thru a proxy.

Corrected below - my bad:

For my laptop syncing to the desktop sync server, if I turn off the https: proxy, the sync works. If it's on, it fails. Note that the network pref has

"localhost, 127.0.0.1, 10.0.5.0/24" in the "Bypass proxy . . .". All network addresses are 10.0.5.x

The console error message if I don't turn off https:// proxying is below:

12/10/09 12:13:23 PM, 12 October 2009 OmniFocus[10055] sync terminated with error: {
code = 310;
domain = kCFErrorDomainCFNetwork;
userInfo = {
NSErrorFailingURLKey = "https://bigmac.local:49162/OmniFocus.ofocus";
NSErrorFailingURLStringKey = "https://bigmac.local:49162/OmniFocus.ofocus";
NSLocalizedDescription = "There was a problem communicating with the secure web proxy server (HTTPS).";
NSLocalizedRecoverySuggestion = "To change your proxy settings, open Network preferences, click Advanced, and then click Proxies. For help with this problem, contact your system administrator.";
};
}
Sometimes we overlook the fact that we have at hand and it's well when we learn from our mistakes .
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sync through authenticating proxy mtnygard OmniFocus Syncing 1 2010-08-17 08:51 AM
OmniWeb and proxy settings BonafideBM OmniWeb General 4 2007-12-05 08:44 PM
Site-pref Proxy switching Lewisham OmniWeb Feature Requests 3 2007-07-25 05:07 PM
how to set a proxy? klassa OmniWeb Feature Requests 1 2007-04-04 11:15 AM


All times are GMT -8. The time now is 03:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.