The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Other WebDAV
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Sync works from office, not at home: how to debug? Thread Tools Search this Thread Display Modes
Hello,

I have been syncing OmniFocus between the desktop version and my iPhone for months now, without any problems. In this whole setup, nothing has been changed since the beginning. The WebDAV share is a password protected HTTP share, hosted at Dreamhost.

Syncing works correctly, both from my Mac and my iPhone, when the devices are connected to the company office network, but since a few days no longer from my home network.

I already called my ISP (Telenet in Belgium) to ask them if anything changed in their setup, e.g. regarding transparant proxy servers, but they state they don't use that, and also that nothing has changed in their setup in the last days.

Can someone suggest methods to debug/detect whether there is an intermediate server/proxy that is the culprit?

Below is an error I took from Console when trying to sync from my home network:

Code:
20/09/10 20:49:24	OmniFocus[1842]	sync terminated with error: {
    code = 7;
    domain = "com.omnigroup.OmniFocus.XMLData.ErrorDomain";
    userInfo =     {
        NSLocalizedDescription = "Unable to read document.";
        NSLocalizedRecoverySuggestion = "Unable to read the contents of \U201chttp://anonimized/omnifocus/OmniFocus.ofocus/\U201d.";
        NSUnderlyingError =         {
            code = 405;
            domain = "com.omnigroup.OmniFocus.XMLData.DAVHTTP.ErrorDomain";
            userInfo =             {
                NSErrorFailingURLKey = "http://anonimized/omnifocus/OmniFocus.ofocus/";
                NSLocalizedDescription = "Unable to perform WebDAV operation.";
                NSLocalizedRecoverySuggestion = "The anonimized server returned \U201cmethod not allowed\U201d (405) in response to a request to \U201cPROPFIND /omnifocus/OmniFocus.ofocus\U201d.";
                errorData = <3c21444f 43545950 45204854 4d4c2050 55424c49 4320222d 2f2f4945 54462f2f 44544420 48544d4c 20322e30 2f2f454e 223e0a3c 68746d6c 3e3c6865 61643e0a 3c746974 6c653e34 3035204d 6574686f 64204e6f 7420416c 6c6f7765 643c2f74 69746c65 3e0a3c2f 68656164 3e3c626f 64793e0a 3c68313e 4d657468 6f64204e 6f742041 6c6c6f77 65643c2f 68313e0a 3c703e54 68652072 65717565 73746564 206d6574 686f6420 50524f50 46494e44 20697320 6e6f7420 616c6c6f 77656420 666f7220 74686520 55524c20 2f6f6d6e 69666f63 75732f4f 6d6e6946 6f637573 2e6f666f 6375732f 2e3c2f70 3e0a3c2f 626f6479 3e3c2f68 746d6c3e 0a>;
                errorDataContentType = "text/html; charset=iso-8859-1";
                errorString = "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML 2.0//EN\">\n<html><head>\n<title>405 Method Not Allowed</title>\n</head><body>\n<h1>Method Not Allowed</h1>\n<p>The requested method PROPFIND is not allowed for the URL /omnifocus/OmniFocus.ofocus/.</p>\n</body></html>\n";
            };
        };
        "com.omnigroup.framework.OmniBase.ErrorDomain.FileLineAndNumber" = "/Volumes/Local/Users/Shared/kc/ReleaseProduct/Source/OmniGroup/Applications/OmniFocus/XMLData/XMLTransactionGraph.m:216";
    };
}
The real hostname has been replaced with "anonimized".

Greetings,

Ringo
 
Be sure to also contact the Omni support ninjas directly for help. Help->Send Feedback or call +1-206-523-4152
 
The problem has been rootcaused. My hosting company moved my sites to another machine and updated their DNS appropriately. It seems my router was still caching the old DNS entries. A reboot of my home router resolved it.

Ringo
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sync Failure - Then it works? nickbarbosa Syncing via Omni Sync Server 1 2013-02-01 08:50 PM
Sync only works manually... Verxion Syncing via Omni Sync Server 1 2012-08-17 11:24 PM
Bonjour sync works at home, not at work leingang Bonjour sync 5 2010-09-02 10:00 AM
Sync failure for Office-iPhone-Home scenario chidmf OmniFocus Syncing 53 2008-08-06 04:12 PM


All times are GMT -8. The time now is 12:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.