The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Omnifocus Embed Attachments - Mac & iPhone Syncing Woes Thread Tools Search this Thread Display Modes
Hi all,
First post, hoping anyone can assist.

Loving Omnifocus which I have for my mac and my iphone, but it is not without its quirks.
I have been on to support directly with regard to small attachments to tasks (plain text files & simple excel and PDF files > all well under 50 - 80kb). They told me if I embed the file instead of linking to it, it will show up as a read only file on my iPhone, which is fine by me. Once they told me how to embed I was set.
Now today, two major issues have cropped up after a few days of absolute sync bliss.

1 - Image attachments taken on the iPhone - Gone on Mac... but present on iPhone. Mac shows the file attachment icon on the far right, but there is no image file there to view when you expand it. Now, these images are, small, 480 x320 pixels, and were taken natively from within Omnifocus, so they are not too big, AND, they were visible clearly for days on my Macbook. I opened them in Preview just fine a bunch of times.
But today, nothing there. Like the database has somehow become corrupted?
For me, this is not good at all because I often create a task from an image using my iPhone and Omnifocus, and the text of said task is is simply "See image" or "Picture Task". The idea is to drop these in to the inbox and assign context et al at the sorting stage on the desktop.
Now I have about 10 similar task titles that are meaningless to me without the bloody image.
If they were gone on the iPhone i would, to put it simply, be screwed. Anyone know whats going on there? I don't want to inundate support directly with more questions, and I badly want this to work reliably.

2 - A bigger issue. Back to my embed files I mentioned at the top of this post. In Omnifocus for Mac, I have, attached, as an embedded file, a plain text document, attached to a task. Here is where I put my notes, I use the plain text file as it is linked to dropbox.
I was able to view the plain text file as a read only file on my iPhone. this worked for a few days fine.
I would amend the text file > Sync > review my amended notes in said text file (read-only) on the train home etc. I would get in to work, make more amendments on the desktop and sync again, review the read-only text attachment on my lunchbreak etc. After doing this for a few days, I dug in, and spent a good part of yesterday, amending a bunch of text files, saving and syncing.
Today however, ALL my changes and amendments in these plain text files from yesterday are gone. A good portion of a days work, just gone. They have reverted to an earlier state, like before yesterday or something. And they are not on my iPhone either.
Bottom line, sync screwed up royally here and I'm at a loss to explain it. This is an imperative function for me and if I cannot rely on it 1000% as one needs to do if this is a 'trusted bucket' I should go back to pen and paper.

Now, if you've gotten this far, thanks, I wanted to be as clear as I could be in the initial post, sorry if its a little long!

There's a good chance its user error. But it worked before, now it doesn't and I really need to know whats going on as I can't trust the system as it is.

Any advice appreciated!
Thanks in advance,

weareborg.
 
Quote:
Originally Posted by weareborg View Post
1 - Image attachments taken on the iPhone - Gone on Mac... but present on iPhone. Mac shows the file attachment icon on the far right, but there is no image file there to view when you expand it. Now, these images are, small, 480 x320 pixels, and were taken natively from within Omnifocus, so they are not too big, AND, they were visible clearly for days on my Macbook. I opened them in Preview just fine a bunch of times.
But today, nothing there. Like the database has somehow become corrupted?
For me, this is not good at all because I often create a task from an image using my iPhone and Omnifocus, and the text of said task is is simply "See image" or "Picture Task". The idea is to drop these in to the inbox and assign context et al at the sorting stage on the desktop.
Now I have about 10 similar task titles that are meaningless to me without the bloody image.
If they were gone on the iPhone i would, to put it simply, be screwed. Anyone know whats going on there? I don't want to inundate support directly with more questions, and I badly want this to work reliably.
I've had the library that handles uncompressing attachments get confused a few times on the Mac, with the result that the Attachments Window shows everything as being size 0 bytes, and not being able to view the attachments. Quitting and restarting OmniFocus cleared it up, with no damage to the database. Omni support can walk you through examining your console log and sending them anything interesting.
Quote:
2 - A bigger issue. Back to my embed files I mentioned at the top of this post. In Omnifocus for Mac, I have, attached, as an embedded file, a plain text document, attached to a task. Here is where I put my notes, I use the plain text file as it is linked to dropbox.
I was able to view the plain text file as a read only file on my iPhone. this worked for a few days fine.
I would amend the text file > Sync > review my amended notes in said text file (read-only) on the train home etc. I would get in to work, make more amendments on the desktop and sync again, review the read-only text attachment on my lunchbreak etc. After doing this for a few days, I dug in, and spent a good part of yesterday, amending a bunch of text files, saving and syncing.
Today however, ALL my changes and amendments in these plain text files from yesterday are gone. A good portion of a days work, just gone. They have reverted to an earlier state, like before yesterday or something. And they are not on my iPhone either.
Bottom line, sync screwed up royally here and I'm at a loss to explain it. This is an imperative function for me and if I cannot rely on it 1000% as one needs to do if this is a 'trusted bucket' I should go back to pen and paper.

Now, if you've gotten this far, thanks, I wanted to be as clear as I could be in the initial post, sorry if its a little long!

There's a good chance its user error. But it worked before, now it doesn't and I really need to know whats going on as I can't trust the system as it is.

Any advice appreciated!
Thanks in advance,

weareborg.
The way the embedding of files works is not really conducive to editing them unless you are very meticulous and understand exactly what is going on behind the scenes. When you embed a file, you make a snapshot of it as it stands at that point, but there is no link to the file embedded, so if you make changes to the file you embedded, they will not be reflected in the copy inside OmniFocus. I'll write more later this afternoon, but my recommendation would be instead use something like Dropbox to store files that you intend to change, and only embed static documents. Or, when you want to make some changes, do a File->Save As operation to save the finished work, and re-embed that file. If you've been saving the file to Dropbox as you say, you should be able to use the version history feature in Dropbox to recover your lost work.
 
whpalmer4, thanks so much for your speedy reply! The dropbox version history option (which I wasn't even aware of) just saved me a bucket load of work. THANKS!!

I restarted Omnifocus and the images were back again. So thanks for that help also.
Still, I would consider this a bug that needs to be resolved, so I'll get on to Omnifocus about console log if it happens again.
I do get what you mean about the nature of the embedding. Not ideal but I know now how to work around it. I would honestly have thought that the software could manage to update the embedded file if the location of said file doesn't move?

Thanks again! I really appreciate it.

wab.
 
Quote:
Originally Posted by weareborg View Post
The dropbox version history option (which I wasn't even aware of) just saved me a bucket load of work. THANKS!!
Glad to hear it! That's one of the killer features of Dropbox, and I show it to everyone when telling them about Dropbox. If you are using the free version, the history only goes back 30 days, but that's still pretty good.
Quote:
Still, I would consider this a bug that needs to be resolved, so I'll get on to Omnifocus about console log if it happens again.
I agree that it is a bug. You should go ahead and send them email with Help->Send Feedback describing what happened. I seem to be kryptonite for software, but if they see reports of others encountering the same problem it might get some attention sooner than if I'm the only one reporting it.
Quote:
I do get what you mean about the nature of the embedding. Not ideal but I know now how to work around it. I would honestly have thought that the software could manage to update the embedded file if the location of said file doesn't move?
It certainly would be possible to make the software do that, but I would argue that it wouldn't necessarily be desirable to have it do that. An option to control whether it did that would be fairly esoteric, and Omni tries to keep the option set that a new user has to confront reasonably small (rightly, in my opinion). If it is relatively plain text, one could keep it directly in OmniFocus in the note field and not have to worry about the embedding. You do get RTF text in the notes. Unfortunately editing on the iOS clients will cause the formatting to be lost.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
iPhone Omnifocus: how to see attachments? mlevin777 OmniFocus for iPhone 5 2011-03-11 03:28 PM
Omnifocus for iPhone not syncing to MobileMe JDog iDisk/MobileMe/.Mac Syncing 1 2010-12-14 05:06 PM
iPhone Internet Tethering = USB syncing to Omnifocus y011 OmniFocus Syncing 2 2010-02-23 10:24 PM
clip o tron embed or link to file attachments? A to the B OmniFocus 1 for Mac 2 2010-01-10 04:32 PM
repeating action start/end times syncing woes Quorcork OmniFocus Syncing 2 2008-09-27 12:19 AM


All times are GMT -8. The time now is 08:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.