The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > iCal Sync
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OF -> iCal not working Thread Tools Search this Thread Display Modes
Nothing in OF is showing up in iCal (I ran a sneaky peak a long time ago so maybe old data is gumming up the works? I removed everything in App Support and started over again but still no love). Also, in another thread someone suggested removing subscribed calendars fixed it for them. Tried that and a lot of old stuff that was long since marked complete in iCal showed up in my OF inbox suddenly but nothing in OF went to iCal still.

So... I'm at a loss. Anything else I can try?

-A
 
Just a thought ... Since you haven't used OF in a while, there's a new sync preferences panel where contexts are mapped to calendars.
 
Yes, I already mapped them to appropriate calendars.
 
Same here, action items in OF do not show up in iCal. Yes, I mapped OF context to iCal calendar.

/Markus.
 
When I first opened OmniFocus and tabbed to the Sync pref pane I saw a slew of old, previously deleted calendars. After a little digging I found this article outlining how to reset the SyncServices folder and that cleared up the old calendars problem. For others having this problem all you do is open terminal and paste in this command.
Quote:
/System/Library/Frameworks/SyncServices.framework/Versions/A/Resources/resetsync.pl full
Unfortunately after clearing out all the kruft, OmniFocus won't sync. Nothing shows up in iCal. I have no idea if this issue existed before I reset syncservices since I didn't try beforehand, but I thought I'd include it just in case.

I'm also running Spanning Sync (which syncs iCal calendars to Google Calendar) and it's had its share of issues in 10.5 as well, but seems to be functioning fine right now.

EDIT: I uninstalled Spanning Sync. No change. Then I ran across this forum post which recommended assigning all contexts to a calendar. Still no change. iCal refuses to sync and I get no error message at all. OmniFocus seems to think everything is fine.

Last edited by pinotblogger; 2007-11-19 at 03:48 PM..
 
Same Problem Here....
 
Quote:
Originally Posted by pinotblogger View Post
When I first opened OmniFocus and tabbed to the Sync pref pane I saw a slew of old, previously deleted calendars. After a little digging I found this article outlining how to reset the SyncServices folder and that cleared up the old calendars problem.
That fixed the problem for me. Now OF <-> iCal is working just fine.

Thanks!

-A
 
@pinotblogger

Thanks I got it working after resetting sync preferences. This has been bugging me for a week now.
 
Tried all the above offerings and now get this:

Unable to synchronize with iCal:

Exception raised:
---------------------------
Name: NSInvalidArgumentException
Reason: This client (<ISyncClient 0x172e2aa0>{ INVALIDcom.omnigroup.OmniFocus type="app" name="OmniFocus" description file="/Users/allanmoult/Downloads/OmniFocus.app/Contents/Resources/OmniFocusClientDescription.plist" image="/Users/allanmoult/Downloads/OmniFocus.app/Contents/Resources/OmniFocus.icns"
sync state=(
<ISDSyncState 0x18b25150 [com.apple.calendars.Calendar]>{ last sync 6827 2007-11-22 07:42:20 +1100 status=2 enabled=1 wants pull Truth=0 sync mode=1 pull-only=1 push-only=0 refilter=0 properties=com.apple.syncservices.RecordEntityName , title, url, notes, read only},
<ISDSyncState 0x1597d390 [com.apple.calendars.Task]>{ last sync 6829 2007-11-22 07:42:23 +1100 status=1 enabled=1 wants pull Truth=0 sync mode=1 pull-only=0 push-only=0 refilter=0 properties=com.apple.syncservices.RecordEntityName , summary, url, description, completion date, due date, priority, calendar}
)
}) is no longer valid - perhaps it was unregistered by someone else?
Info:
(null)
Backtrace:No numeric backtrace found
 
I restarted twice and then things started working again, except all dates are a day behind, ie, 'today' events show up as 'yesterday' in iCal.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
iCal and MobileMe syncing not working gryphonent iDisk/MobileMe/.Mac Syncing 2 2010-10-03 07:45 AM
iCal Sync not working bmoorhouse OmniFocus 1 for Mac 3 2009-11-06 08:25 AM
iCal syncing not working!!!!!!!! Robster iCal Sync 1 2009-01-11 06:21 AM
iCal not working etcher iCal Sync 0 2007-12-12 06:23 AM
iCal Synch not working prider iCal Sync 4 2007-10-27 07:39 AM


All times are GMT -8. The time now is 06:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.