The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Old-format transactions must be upgraded before opening. Thread Tools Search this Thread Display Modes
I just upgraded to 1.1 in order to sync with my iphone and I'm getting this message:

Old-format transactions must be upgraded before opening.

When I first upgraded to 1.1, it told me of the new format, which I upgraded to, but apparently something went amiss. Any ideas how to fix this. The message is now popping up even when I'm not trying to sync.
 
Sorry, I forgot to mention. The header of the message reads:

Unable to read document

I'm not sure what document it is trying to read since OF is open and I'm using it (but alas not yet syncing with iphone)
 
I'm having the same problem. The notice pops up every minute or so. I've tried closing OF, discarding my updated database, and re-upgrading, but the problem persists.
 
Me too. Same problem.
 
I'm sorry for the trouble here, guys. Can you do me the favor of trying the following, then sending the results in an email to omnifocus@omnigroup.com?

We'll take a look at that information and try to determine what's going on here.
  1. Open your Applications folder, then the Utilities folder it contains.
  2. Launch the application named Terminal
  3. Paste the next two lines into the Terminal window, hitting Return after each.
    Code:
    cd ~/Library/Application\ Support/OmniFocus/OmniFocus.ofocus
    
    /bin/ls -C1
  4. copy and paste the results of the second command into an email and send it to the address I linked above.

I may not be the person that reads that email, so briefly describe your problem and/or point the support ninja at this thread. We'll use that info to try and determine what's going on here.

Again, very sorry for the inconvenience this is causing.
 
I have emailed the results from the terminal commands. I'm really hoping this will get resolved soon. I have so been looking forward having my OmniFocus actions on my iPhone. After suffering through Apple's 2.0 update problems this morning and now not being able to get my OF data down to my iPhone, I'm getting a little discouraged.
 
I hear what you are saying, but think of it this way. I wouldn't be nearly as anxious if I didn't use this program 12 times a day, which is a testament to how great the program really is. They'll fix it and get the sync working, and soon we'll wonder how in the heck anyone keeps track of their lives without Omnifocus and an iphone.
 
Hmm....

Ok, in hopes of getting something to sync. I've deleted all the files in ~/Library/Application Support/Omnifocus and reopened OF. It opened with the starter NAs (learn more about OF, merlin mann plug etc..) and after about a minute the error message came back.

I also tried to sync with my idisk, and then tried to sync my ipod with the data via the manual method, it prepared to sync, then failed with the same "unable to read document." message.

However, if I turn off syncing with idisk (by using the reset button, as all other options were greyed out), the message stops.

So syncing may be the culprit here, not nec. old data.

I'm ok with entering all my data by hand on my computer into the sneaky peek version if I could get it to work before I left work for the weekend.

Last edited by gofargogo; 2008-07-11 at 03:00 PM.. Reason: wanted to add info.
 
Ah ha! Updated to the latest (as of 4:45pm) sneaky-peek, and now when I turn on syncing it tells me of a particular item that needs updating:
Unable to read document. Old-format transaction file "root=99A135D5-AFDA-496A-B2F7-1D99CBD10D0D:1EF5EADA-8642-4953-B5DD-7CCA610BC01D.xml" must be upgraded before opening.
 
They added some code to collect additional info since they haven't been able to reproduce the error. Here is what I got after this evenings update:

Old-format transaction file "051A0CF3-293B-4769-A45F-2275243D365C:FFEB9BA9-36C2-403D-B62E-924216B8F1DD.xml" must be upgraded before opening.

I'll be running the console commands and emailing it in to support.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgraded document browser HappyCatMachine OmniGraffle for iPad 0 2012-05-01 05:10 AM
Upgraded and lost needed stencils. pbrunnen OmniGraffle Extras 4 2011-03-30 12:13 PM
No root transactions found epicurean OmniFocus Syncing 2 2009-01-14 03:45 PM
upgraded version of OF iPhone reports database reverted when sync lilyblossom OmniFocus for iPhone 4 2008-07-26 03:18 AM
upgraded to 1.0.2 and can't open my database! webalstrom OmniFocus 1 for Mac 6 2008-05-21 06:35 AM


All times are GMT -8. The time now is 10:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.