The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Bonjour sync
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Bonjour Sync says "sync in progress" but times out. [In Progress: See thread] Thread Tools Search this Thread Display Modes
Try this if you're using OS X 10.4 and Bonjour...
  1. Launch System Preferences in your Applications folder
  2. Choose the Sharing icon under Internet & Network
  3. Select the Firewall tab
  4. Click New

Enter this information:
Port Name: Other
TCP Port Number(s): 60000-62000
Description: OmniFocus Bonjour

Now try the normal steps to sync your iPhone.


Note: I'm not entirely sure what the port range it. It seems that the phone attempts to connect to ports in the 60,000 range till it finds one that's open. That makes it difficult to configure your firewall properly (and securely).

The Mac OS 10.4 firewall works by denying everything by default then allowing only specific incoming connections based on ports.

The OS 10.5 firewall, by default, allows all connections but restricts which applications can open ports. This is probably why 10.5 has fewer firewall issues than 10.4. Convenience at the cost of security.

Last edited by brains; 2009-05-09 at 09:49 AM..
 
Thanks for the attention, everyone.

No luck so far.

By the way, both the Mac, laptop and Mini, are running MacOS 10.5.6.

I meant to have said, the laptop is an iBook -- specifically, a 1.33 GHz PowerPC G4 ... but anyway, it syncs okay. I think the problem is between the iPhone and the Mini. Some of the suspects mentioned -- the firewall settings, some kind of password mixup, a local network misfire (wireless routers out the ying yang up in this joint) -- do sound plausible.

I did try syncing the laptop and the desktop computers and then syncing the iPhone right away. No dice.

For what it's worth, here are screenshots of what the iPhone shows me. The app does not quit -- it just stops trying to sync and shows an exclamation point in the middle of the little "sync" circular arrow icon at the bottom of the screen.

http://straightclaw.com/iSyncNot/IMG_0003.PNG

http://straightclaw.com/iSyncNot/IMG_0002.PNG

OmniFocus is generally working well for me aside from this. I can probably rock GTD when not at my desk with just a 5x8 pad of paper and an ink pen and tearing out sheets later and sticking them in a physical in box on my actual analog desk (made of an old door) and then processing that routinely. It's really about capturing and organizing. OmniFocus also nicely prints out little lists for the grocery store, hardware store, trips like that, as far as "doing". So ... later maybe for this iPhone extravaganza. I mean, it is still a kick ass phone, has Pandora, shows me the weather, keeps me from getting lost, takes nice pictures ... I love it.

I do think I will get WebDAV set up and sync everything to that (someday/maybe). Then all this local net confusion, firewall settings, etc., may not matter any more. From what I hear, that seems to work well for people. Then at that point try rocking OF on the iPhone again. But meanwhile I do have actual work that is flagged like "get this done if you want to get paid, my home dog," so ... train keeps a rollin.

Take er easy, dudes & dudesses. :)
 
Tredlite, based on what you're describing, it sounds like you're running into the password issue. Contact the support ninjas and we can help you resolve the problem.
 
Quote:
Originally Posted by whpalmer4 View Post
What version of Mac OS X are you running on the desktop machine? There were some problems fixed in the 1.6.1 release for 10.4 and Bonjour service in OF, so if you're running 10.4, make sure you've got the latest OF build. During the brief time I used Bonjour syncing with 10.4, I didn't encounter any problems, so I don't know if the bug(s) that were fixed caused behavior like you are seeing, but that would be an easy fix to adopt!
I have seen no evidence that this release fixes anything for OSX 10.4. I still have to turn off the Firewall manually to have any hope of syncing. It gets old fast.
:mad:

ninja are nice but only make suggestions that work with 10.5

Last edited by kbs1138; 2009-05-12 at 11:14 AM..
 
Quote:
Originally Posted by kbs1138 View Post
I have seen no evidence that this release fixes anything for OSX 10.4. I still have to turn off the Firewall manually to have any hope of syncing. It gets old fast.
Oh, your 10.4 firewall is configured to block incoming connections to OmniFocus on your Bonjour sync server? We can't fix that with a software update, but I think I can help you configure your firewall to stop blocking connections to the OmniFocus Sync Server.

First, you need to pick an unused TCP port for your incoming connections: 50042, for example. Step one is to make OmniFocus use that port for its sync server (rather than picking a new empty port each time you run it), which you can do by running this command in a Terminal window:

Code:
defaults write com.omnigroup.OmniFocus SyncServerPort -int 50042
After you've done this, restart OmniFocus and your Bonjour server should be running on port 50042.

The next step is to configure your 10.4 Firewall to allow connections to port 50042 from other machines. Open up System Preferences, click on Sharing, then click on the Firewall tab. On that screen, click the "New…" button, set the Port Name to "Other", add the port number you picked (e.g. 50042), and optionally set the description (e.g. "OmniFocus Sync Server"). When you've got that all set up, click "OK". You should now see "OmniFocus Sync Server" in your "Allow" list, and it should be checked (allowing incoming connections).

Does that help?
 
Quote:
Originally Posted by Ken Case View Post
... On that screen, click the "New…" button, set the Port Name to "Other", add the port number you picked (e.g. 50042), and optionally set the description (e.g. "OmniFocus Sync Server"). When you've got that all set up, click "OK". You should now see "OmniFocus Sync Server" in your "Allow" list, and it should be checked (allowing incoming connections).
Does that help?
Yes. It does, though the method had been described to me in an email a couple months before without the above step explained, it had not worked - seeming to initially and then failing. Maybe it seems obvious to some but the above crucial detail you gave was missing from the ninja instructions.

I had other iPhone apps that were using SyncDocs to create a port to communicate with so I was focused on using that to create an open port. Bit of tunnel vision.

Just now that this is finally figured out, I see a tweet that discusses free iDisk alternatives like SwissDisk. Using WebDav seems appealing. wondering about back up though, also wonder if it's one other the other, that using WebDav would not allow me to use Bonjour when home.
 
Okay, it just seemed too easy to try out the WebDav. Wasn't sure if SwissDisk free space was big enough, but figured I would try myDisk if it wasn't. My database is only 8 Mb, so got another 40 Mb of room if needed! That was pretty fast syncing on WiFi. Both my laptop and iPhone now synced to SwissDisk. :D

Doesn't seem however that I can save my Bonjour settings. :(
did Omnifocus delete the database I was using to sync through bonjour? What does the backup when I close Omnifocus mean now ?
what if I decide to go back to using bonjour ?
 
OF always keeps a local copy of your database, regardless of the sync method. You can switch between methods if you make sure to sync all your devices before switching. I would do it twice just to be sure everything was completely in sync.

When you switch things around, you'll probably get warnings about how the sync database and your local database don't appear to match. You need to be very careful about how you answer the "which one do you want to use" question. I believe OF does make a backup of your database when you switch, but I prefer not to test that portion of OF :-)

OmniFocus writes backups to the Documents/OmniFocus Backups directory regardless of your sync settings. In the OmniFocus preferences, the General pane, you'll find settings for controlling when backups are done. You may want to prune old backups occasionally, as the program doesn't do so at the moment (though it is an often-requested feature).
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Date Specific Actions & iCal Sync [See "Replacing Calendar Sync" thread.] jakobox iCal Sync 8 2011-07-22 01:07 PM
Sync tasks with due-dates to iCal-calendar? [See "Replacing Calendar Sync" thread.] tkaufmann iCal Sync 34 2011-02-10 03:25 PM
iCal Sync : Support CalDAV Calendars [See "Replacing Calendar Sync" thread.] darco iCal Sync 29 2011-02-07 04:01 PM
MobileMe Calendars break iCal sync [See "replacing calendar sync" thread] Scottn57 iCal Sync 25 2011-01-06 12:17 PM
Finally: An elegant way to handle tasks that are "in progress" (?) soundsgoodtome OmniFocus 1 for Mac 19 2007-11-06 02:27 PM


All times are GMT -8. The time now is 01:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.