The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
[FIXED] Crash on launch in OmniFocus 1.6.2 for iPhone Thread Tools Search this Thread Display Modes
Since the 1.6.2 version went up on the app store, we've received reports of folks getting stuck and crashing during the "Optimizing Database" stage. We're really sorry for the inconvenience these crashes are causing!

Thanks to your crash reports, we've identified that this problem is caused by a thread timing issue during launch phase and we will be submitting an urgent update to the App Store to fix this as soon as possible.

In the meantime, if your database no longer opens you can open this link on your iPhone to rebuild the cache from your stored transaction files. This will let you access your data again:
Rebuild Database
Unfortunately, this rebuild isn't a permanent solution. The thread timing issue still exists in the launch sequence and can put the cache into a bad state again during a subsequent launch.

We're terribly sorry this slipped through the cracks! It's very dependent on how many tasks you have, how many of them have start dates or due dates, how long it's been since the last time you opened the app, and how fast your device is.

We'll get a fixed build out as soon as possible; that will resolve the problem permanently.

UPDATE: OmniFocus 1.6.3 for iPhone is now available on the App Store; it fixes this crash.

Last edited by Ken Case; 2010-04-23 at 09:40 AM.. Reason: OmniFocus 1.6.3 fixes this and is now available
 
A bit more detail on what is happening:

First, it's important to know that the bug will not cause any data loss. The problem affects a cached copy of the information in the database, but it doesn't touch the underlying transaction files that cache is built from.

The bug happens when two normal parts of an OmniFocus launch both try to write to the cache at the exact same time. If the writes both happen at different times there's no problem; it's only when they overlap that the cache gets into a bad state.

The bug becomes more likely to trigger during a launch where a lot of start or due dates have passed since the last time OmniFocus ran. This is because one of the two things I referred to above is the "catch up with everything that happened while OmniFocus wasn't running" process is one of the two things I referred to before.

If it's been a long time since the last launch, or if there are more dates attached to actions in the database, there's a relatively larger chance of being affected by this.

Again, we're really sorry for the trouble this is causing!

Last edited by Brian; 2010-04-22 at 11:18 AM.. Reason: "since the last launch" -> "since OmniFocus ran"
 
OmniFocus 1.6.3 has been submitted to the App Store for review; we'll let you know when it's approved.
 
Clicked the link....
Safari can’t open the specified address.
Safari can’t open “x-omnifocus-debug:rebuild-database” because Mac OS X doesn’t recognize Internet addresses starting with “x-omnifocus-debug:”.
 
Quote:
Originally Posted by glewis76 View Post
Clicked the link....
Safari can’t open the specified address.
Safari can’t open “x-omnifocus-debug:rebuild-database” because Mac OS X doesn’t recognize Internet addresses starting with “x-omnifocus-debug:”.
You've got to do this on the iPhone or iPod touch or iPad...
 
Hi can somebody help me with this, I have the latest version but I can't pull up the application every time, it crashes. Can anyone tell me how to fix this bug. I badly need OmniFocus for work.

Many thanks.
 
Ken, unfortunately this doesn't work. In my case, I click on the link for "Rebuild OmniFocus Database" (on my iPhone), then I get a choice to "Invoke and Quit" (to run the script), and then OF on the iPhone crashes out again.

The only solution I've been able to find is to un-install OF and then reinstall and re-download the database (thank goodness for syncing to MobileMe).
 
Hi can somebody help me with this, I have the latest version but I can't pull up the application every time, it crashes. Can anyone tell me how to fix this bug. I badly need OmniFocus for work.

Many thanks.
 
Are you doing it from the iPhone? It won't open from the desktop.
 
OmniFocus 1.6.3 for iPhone is now available; it fixes this crash.

Last edited by Ken Case; 2010-04-23 at 09:41 AM.. Reason: Added a link to the 1.6.3 release notes
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
File Locations (recovering from crash on launch) timjbuck OmniFocus 2 for Mac (Private Test) 4 2013-04-05 08:53 AM
Crash at Launch; Lion and iDisk dancingbrook OmniFocus 1 for Mac 3 2012-07-05 02:48 PM
OmniFocus 1.5.2 crashes with iPhone 3.1 [Fixed in 1.5.3 update] niels OmniFocus for iPhone 23 2009-09-20 01:04 PM
OmniFocus for the iPhone wont launch unorder OmniFocus for iPhone 20 2008-10-03 12:11 PM


All times are GMT -8. The time now is 02:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.