The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Odd cut/paste behavior? Thread Tools Search this Thread Display Modes
Hi,

When I paste text into an OW multi-line text field, the insertion point jumps to the bottom of the text field, even if I've inserted the text at the top of the field. What's up with that?

Thanks in advance,



Steve
 
I don't understand. i just tried it, in this field (in OW and Fx).

Copied your post, pasted it. The cursor is at the end of the pasted block, just where it should be. I then put the text cursor at the beginning of what I pasted and pasted it again. The cursor is at the end of what I just pasted -- as is normal.
 
Um, that is the standard behaviour for any cut and paste action in the entire OS - the insertion point is at the end of the inserted item. (Or maybe I am misinterpreting what you are saying?)

Edit: Oops, should have refreshed the thread before posting... didn't see Handycam's response before I posted myself!

Last edited by JKT; 2007-02-12 at 01:02 PM..
 
Quote:
Originally Posted by JKT
Um, that is the standard behaviour for any cut and paste action in the entire OS - the insertion point is at the end of the inserted item. (Or maybe I am misinterpreting what you are saying?)

Edit: Oops, should have refreshed the thread before posting... didn't see Handycam's response before I posted myself!
Maybe I wasn't clear. (Okay, obviously I wasn't clear.) :D

Let's say these X's represent a block of some pre-existing text in a text field. If I paste in a block of text from the clipboard,at the position of the asterisk, above, the insertion point ends up at the position of the pound sign, that is at the bottom of the text field, rather than at the end of the pasted-in text. Is that clearer?

*
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX #

Thanks in advance,



Steve
 
Does this happen for all text fields or just particular ones? I haven't had this happen to me and pasting text in front of the asterisk will leave the insertion point just in front of that asterisk for me. No jumping to the hash at the very end of the text in the field.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd behavior in 1.6 jpbarr OmniFocus 1 for Mac 2 2009-03-18 01:32 PM
Alarm behavior... Tinchohs OmniFocus 1 for Mac 4 2007-12-22 12:02 PM
Click box behavior librarymonkey27 OmniFocus 1 for Mac 0 2007-12-09 06:58 AM
minor odd behavior Suzannah OmniOutliner 3 for Mac 0 2007-11-28 02:42 PM
Strange cut and paste behavior on Blogger jnv OmniWeb General 1 2007-08-16 01:21 PM


All times are GMT -8. The time now is 03:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.