The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Disappearing notes? Thread Tools Search this Thread Display Modes
I'm 99% sure this is not happening, but I want to put a stake in the ground:

Has anyone entered items (with notes) via Quick Entry, and discovered that they've disappeared later? Either the notes have gone missing, or the items themselves?

I'm pretty sure this is user error, and I'm just misremembering things: I thought I captured a note, and it turns out I didn't. It seems unlikely that this would be an OF bug.

But it sure seems to be happening a lot lately, so I figured I'd ask around.
 
I've been using OmniFocus heavily since September 2007 and I've never had any data disappear on me - no data loss whatsoever. That's including every pre-release sneakypeak build as well.

I'm not saying it couldn't happen, but in my experience OmniFocus is extremely reliable.

-Dennis
 
Jay,
The only thing along these lines that I've ever experienced involved an unexpected interaction between OF and another application that worked via Input Manager (TextExpander). You might want to check to see if you've got something like that going on.
 
The other thing that happens to some folks is that they accidentally switch to a view setting that is hiding some tasks and they don't realize it.
__________________
Cheers,

Curt
 
This does happen---I recently submitted a bug report about it.

I dragged a file into the notes and although the notes symbol was still visible, the dragged file went missing (I checked weeks later as I wanted to work on this task). I found the file in the OmniFocus.ofocus data directory, but it still doesn't show up in the notes.
 
Quote:
Originally Posted by kasi View Post
I found the file in the OmniFocus.ofocus data directory, but it still doesn't show up in the notes.
What's the "OmniFocus.ofocus data directory" you mentioned? Is that a directory inside the OmniFocus database bundle? I've never seen it.

-Dennis
 
Quote:
Originally Posted by kasi View Post
I dragged a file into the notes and although the notes symbol was still visible, the dragged file went missing (I checked weeks later as I wanted to work on this task). I found the file in the OmniFocus.ofocus data directory, but it still doesn't show up in the notes.
There was (is?) a bug where an attachment for a deleted action would remain in the database, but not accessible from the UI. So, the fact that the file was in the data directory does not necessarily mean that OF lost data. It is possible that either the action was deleted and recreated without the note, or perhaps that editing of the note was cancelled after the attachment was made. Of course, it's also possible that OF lost data, but I've never seen that even in the very earliest sneaky peeks of v1.0.
__________________
Cheers,

Curt
 
I just had a meeting, writing notes in the Notes field, and when I took a look at Omni back at my desk, it was all gone. I bolded lines that were important for me to remember...ugh.

Just wanted to note that it happened to me as well...You're not crazy. I'll have to try to look into the software conflicts some of you mentioned. Not sure what would be conflicting, but I'll try to do some research. I am running, AOL Instant Messenger, maybe that's it, I don't know. Other than that...iCal, FireFox, Photoshop. Unless it's something running in the background.
 
Quote:
Originally Posted by Lainie View Post
I just had a meeting, writing notes in the Notes field, and when I took a look at Omni back at my desk, it was all gone. I bolded lines that were important for me to remember...ugh.

Just wanted to note that it happened to me as well...You're not crazy. I'll have to try to look into the software conflicts some of you mentioned. Not sure what would be conflicting, but I'll try to do some research. I am running, AOL Instant Messenger, maybe that's it, I don't know. Other than that...iCal, FireFox, Photoshop. Unless it's something running in the background.
What, if anything, did you do in OmniFocus after making the changes to the note field? I have seen cases when creating a new note where it didn't get saved because I didn't close the edit. I can't reproduce it right now, but I know it has happened to me, and now I make a practice of always being sure to click elsewhere (thus causing OmniFocus to write that change out to the database) as soon as I think I might be done typing or otherwise editing something. My suspicion is that the missing stuff isn't being lost from the database, but rather never was entered into the file on the disk.
 
a-ha! I think that's likely what happened! Silly me. Thanks for the feedback!
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Best Practice Question: Notes Inspector vs Notes Layer atwoodsa OmniGraffle General 2 2011-08-10 09:01 AM
Losing data - notes disappearing kasi OmniFocus 1 for Mac 6 2010-08-20 02:54 PM
Favorites disappearing avilewis OmniWeb Bug Reports 21 2010-03-12 05:27 PM
Notes: Default View Em' Setting? Also, How are notes in the iTouch? 2 Pics Included. HappyDude OmniFocus 1 for Mac 10 2009-06-26 08:32 PM
Disappearing Actions EricW OmniFocus 1 for Mac 4 2008-02-18 06:28 PM


All times are GMT -8. The time now is 04:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.