The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Automatic update not working Thread Tools Search this Thread Display Modes
Since OF switched to using tbz2 my automatic updates do not work. The file is getting downloaded with an extension of .tbz2.txt and I have to rename it to remove the txt part of the extension. After I do that I can install the update manually.
 
Patricia - I jut updated the server so this does not happen.
 
Quote:
Originally Posted by Mindflayer View Post
Patricia - I jut updated the server so this does not happen.
Something's up, as the last several days of downloads are downing as .tbz2.bz2 , and OF gives errors when trying to open the file.
 
I just tried this and I'm not having any weird file naming issues. If this problem persists, please let us know whatever you can about your configuration (particularly if you are using any sort of proxy server, download accelerator plugin or whatnot). If any one else is hitting this, please let us know too!
__________________
CTO, The Omni Group
 
I have reported this via email previously (twice, in fact, in build 94313 (either bug #228382 (in the subject) or #205101 (in the body), and again for 94382 (#229109)). Here's the message that was generated automatically:

Code:
Error: Unable to open package.
Reason: (null)

Details:

{
    NSLocalizedDescription = "Unable to open package.";
    NSLocalizedRecoveryOptions = ("Report Error via Email", Cancel);
    NSLocalizedRecoverySuggestion = "Unknown package type.";
    NSRecoveryAttempter = <OFMultipleOptionErrorRecovery: 0x160a9400>;
    "com.omnigroup.framework.OmniFoundation.ErrorDomain.FileLineAndNumber" = "/Volumes/Disk/Users/Shared/omnibuild/ReleaseProduct/Source/OmniGroup/Frameworks/OmniSoftwareUpdate/OSUInstaller.m:71";
}
I can't think of anything on my system which would lead to this, as nothing's changed on my system or network in the last couple of months, and it happens regardless of where I download from (at work, at home, at a friend's, etc.)

Console generates a message "2007-11-19 21:42:08.317 OmniFocus[2505] Ignoring unknown track 'sneakypeak'" when I click "Check for Updates now" in Preferences, every time.

The file is written out as "OmniFocus-r94800-Alpha.tbz2.bz2" immediately (i.e. it's not being changed by something else).

I'm on 10.4.10
 
The error message in this case is just due to the mangling of the file name; so the real error has happened prior to this.

The message about the unknown track is due to a long-past error in packaging our OmniFocus release; it should be benign, but you can avoid it with the following in Terminal:

defaults remove com.omnigroup.OmniFocus OSUVisibleTracks

As to why the file name might get mangled; my only guess is that somehow Apple's downloader is deciding to rename the file. This could happen if the web server tells it to use a different file name than the original path used in the URL. If you are hitting our extremesims mirror, this shouldn't happen, but if you are getting a copy passed through a proxy server or some other mirror, then a server misconfiguration could cause this.

Beyond that, there might be come client side configuration that would cause this, but I'm unaware of what it might be, other than the options I suggested.

Has anyone else hit this problem and arrived at a solution? This is the first I've heard of it, but maybe someone else has...?
__________________
CTO, The Omni Group
 
I've added some configurable debug logging that will show up in v48.0.94931
(I just committed it, so it'll be a while before it shows up in the download list).

You should be able to do the following in Terminal:

Code:
defaults write com.omnigroup.OmniFocus OSUDebugDownload -bool YES
Then, launch OmniFocus and do a software update. There should be some logging
in /Applications/Utilities/Console.app that will maybe provide a clue as to where
this is going wrong.

Once you've gathered the logs, you can do:

Code:
defaults remove com.omnigroup.OmniFocus OSUDebugDownload
to make the logging stop.
__________________
CTO, The Omni Group
 
Thanks Tim. Here's the results. I've also sent this in via feedback.

Code:
2007-11-21 13:06:53.467 OmniFocus[6136] Ignoring unknown track 'sneakypeak'
2007-11-21 13:07:28.883 OmniFocus[6136] did begin <NSURLDownload: 0x16ac5250>
2007-11-21 13:07:28.974 OmniFocus[6136] will send request <NSMutableURLRequest http://downloads.extremesims.com/omnigroup/omnifocus/releases/OmniFocus-r94944-Alpha.tbz2> for <NSURLDownload: 0x16ac5250>
2007-11-21 13:07:29.255 OmniFocus[6136] didReceiveResponse <NSHTTPURLResponse: 0x16ad51e0>
2007-11-21 13:07:29.255 OmniFocus[6136]   URL http://downloads.extremesims.com/omn...944-Alpha.tbz2
2007-11-21 13:07:29.255 OmniFocus[6136]   MIMEType application/octet-stream
2007-11-21 13:07:29.255 OmniFocus[6136]   expectedContentLength 5149186
2007-11-21 13:07:29.255 OmniFocus[6136]   textEncodingName (null)
2007-11-21 13:07:29.255 OmniFocus[6136]   suggestedFilename OmniFocus-r94944-Alpha.tbz2.bz2
2007-11-21 13:07:29.255 OmniFocus[6136]   statusCode 200
2007-11-21 13:07:29.256 OmniFocus[6136]   allHeaderFields {
    “Accept-Ranges“ = bytes; 
    Connection = “Keep-Alive“; 
    “Content-Length“ = 5149186; 
    “Content-Type“ = “application/octet-stream“; 
    Date = “Wed, 21 Nov 2007 21:07:33 GMT“; 
    Etag = “\“828cbe-4e9202-43f76786ddf80\““; 
    “Keep-Alive“ = “timeout=5, max=100“; 
    “Last-Modified“ = “Wed, 21 Nov 2007 20:46:06 GMT“; 
    Server = “Apache/2.0.55 (Ubuntu) DAV/2 PHP/5.1.2 mod_ssl/2.0.55 OpenSSL/0.9.8a“; 
}
2007-11-21 13:07:29.446 OmniFocus[6136] decideDestinationWithSuggestedFilename OmniFocus-r94944-Alpha.tbz2.bz2
2007-11-21 13:07:29.458 OmniFocus[6136]   destination: /Volumes/Users/redacted/Desktop/Downloads/OmniFocus-r94944-Alpha.tbz2.bz2
2007-11-21 13:07:29.459 OmniFocus[6136] didCreateDestination /Volumes/Users/redacted/Desktop/Downloads/OmniFocus-r94944-Alpha.tbz2.bz2
2007-11-21 13:07:37.910 OmniFocus[6136] downloadDidFinish <NSURLDownload: 0x16ac5250>
 
Thanks; this should be fixed in 95000 and later.

I conversed with another user in email (unless it was one of you...). In their case the problem seems to involve a 3rd party utility (BetterZip, I think) that adds some type identifiers for these file. This convinces Apple's downloader classes to suggest the changed file extension.

Anyway; I've updated this to ignore Apple's suggestion and just use the original download name.
__________________
CTO, The Omni Group
 
Resolved! Thanks Tim.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Spell checking: Automatic by language not working anymore ozean OmniOutliner 3 for Mac 3 2012-03-20 02:57 AM
Lost badge counts after iOS 5 update [A: caused by update; re-enable in Settings.app] Warwick24 OmniFocus for iPhone 4 2011-12-22 01:53 PM
Automatic Layout with Automatic Re-alignment michael.prescott OmniGraffle General 0 2010-03-10 06:27 AM
Sneaky Peek update not working sperkinz OmniFocus 1 for Mac 7 2008-07-31 08:18 AM
New update function not working with non-admin account John Stalberg OmniWeb Bug Reports 1 2007-09-05 10:02 AM


All times are GMT -8. The time now is 12:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.