The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Error with Mail to OmniFocus Thread Tools Search this Thread Display Modes
Up until recently, the process of e-mailing myself via the "+omnifocus" command has worked flawlessly. Since the update to v1.6, the function no longer seems to work as described.

I've attempted to remove the rule and reset all items associated with the process (i.e. - Mail Clip-o-tron disabled, mail rule removed from mail, etc.) but the issue persists. I have detected several different logs in Console showing where the system starts the process -- but it consistently fails. The mail messages move to the designated folder but there appears to be an issue with the AppleScript command associated with the transfer of data from Mail to OF. Below is a snippet from the Console Log:

Quote:
4/7/09 11:55:19 PM 4/7/09 Mail[213] OmniMailMessageServiceEnabler registered
4/7/09 11:56:10 PM 4/7/09 Mail[222] OmniMailMessageServiceEnabler registered
4/7/09 11:56:15 PM 4/7/09 OmniFocus[219] Error executing operation:get_all_mailboxes with arguments '(
)' -- {
NSAppleScriptErrorBriefMessage = "The variable MyFullName is not defined.";
NSAppleScriptErrorMessage = "The variable MyFullName is not defined.";
NSAppleScriptErrorNumber = -2753;
NSAppleScriptErrorRange = NSRange: {3277, 10};
}
4/7/09 11:57:18 PM 4/7/09 OmniFocus[219] OmniFocus calling process_message in MailAction script
4/7/09 11:57:18 PM 4/7/09 Mail[222] An exception was thrown during execution of an NSScriptCommand...
4/7/09 11:57:18 PM 4/7/09 Mail[222] NSData* -[WebArchive data](WebArchive*, objc_selector*) was called from a secondary thread
4/7/09 11:57:41 PM 4/7/09 com.apple.quicklook[229] Tue Apr 7 23:57:41 Chris-Adcocks-MBP15.local quicklookd[229] <Error>: CgBI: unknown critical chun
4/7/09 11:57:41 PM 4/7/09 com.apple.quicklook[229]
4/7/09 11:57:42 PM 4/7/09 com.apple.quicklook[229] Tue Apr 7 23:57:42 Chris-Adcocks-MBP15.local quicklookd[229] <Error>: CgBI: unknown critical chun
4/7/09 11:57:42 PM 4/7/09 com.apple.quicklook[229]
4/8/09 12:00:01 AM 4/8/09 Mail[222] NSData* -[WebArchive data](WebArchive*, objc_selector*) was called from a secondary thread during invocation of -[MessageViewer _copyMessagesToPasteboard:deleteWhenCopied:pastebo ardType:alternateType:]
Stack Trace: (
(
2440933643,
2430123579,
2440933099,
2440933162,
2438465651,
2491628131,
1669253,
4841139,
1048667,
2440956477,
2440954920,
4801548,
4800494,
2474141677,
2474140564,
2421764245,
2421763922
))
4/8/09 12:00:11 AM 4/8/09 OmniFocus[219] NSShouldActivateForServiceRequest=NO
Any thoughts on how to get this resolved?

Of note: I did try "Dalite" (Application for task, project, calander, etc. management), but it was on the system prior to the upgrade to v1.6 OF and produced no issues.
 
By any chance did you install Safari 4? It has a known issue with Applescript and Mail that Apple hasn't fixed yet.
 
Quote:
Originally Posted by whpalmer4 View Post
By any chance did you install Safari 4? It has a known issue with Applescript and Mail that Apple hasn't fixed yet.
Good - call; yeah, I'm currently running beta 4. Just pulled it off and all is back to normal.

Thanks so much! I'm back in business!
 
I was having the same problem as cadcock. Ran the Safari 4 uninstaller, restarted my computer, and it works again. Yay!

@whpalmer4
Thank you! I would have never even thought that the installation of Safari 4 would interfere with mail processing between Mail and OmniFocus.

@cadcock
Thank you for posting the errors from withing your Console Log. That's what I used to search for an answer to my problem.
 
Mail uses the Webkit framework to render HTML messages, and apparently there's a bum change to Webkit in Safari 4 that upsets the apple cart...
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail, Omnifocus and Mail Act-On Pablofp OmniFocus 1 for Mac 0 2013-01-07 01:57 AM
Missing Omnifocus Mail Integration in Mail Version 4.3 (1081) cummins OmniFocus 1 for Mac 1 2010-07-12 04:01 AM
Error when you select send mail clipping to Inbox ksrhee OmniFocus 1 for Mac 5 2009-04-22 12:01 PM
Mail.app and OmniFocus Mail Rule chinarut OmniFocus 1 for Mac 0 2008-06-28 09:26 AM
Adding Tasks Via Send To OmniFocus Mail Rule, Mailtags, & Mail Act-On reuben OmniFocus 1 for Mac 0 2007-11-18 06:07 PM


All times are GMT -8. The time now is 04:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.