The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Extras
FAQ Members List Calendar Search Today's Posts Mark Forums Read

AppleScript that adds Waiting For emails from (delegated tasks) to OmniFocus Thread Tools Search this Thread Display Modes
thanks abroess! I'll be checking whether this works for me over the holidays. My outgoing mail script hasn't worked for months and I haven't had more than a few moments to figure out what happened. I miss it, so I'm very glad to see your fix...
Originally Posted by abroess View Post
The function "on perform_mail_action(theData)" is not longer working in Apple Mail on Mountain Lion. I found a workaround and
I have tried abroess' version of the script. It does not appear to be working for me. I do question whether "perform_mail_action" is not working in 10.8.2 as abroess states. I use Spamsieve's remote training drone. It invokes "perform_mail_action" and works as specified.

Is this script being used successfully by others running 10.8.2?

I am a neophyte when it comes to applescript. While I have been able to insert some diagnostic code, I have not been able to diagnose with any confidence as to why it is failing. It seems to be failing to get the data it expects and invokes it default error function.

Any suggestions? Or are people moving on to OmniFocus Mail Drop? Which does work but lacks tight integration with MailTags as well as Mail.
Originally Posted by Greg Jones View Post
This may be useful-a user on the DEVONthink forum just linked to this discussion on the Apple support board in response to a similar problem with a Mail script and DEVONthink. the link posted by Greg Jones above. It describes similar problems with 10.8.x. I'm having the same issues. If you run your script (send an email with the outbox rule firing) and then check Console, you will probably find an error message. If so...this is a bug in ML and I haven't found a work around yet...which doesn't mean there isn't one out there.

I also think this is a sporadic problem...because I think some users are still able to use this script successfully in ML.
Working now for me with 10.8.3 update!

This would be hilarious if it wasn't so frustrating. The script worked flawlessly last night after updating to 10.8.3. Today, after what I'm assuming is my computer shutting down for the night...I get the same console error...and the script isn't running again!! Unbelievable!

3/15/13 1:36:17.922 PM Mail[170]: Failed execution of AppleScript: /users/imac/Library/Application Scripts/ For Mails to OmniFocus.scpt
Error Domain=NSCocoaErrorDomain Code=257 "The file “Waiting For Mails to OmniFocus.scpt” couldn’t be opened because you don’t have permission to view it." UserInfo=0x7fb477c36440 {NSURL=file://localhost/users/imac/Library/Application%20Scripts/, NSLocalizedFailureReason=Script file is not in the application scripts folder.}
So...does anybody on the forums reading this have ANY idea why it would do this? Or better to fix it?
I first want to thank Beth, co-owner with her husband of Indev...the awesome developers of MailTags and Mail Act-on. She spent literally HOURS with me chatting back and forth online trying to figure out what was going on. We played with permissions, the console, terminal, etc. We tried all kinds of iterations of the setup. Ultimately she had me set up a new user account and run the script from there. It runs perfectly. Somehow, on upgrading to ML, my existing user profiles were corrupted. We tried to fix them to no avail. I'm currently in the process of updating this new profile to be my primary profile. I don't know if I'll be able to delete my initial primary profile, as it was the first profile I created on the machine...but I'll at least be able to get the script working and essentially deactivate the original profile.

Give it a try...maybe it will work for you too. And if it does...drop Indev a line and thank them for their time and great customer service.
Awesome, but i haven't tried it. Hope i will check it soon. Thanks !!!
I hope it works for you too...
Any idea why the message URL embedded into the action is invalid on my MacBook?

Other than that it works a treat!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to deal with delegated or "waiting for" actions bisimpson Applying OmniFocus 20 2013-02-27 06:52 AM
Delegated tasks? mattw OmniFocus 1 for Mac 35 2011-10-07 02:10 PM
Sync with Omnifocus on Mac adds completed tasks.. ohla313 OmniFocus for iPhone 7 2011-06-13 08:50 AM
Script to add delegated tasks from entourage to "Waiting" context in OmniFocus tarun101 OmniFocus Extras 1 2010-05-21 08:09 AM
Adding Tasks Via Send To OmniFocus Mail Rule, Mailtags, & Mail Act-On reuben OmniFocus 1 for Mac 0 2007-11-18 06:07 PM

All times are GMT -8. The time now is 05:33 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.