The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OmniWeb not working with Mongrel Thread Tools Search this Thread Display Modes
I'm working on a couple of Ruby on Rails apps and using Mongrel to deploy them.
While testing out OW 5.5, I've noticed AJAX support seems broken with Mongrel, which is giving me this error: "Invalid HTTP format, parsing fails.".

Given I know Mongrel uses a very strict HTTP parser which is 100% RFC compliant, I wondered if it isn't an OW issue.
 
Yes, I've noticed this as well on some older builds...the Ajax stuff in my apps worked on every browser except OW 5.5

Edit: Actually, OW doesn't work with the app under lighttpd as well, so I'm wondeing if it's something between the javascript library that Rails uses and OW or what. Like I said, no other browsers have problems with the functionality at all.

Last edited by toby@120db.com; 2006-07-18 at 06:43 PM..
 
Do your apps work with the same WebKit nightly that OmniWeb is roughly based off of?

<http://nightly.webkit.org/builds/WebKit-SVN-r13302.dmg>

Download and try the app contained within. If it doesn't work then you're probably seeing a WebKit issue that hopefully is fixed in more recent nightlies.

Last edited by troyb; 2006-07-19 at 10:15 AM..
 
nope, doesn't work in that version of the WebKit nightly either.
 
Okay, how about a more recent WebKit nightly such as:

<http://nightly.webkit.org/builds/WebKit-SVN-r15522.dmg>
 
The newer Webkit nightlies bomb out if you have any Safari extensions installed, and I'm not sure which ones I even have installed, let alone how to remove them all. I'm still looking into it.
 
Quote:
Okay, how about a more recent WebKit nightly such as:
Everything seems to work fine with recent versions of WebKit.
 
yes, i downloaded the most recent webkit nightly just now and removed the acidsearch extension that was making it bomb, and it works fine with the ajax apps now. will 5.5 have these latest versions?
 
Yes, we're going to hold on at the current version of WebKit we're at right now but we'll be following 5.5 up with an update containing a newer version of WebKit.
 
Quote:
Originally Posted by troyb
Yes, we're going to hold on at the current version of WebKit we're at right now but we'll be following 5.5 up with an update containing a newer version of WebKit.
well that's unfortunate, I won't be able to use it until that type of stuff gets fixed.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Recent 1Password versions no longer working on OmniWeb jwthomas OmniWeb General 11 2012-09-12 09:13 PM
Web colours not working correctly in OmniWeb? Steeve OmniWeb General 7 2009-04-01 03:59 AM
Adobe Reader 8 Not Working with OmniWeb webmacster87 OmniWeb General 10 2007-01-16 10:35 PM
Flash not alway working in OmniWeb 5.5.1 sebid OmniWeb Bug Reports 5 2006-11-28 01:43 PM
OmniWeb needs a good working ad blocker like PithHelmet uelef OmniWeb Feature Requests 14 2006-07-24 02:04 PM


All times are GMT -8. The time now is 08:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.