The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniOutliner > OmniOutliner 3 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Do unwanted styles appear in your outline? Thread Tools Search this Thread Display Modes
Everyone else no doubt knows this, but I just figured it out and maybe I can save someone else the confusion period in the future.

When text is pasted into a row, using ordinary Paste command, not only does the pasted text appear in the style of the "clipping" or copied text, but it creates a new style for subsequently added rows at that level and its children.
When I make a new row that is to the left of the one into which I originally pasted the text, then the overall style of the doc resumes.

To avoid this behavior, use Paste with Current Style, Opt-Shift-Command-V.

Maybe it is just me, but this seems backward. I'd like to have the option of choosing how this works, with the default being that the pasted material has its own style but does not affect the style of subsequently added lower rows.

For now I will try assigning an easier key stroke to Paste with Current Style.

Also, now that I knew what to search under, I found this addressed in a 2006 forum post, where Jacob offered advice including:

Quote:
As for the outline you're trying to clean up, I think the thing to do is, (1) MAKE A COPY (in case this is bad advice I'm giving), (2) select all the rows in the outline and select "Clear Style" from the Format menu. This will (I think) clear away all the formatting except what's applied to the whole document. Then you can select "All Level 1 Rows" in the styles pallette at the bottom of the utility drawer and use the Inspectors to set the formatting of your top level rows, then select "All Level 2 Rows", etc. etc.
and also in 2006 moderator Derek M responded to this question

Quote:
If I paste in some text that has it's own format, what is the easiest way to change it to the style of that row in my document. I'm not sure what "Clear style" is supposed to do, but that isn't it.
with

Quote:
This can depend on a couple things. If you have 'Automatic Level Styles' on under the Format menu, then the pasted styles can be promoted depending on the content of your file when you paste. If you want to know more about this, let me know.

The Clear Style command will remove any local styles. If you have the auto level styles feature off, Clear Style should remove everything that was brought in by the paste.

If Clear Style doesn't work, then you need to highlight the text and use the Style Attributes inspector. In that inspector you'll see all the styles effecting that text. Click the 'x' to the right of each entry that you want to remove.

However, you can avoid all this if you use the other paste option 'Paste With Current Style' which will paste the clipboard data without any styling so it takes on the style of the row you're pasting to.
A long thread from 2006 on handling styles in OO is at
HTML Code:
http://forums.omnigroup.com/showthread.php?t=480
I have not read all of the 4 pages of this thread yet but I have found at least one good tip,
from bashosfrog,

Quote:
I pretty much ignore Styles view for mass changes and just use the Utilities panel. ie. Select "All Level 2 Rows" in the lower window (OO clicks into Styles View), then make changes in Inspector = all Level 2 rows changed as expected.

I don't really "get" Styles View either. Not for everyday use. But I haven't needed to use it in order to set up OO documents of stunning style :-)
And this thread showed me I am far from alone in having difficulty with how OO handles styles. I love what I can do with OO, don't get me wrong, it is just hard for me to figure out this aspect of the app. I am working my way through about 20 pages of the pdf manual that deal with style. Searching for "paste" and "pasting", though, gets no hits in the manual so it is possible that this business of having inherited styles introduced by pasting, is not addressed in the manual.
 
It sounds like what you want to do is disable the "Automatic Level Styles" feature. With that active, anytime the entire text of a row is styled a certain way (say, after you paste content into a row) OmniOutliner thinks the next row should be styled the same way.
 
Brian,

Still having a problem with this. Here is what I am seeing:

(Just FYI for others, the "Automatic Level Styles" feature is located in the Format menu.
And it is governed globally by the default template. If checked in your template, unchecking it in the menu for a specific doc will not help. Open the default template (Prefs, General> edit template) to make an overriding choice.)

Now my template has been edited and saved, new docs open with "Automatic Level Styles" feature not checked in the menu. But the unwanted behavior persists in new docs!

My template for each entire new doc is Hoefler 18 Normal. That is followed until I paste in text in another style, using regular paste. Then not only does the pasted text appear in the pasted font and size, but so do siblings created below it, and children of it and its siblings.

Example: (I don't know how to paste images in so they appear properly here in regular replies & this is a Quick Reply)

Level 1: Hoefler 18
Level 2: Hoefler 18
Level 3: paste in Verdana 12
Level 4 (child of pasted row) appears in Verdana 12
Level 3 sibling beneath it also appears in Verdana 12
A new Level 2 row, created below the Verdana rows, reverts to Hoefler 18 and all is well thereafter unless I paste again.

And, the "Automatic Level Styles" remains unchecked despite this behavior.

To get things back to Hoefler 18 in rows equal to or below the pasted row I have to delete the style chits in Inspector>Style Attriburtes, or apply menu Format> Clear Style.
 
Quote:
Originally Posted by lostcities View Post
Brian,

the "Automatic Level Styles" feature is located in the Format menu.
And it is governed globally by the default template. If checked in your template, unchecking it in the menu for a specific doc will not help. Open the default template (Prefs, General> edit template) to make an overriding choice.)
When I said this I should have noted that it is contradictory to the OO 3 manual which says on page 21, " If you’d rather
OmniOutliner didn’t automatically create level styles for you, just deselect
the Automatic Level Styles item in the Format menu."

So maybe my experience is some isolated thing unique to my computer.
 
What you're seeing is not unique to you and is working as expected. There are a number of automatic things related to styles that have a high probability of changing or being removed in OO4. I think you've figured out what's going on though.

The best thing to do in this case is make sure automatic level styles is off from the start and after you paste something and see that that style is carried on, is to right then use the clear format option on that row.

If there's something specific you'd like information on let me know.
 
I would like to be able to turn off the *application* of level styles to new rows. Reason: I have a large document that contains samples of text in many different styles. Reconstructing it in a fresh document is not an option. "Turning off level styles" does not turn off level styles: Omnioutliner has already decided that new rows must by default have (horribily inappropriate) styles. Clearing a default level style, so far as I can tell, wipes the existing styles.

I just want to keep the formatting I have, and stop the automated stuff. I can format levels as needed in the convenient-enough way that Omnioutliner provides: open to a particular level, and apply the desired styles.

Isn't this the moral equivalent of a one line patch, give or take a UI check-box?
 
Since this issue of pasted text having the style of the original document when you don't want it, and it possibly affecting subsequent behaviour, happens not only in OO but also in other apps, I usually swap the setting for normal paste, and Paste with Current Style, as the latter is what I normally want, either doing it through the Keyboard preference pane, or in an app with its own shortcut preferences like Nisus Writer, through that.
 
Quote:
Originally Posted by Harold_f View Post
I would like to be able to turn off the *application* of level styles to new rows. Reason: I have a large document that contains samples of text in many different styles. Reconstructing it in a fresh document is not an option. "Turning off level styles" does not turn off level styles: Omnioutliner has already decided that new rows must by default have (horribily inappropriate) styles. Clearing a default level style, so far as I can tell, wipes the existing styles.

I just want to keep the formatting I have, and stop the automated stuff. I can format levels as needed in the convenient-enough way that Omnioutliner provides: open to a particular level, and apply the desired styles.

Isn't this the moral equivalent of a one line patch, give or take a UI check-box?
Unfortunately your document can't be fixed with a patch. The checkbox is already there, it's turning off Automatic Level Styles. The automatic function doesn't work such that it can be shut off to have everything revert.

Thinking of your options.... Do you have OO3 pro? Is most of your sample text all on the same row level? Or a couple row levels? This'll be messy to explain without being able to see your file.
 
I am also having an issue with changing styles and pasting.

Here is what would work for me:
  • The ability to make a template and lock the styles for each level. Any pasted text would follow the style that is in OO and strip any formatting.
  • The ability to edit any existing template and apply it globally with any docs that are currently using this template or a checklist of the docs that are using this template.

I have many notes that I have taken for classes and research; few, if any, of the notes follow the template that I originally set up due to cutting and pasting from the web, other docs and such. Spending the time formatting the documents took place in the setup of the template; that I have to spend time formatting later on is a complete waste.

I have read these threads and have implemented the cut-and-paste keystroke combination, but none of the other suggested fixes work.
 
I too would love to be able to lock the styles for a template so that pasting wouldn't alter anything. Only specifically selecting a line or group of lines should allow me to change the format.

I feel like I've spent way too much time re-formatting items that were pasted in ... and also reformatting items that I've typed in surprised me with new formats because OO adopted some formatting change for next items or sub-items because of something that was pasted in earlier.

Last edited by rogbar; 2009-11-21 at 02:53 PM..
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Spaces between images unwanted Dusty OmniGraffle General 2 2011-09-11 01:10 PM
Unwanted links created for all text entries sfoster OmniFocus 1 for Mac 1 2009-12-05 07:55 AM
Unwanted Attachments in action notes ceffe OmniFocus for iPhone 0 2008-08-29 01:00 AM
Deleting unwanted Contexts, Planning Mode MarkSealey OmniFocus 1 for Mac 2 2008-04-22 04:56 PM
unwanted window flashes during navigation Gregory OmniWeb Bug Reports 0 2006-05-14 09:15 AM


All times are GMT -8. The time now is 04:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.