The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
User agent string has wrong WebKit version Thread Tools Search this Thread Display Modes
The User Agent string in the latest 5.9.2 SneakyPeek (6.22.7.0.110031) has the same WebKit version listed as 5.9.1, even though it's now using the new Safari 4.0 WebKit. For example:

Code:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US) AppleWebKit/525.18 (KHTML, like Gecko, Safari/525.20) OmniWeb/v622.7.0.110031
...whereas the Safari 4.0 beta reports something like:

Code:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_6; en-au) AppleWebKit/528.16 (KHTML, like Gecko) Version/4 Public Beta Safari/528.16
In other words, Safari 4.0 reports WebKit version 528.16, whereas OmniWeb 5.9.2 reports 525.18.

I know, not very significant; but I wanted to make sure it was reported so it wouldn't be forgotten!
 
Thanks to whoever fixed this -- the latest 5.9.2 SP (110241) now reports:
Code:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US) AppleWebKit/528.16 (KHTML, like Gecko, Safari/528.16) OmniWeb/v622.7.0.110241
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
User agent for WebDAV sync Alvaro Other WebDAV 4 2010-08-24 04:26 AM
Language code in user agent string David Shepherdson OmniWeb Bug Reports 0 2009-03-11 07:26 PM
User Agent jcraig OmniWeb General 0 2006-11-04 12:26 AM
Webkit version David Latapie OmniWeb Feature Requests 3 2006-10-09 12:55 PM
WebKit browsers still render some sites wrong spacewalk OmniWeb Bug Reports 4 2006-04-18 02:02 PM


All times are GMT -8. The time now is 02:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.