The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniOutliner > OmniOutliner 3 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Add new row without pushing down column data? Thread Tools Search this Thread Display Modes
So I've got a text column and three checkbox columns. I enter some text and the click the appropriate checkboxes (in the same row). Now I hit <enter> to create a new row underneath. A new row is created, but my checkbox settings move down into the new row leaving empty checkboxes up above - what the...? I wanted those settings to remain with the row above. Is there a way to add new rows at the bottom without pushing adjacent column data down?

(Right, I see "Reorganize->add row" works). No chance I can get the <enter> key to do that, huh?


OmniOutliner/3.8/final-v143.41

Last edited by Leon Starr; 2009-03-25 at 10:28 AM..
 
It sounds like you have the "when creating a new row, split current row at cursor" option enabled in preferences, but don't actually want that behavior.

If you un-check that box, do you get the behavior you'd prefer?
 
That is definitely not the problem (and the first thing I checked).

Quote:
Originally Posted by Brian View Post
It sounds like you have the "when creating a new row, split current row at cursor" option enabled in preferences, but don't actually want that behavior.

If you un-check that box, do you get the behavior you'd prefer?
 
Could you please try adding an extra column of text, or something non-checkbox and see if it does the same? It should not be doing what you're describing unless you're using the split row behavior.

Does it do the same thing if you push control-return?
 
Hmmm... I guess I'm not understanding what you're seeing then. When I start with a document like this:



(You can't see it, but the text insertion cursor is just after "typed".)

When I uncheck column 2 and hit Return, I get:



It definitely seems like the split behavior is activating, though I don't know why. If you quit OmniOutliner and set your preferences file aside - move it to the desktop, for example - does the problem occur when you restart the app?
 
My apologies - I was looking at the wrong preference all this time!

I was looking at "When creating new row - create new empty row" which was checked and I figured that was that. LOOKING MORE CLOSELY, I see that there is that other part: split current row at cursor, and you were right, that was selected. Oops. Deselected it and now everything is fine.

Quote:
Originally Posted by DerekM View Post
Could you please try adding an extra column of text, or something non-checkbox and see if it does the same? It should not be doing what you're describing unless you're using the split row behavior.

Does it do the same thing if you push control-return?
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pushing stencils updates to Omni... possible? rtilghman OmniGraffle General 1 2013-01-09 08:17 AM
Plan: Data Calculations (custom column math) Juljon AppleScripting Omni Apps 12 2012-05-05 04:44 AM
Pushing more OF claus OmniFocus 1 for Mac 0 2012-04-14 04:46 PM


All times are GMT -8. The time now is 01:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.