The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Hyperlinks persisting in .pdf of .graffle Thread Tools Search this Thread Display Modes
Hi,

I think the answer to this is 'no' as I can't get it to work, but once I have associated a hyperlink to an object is there a way to get the link to persist (be 'alive' and clickable) in a pdf made from the .graffle?

The guys over at http://www.beedocs.com have managed to do it with Timeline :^)

Cheers

S
 
The answer is yes, in OmniGraffle 5. You will need to export to PDF as opposed to printing to PDF, but at least in Preview.app links that jump to other canvases as well as linking to URLs work fine.
__________________
"Vroom! Vroom!!"
 
Quote:
Originally Posted by Joel View Post
The answer is yes, in OmniGraffle 5. You will need to export to PDF as opposed to printing to PDF, but at least in Preview.app links that jump to other canvases as well as linking to URLs work fine.
Thanks Joel, sorry to have troubled you. I subsequently tried 'exporting' rather than 'printing' a pdf and it works beautifully.

Regards

S
 
I've looked at options in OmniGraffle 5, and cannot find one that suites my requirements:

Can a "relative website link (../page.html)" be created or edited in OmniGraffle Pro 5, so that it successfully exports and retains its hyperlink attributes?

My requirement is that the exported PDF file also retain the relative linkage.

Thank you,
Harry
 
Hello everyone,

I might have missed something on the forum about hyperlinks.
Here is my issue with Omnigraffle 5.4

One of my customer wishes to put hyperlinks on objects on a PDF file. To do so, I followed the action/open URL process to put hyperlinks on object.

However, when I export the file into a PDF (using the export options) and open the file, the link doesn't work, displaying a message such as:

"This program try to access the site
file://localhost/etc..." Even if I allow nthe action nothing is happening.

Did someone had the same problem and how do you manage to solve it?
 
I'm having the same problem whilst exporting a pdf and linking to pdfs. It opens my web browser and searches for file://localhost/etc...

I have partially solved this by reseting the link to "does nothing" and then re-linking and exporting. However the next time I save and export the link is broken.

I have tried varying where I save files ie making sure they're all in the same folder or not, and saving over the old file or creating a new version but can't work it out. I presume it just can't locate the correct file?

Thanks for any help in advance.
 
I've been trying the "jumps elsewhere" action. So rather than linking to the pdf externally it's switches to the next canvas or a specific canvas. Then when I export the document as a pdf or html format it still won't link correctly.
 
Sounds like you're running into a new issue which appeared in OmniGraffle 5.4: we made a lot of changes with the move to 64-bit, and accidentally broke PDF export of actions.

These issues have been fixed for the OmniGraffle 5.4.1 beta:

Quote:
Fixed a regression where actions to open URLs were not exporting properly to PDF.

Fixed a regression when using actions to jump elsewhere in the document and then exporting to PDF.
 
Hi. I have Omnigraffle 5.4.1, both standard and Pro. I can't get hyperlinks to work when files are exported to PDF. The error message is "Can't open link “file://localhost/../Components/ESBE/VZA_VZB_GB_99501362_A_LR.pdf” [...]"

Reading this thread it seems that I should be having no problems, so I am surprised. I have not been able to find the 5.4.1 beta release, so I wonder if the 5.4.1 release is not enough. In the release notes of 5.4.1, however, it is noted that the bug has been fixed, "Fixed a regression where actions to open URLs were not exporting properly to PDF."

I have a Mid 2007 Intel Core 2 Duo Macbook.

Thanks for help!

Joan
 
Quote:
Originally Posted by jsola View Post
I have a Mid 2007 Intel Core 2 Duo Macbook.
Just in case it is relevant for the last post above: I am running Lion 10.7.4.

Thx -- Joan
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Items becoming hyperlinks? markand OmniFocus 1 for Mac 5 2013-09-08 10:53 PM
Importing .graffle files into a .graffle document gshenaut OmniGraffle General 0 2013-03-20 05:09 PM
hyperlinks busa OmniOutliner 3 for Mac 0 2012-07-27 06:16 AM
Weird hyperlinks pacster OmniFocus 1 for Mac 4 2011-03-24 01:30 PM
Product Focus not Persisting in Context View blueice OmniFocus 1 for Mac 2 2010-09-20 05:08 AM


All times are GMT -8. The time now is 11:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.