The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPad
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Turning emails into actions: send-to-omnifocus@omnigroup.com Thread Tools Search this Thread Display Modes
One of the most-requested features for the iOS editions of OmniFocus is a way to process information from other apps into OmniFocus action items. (Email, for example.)

One option is to use applications that support the Send to OmniFocus feature, but what if you're using an app that doesn't support it, like the built-in Mail app on your iPad?

(If you're interested in apps that do support the feature, check this thread.)

Starting today, if you can turn the information into an email, you can add it to your OmniFocus inbox. Send an email from your PC, then tap a link on your iPad to add that email to your database.

To try out the feature, send a message to send-to-omnifocus@omnigroup.com. Within a few minutes, you'll receive an auto-response from us which includes a "Send to OmniFocus" link.

When you get back to your OmniFocus device of choice, open that mail message and tap or click the "Send to OmniFocus" link. At that point, OmniFocus will launch on your device and add the the subject and text of the original email to your database. (Attachments don't go along for the ride, but that also means that your sync times stay fast.)

(Note that this works best if you use a dedicated mail application - Mail for OS X/iPhone/iPad - as opposed to viewing your mail inside a browser. Web browsers don't seem to handle the custom link type as well as the native apps do.)

We'll probably do more work in this area for future versions of OmniFocus and/or the Omni Sync Server; this was just a quick/easy way we could improve the experience for folks that do a lot of work on non-Apple platforms. Hope it helps, and as always, we'd love to hear your feedback.


Update on 12/3/2012:

Closing this thread, as we're rolling out a new Omni Sync Server feature that's a significant improvement over this method. See this thread for more info.

Last edited by Brian; 2012-12-03 at 03:45 PM..
 
This seems to work well, but the body of text I'm getting back from the server seems corrupted - jumbled letters.
 
Quote:
Originally Posted by ksrhee View Post
This seems to work well, but the body of text I'm getting back from the server seems corrupted - jumbled letters.
If you can forward the original message along to the support ninjas, we'd love to take a look at that. Possible a different encoding is being used than the server-side script expects...
 
Quote:
Originally Posted by Brian View Post
If you can forward the original message along to the support ninjas, we'd love to take a look at that. Possible a different encoding is being used than the server-side script expects...
I forward it, but it looks like mails forwarded from my Mac is working fine, but if I forward it from my iPad, it comes back all jumbled up. Perhaps this gives you a better idea?
 
Strangely, although Ipad body doesn't generally come back, emails from Iphone work ok. I'llcontinue testing to see if I can refine the reasons.
 
When I tried it this morning from my iPhone it worked fine, but now the mails I send to the omnifocus email adress are not returned, is the mailserver down?
 
Quote:
Originally Posted by Nicolas_Thomsen View Post
When I tried it this morning from my iPhone it worked fine, but now the mails I send to the omnifocus email adress are not returned, is the mailserver down?
Tried it out just a minute ago, and it seemed to be responding fine. Still having trouble?
 
Quote:
Originally Posted by ksrhee View Post
I forward it, but it looks like mails forwarded from my Mac is working fine, but if I forward it from my iPad, it comes back all jumbled up. Perhaps this gives you a better idea?
Oooh, yeah, that's a useful clue. Information added to the bug we opened on this. Thanks!
 
Quote:
Originally Posted by Nicolas_Thomsen View Post
When I tried it this morning from my iPhone it worked fine, but now the mails I send to the omnifocus email adress are not returned, is the mailserver down?
Checked with the server admin - we haven't had any downtime today....
 
Quote:
Originally Posted by Brian View Post
Checked with the server admin - we haven't had any downtime today....
How long is it supposed to take before you get the mail back? I sent 5 out yesterday, only one of them came back and it took an hour for it to arrive.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turning email into actions: send-to-omnifocus@omnigroup.com Brian OmniFocus for iPhone 55 2012-12-03 03:41 PM
Can't send emails to specific project in OF ofuser OmniFocus Extras 3 2012-08-08 10:08 AM
send-to-omnifocus emails not working? android phone alternatives? travisp OmniFocus 1 for Mac 1 2012-06-09 08:55 PM
Turning email into actions: send-to-omnifocus@omnigroup.com Brian OmniFocus 1 for Mac 0 2010-12-16 12:12 PM
Turning Bugzilla emails into actions in the correct project kstrauser OmniFocus 1 for Mac 2 2010-12-04 07:57 AM


All times are GMT -8. The time now is 02:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.