The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Trouble with Mail Rule Thread Tools Search this Thread Display Modes
Hi,

I noticed that I cannot BCC to my +omnifocus address. When I do, the messages just comes to the inbox as normal and Omnifocus does not pick it up. It works fine when the +omnifocus is in the TO or CC fields.

The rule says any recipient, so I am not sure I am looking at a bug, having something else. I get some concerns from customers wondering who and WHY I am sending email to.

Does anyone have an idea or a workaround?

Thanks,
 
Bump. Anyone? Appreciated.
 
If you need a guaranteed response, you should use Help->Send Feedback or email omnifocus@omnigroup.com. Posting to the forum might get you a quicker answer, if someone else knows it, but it may not be seen by anyone in the know at Omni.
 
Figured it out....

Apparently, mail.app rules don't pick up the BCC from an account because the headers are hidden or something. I did some testing.

If you need to use BCC, you have to change your mail preference to use the -- (or other strong) at the beginning of the subject line, as that doesn't involved the headers being hidden on the BCC.

Hope this helps.
 
Hello there

When I send an email using the rule +omnifocus the message arrives, is marked as read and moved into the chosen mailbox but doesn't appear in OmniFocus.

The applescript command in the rule is

Code:
/Applications/OmniFocus.app/Contents/Resources/MailAction.applescript
I haven't changed this - it is just what was created. It appears third: first is Move Message, then Mark as Read, the Run AppleScript, then Stop Evaluating Rules.

Could someone please give me some guidance on what I might be doing wrong?

Many thanks

Deb
 
I have the same problem a below. It use to work fine but has stopped sometime recently during either Mail updates or OF updates.

Where is the script it does not exist on my Mac or I cannot locate it.

Quote:
Originally Posted by djaneb View Post
Hello there

When I send an email using the rule +omnifocus the message arrives, is marked as read and moved into the chosen mailbox but doesn't appear in OmniFocus.

The applescript command in the rule is

Code:
/Applications/OmniFocus.app/Contents/Resources/MailAction.applescript
I haven't changed this - it is just what was created. It appears third: first is Move Message, then Mark as Read, the Run AppleScript, then Stop Evaluating Rules.

Could someone please give me some guidance on what I might be doing wrong?

Many thanks

Deb
 
Quote:
Originally Posted by acarnegie View Post
I have the same problem a below. It use to work fine but has stopped sometime recently during either Mail updates or OF updates.

Where is the script it does not exist on my Mac or I cannot locate it.
The path indicates that the script is within the application package itself. I guess I could copy it out to a script folder and point it there but as OF created the rule itself and I can't find any information about it needing editing I thought it wiser to ask first.

Deb
 
I worked this out - it is because I use a MobileMe address and still use the old .mac address but MobileMe sees the .me and the .mac as the same thing and I had failed to make sure that both .me and .mac were in the address field in the settings.
 
Ciao everyone,

May I please have your help?

I've been forwarding emails to a _______+omnifocus@gmail.com address and half the time they're imported and then archived, and the other half, they're not.

What should I do?

Luca
 
What are you using to read email? Only Mail on the Mac where OmniFocus is running, or with multiple devices and/or programs? If the message has been incorporated into your mail file and is no longer "new" when Mail gets it, the processing will not be done. You can protect yourself from this problem by setting up a separate gmail account for actions you are sending yourself, and never check the email in that account anywhere except from Mail on the machine where you have OmniFocus.

An easy way to test if this is what is affecting you is to edit the rule created in Mail by OmniFocus to do something like first flagging the message before doing the rest of the processing. If the message gets flagged, that means the rule was run and your problem is elsewhere (if it didn't appear in OmniFocus). If the message doesn't get flagged, the rule was not run and the likely reason for that is that Mail didn't regard it as a new message.

If the messages always get flagged, I would then verify that you are always sending plain text messages, not HTML or RTF formatted messages. The gmail web interface has a setting for message composition which can produce formatted messages which the Applescript internals of the Mail processing code will not handle. If you are sending from multiple clients, and there is a pattern in which messages do not appear, that may be your answer.

Finally, make sure that all the email addresses from which you are sending messages to OmniFocus are listed in the "Allowed From addresses" section of the OmniFocus Mail preferences.

In sum, there are 3 main ways in which you can have problems:
  1. OmniFocus doesn't get the message because the rule was never run
  2. OmniFocus doesn't get the message because the sender isn't authorized
  3. OmniFocus gets the message, but can't understand it because of improper formatting or structure
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble with Mail Rule jenroesch OmniFocus 1 for Mac 3 2012-01-01 12:51 PM
Would like to use the mail rule... Finlay Boo OmniFocus 1 for Mac 3 2009-06-15 12:46 AM
Mail rule and bcc chinarut OmniFocus 1 for Mac 0 2008-07-23 03:41 AM
Mail.app and OmniFocus Mail Rule chinarut OmniFocus 1 for Mac 0 2008-06-28 10:26 AM
Adding Tasks Via Send To OmniFocus Mail Rule, Mailtags, & Mail Act-On reuben OmniFocus 1 for Mac 0 2007-11-18 07:07 PM


All times are GMT -8. The time now is 07:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.