The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
I want my money back! Thread Tools Search this Thread Display Modes
I am sorry, but I am having some really disturbing problems with OmniWeb 5.5.4 (v607.17). I bought it two weeks ago (as version 5.5.3) and I should say that I am not impressed with its speed and the amount of time it takes to load well known, fast Web Sites, such as Digg.com and Slashdot. I tested this against FireFox 2.0.1. I have Excite as my home page for over 8 years now and that is my starting point to a lot of my favourite links. I have Excite as my starting page on both OmniWeb and FireFox. I click on a link to Digg and wait, and wait, and wait... Then I launch FireFox and click on the same link and have Digg open instantly! :mad: The BIG difference is that FF did not cost me a penny! And it works as I expect. My Internet connection is nothing to sneeze at either: I have a 5 mbps DSL connection. I don't undestan why OW takes soooo long to load a Site when it should really be as fast or FASTER than FF. I use it on my MacBook Pro, 2.16 GHz, 2 GB-RAM. Not a slow machine by any means... Even now, as I preview this post it is glacially slow...

For that reason, please, I want my money back. It was very easy for me to purchase OW, so I am assuming it should be equally easy for you guys to credit my money back to my credit card. Thanks. Maybe some other time, when this is resolved.
 
Are you sure understand the sometimes glacial speed of Digg? It's notorious for being ridiculously slow at times, even to the point it's almost a joke (just ask the reddit crowd). I just loaded Digg in OmniWeb and Firefox 2.0.0.1 on my old G5, and Firefox loaded slower.

Right now there's at least 12 javascripts on the homepage, and that tends to slow down any WebKit browser. It gets worse over time, so leaving your browser on for days tends to bog it down in Safari or OmniWeb. It's truly horrible in Safari, though, and the OmniWeb team's made great strides in making it better than Apple's native browser.

That said, I think you're describing the same behavior you get when you've had your browser open for a while (days) combined with the slowness that is Digg.
 
I do not leave my browser open for days. I close it whener I finish a browsing section. And Digg has never been slow on any other browser, including Safari. I see this is going nowhere as to getting my money back... :(
 
Quote:
Originally Posted by cpcabral
I do not leave my browser open for days. I close it whener I finish a browsing section. And Digg has never been slow on any other browser, including Safari. I see this is going nowhere as to getting my money back... :(
Sorry that you're having problems. For me, OW is much faster than FF and does not crash nearly as often. I realize that some users are having issues. Perhaps you can find a solution.

As to getting your money back, why would anyone on a discussion forum be able to help you? You need to contact OmniGroup.
 
In future I suggest that you try using demo versions of software before making a purchase.
 
Quote:
Originally Posted by cpcabral
I do not leave my browser open for days. I close it whener I finish a browsing section. And Digg has never been slow on any other browser, including Safari. I see this is going nowhere as to getting my money back... :(
Contact OmniGroup directly via the Help>Send Feedback menu option.

FWIW, this is likely another example of the Javascript garbage collection bug in the version of WebKit that OmniWeb is currently using and should (hopefully) be resolved in the 5.6 release when it finally arrives.

Last edited by JKT; 2007-02-20 at 12:23 AM..
 
Quote:
Originally Posted by daiyi666@yahoo.com
Sorry that you're having problems. For me, OW is much faster than FF and does not crash nearly as often. I realize that some users are having issues. Perhaps you can find a solution.

As to getting your money back, why would anyone on a discussion forum be able to help you? You need to contact OmniGroup.
I just had no idea where to start. I thought the discussion groups would be a starting point. Obviously, the people around here, like to think that if you don't do what they know it is right, then you must be stupid! Sorry I have offended your intelligence by reporting my problem and asking the question. I will not do that again, ever, since I will be unistalling this idiotic piece of software as soon as I finish this post.
 
Quote:
Originally Posted by JKT
Contact OmniGroup directly via the Help>Send Feedback menu option.

FWIW, this is likely another example of the Javascript garbage collection bug in the version of WebKit that OmniWeb is currently using and should (hopefully) be resolved in the 5.6 release when it finally arrives.
Thanks for your reply JKT. You seem to be more accomodating than some around here...
 
Quote:
Originally Posted by revs
In future I suggest that you try using demo versions of software before making a purchase.
In the future, I suggest you keep your smart replies to yourself. That does not help me and I am sick and tired of useless replies like these. Adios!
 
1. Just like to mention his attitude does not reflect those of all Canadians

2. Just like to mention that no replies in this thread were useless. I can't give you your money back. Neither can most people here. Thus, they were just attempting to figure out -why- it's running so slow on your computer. The knowledge of these things really does help devs fix problems.

3. Just want to mention that I hardly doubt it was a smart reply. Did you try the demo? If not, it might be a good idea for future products, I've had several occasions that software does not work on my machine as suggested by the developers, and using a demo first saved me a lot of money.

4. Lastly, I'm sorry that OmniWeb didn't work out for you. It's unfortunate that there are still some bugs that seem to completely ruin the experience for some users. I would invite you try the browser out again when it hits 5.6 to see if the newer, updated version of WebKit fixes your problem.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
30 Day Money Back Guarantee or not? BK0001 OmniFocus for iPad 1 2010-07-30 09:20 AM
We're extending our 30-day money back guarantee to App Store purchases Brian OmniGraffle for iPad 0 2010-04-09 11:44 AM
We're extending our 30-day money-back guarantee to App Store purchases Brian OmniFocus for iPhone 0 2010-04-09 11:43 AM
Can I get my money back? Daland OmniFocus Syncing 1 2008-08-05 05:28 PM


All times are GMT -8. The time now is 10:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.