The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Feature Requests
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
View PDF in Browser Window Thread Tools Search this Thread Display Modes
I'd like it if OmniWeb would allow me to view PDF's in a browser window like safari does. I don't like having to download it and open it in another app even if it does it automattically. Seems like a waste to use another app simple to view a PDF.
 
just use the terminal and type "defaults write com.omnigroup.omniweb5 WebKitOmitPDFSupport -bool false"
omniweb then will open pdf files in the browser window instead of downloading them.
 
You may also have a look at these plugins (which are free for personal & educational use):

http://www.schubert-it.com/products/
 
In my Sneaky Peak 11 of OmniWeb 5.5, PDFs don't even download. All I get is an "Open" dialog box, not a "Save" dialog. I have to click "Cancel", and the browser window is going blank.

The "defaults write com.omnigroup.omniweb5 WebKitOmitPDFSupport -bool false" trick doesn't seem to work. At least, it doesn't change anything.

I'm using Schubert IT's PDF Browser Plugin (v. 2.2.3) which works well with OmniWeb 5.1.3 and all other browsers.

I assume this is a bug in the Sneaky Peak versions or, possibly, that they're not compatible with Schubert IT's PDF Browser Plugin?
 
I use that plug-in, and it works fine. Do you have the AdobePDF plugin disabled?
 
Quote:
Originally Posted by Forrest
I use that plug-in, and it works fine. Do you have the AdobePDF plugin disabled?
Yup. Adobe's plug-in is disabled. Today, I succeeded to get things working. Via OmniWeb > Preferences > Plug-Ins, I disabled Schubert IT's plug-in, then enabled Adobe's plug-in, and relaunched OmniWeb. PDFs still didn't show up in the browser. Then I disabled Adobe's plug-in and re-enabled Schubert IT's plug-in, relaunched OmniWeb, and now it all suddenly worked well. Go figure! :-)
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Export browser window too large oblomow OmniGraffle General 12 2008-10-19 04:36 PM
Browser window size tfindlay OmniWeb General 1 2006-11-03 01:57 PM
Can't drag links into the browser window neilio OmniWeb Bug Reports 0 2006-06-25 05:10 PM
RSS in browser window nayr OmniWeb Feature Requests 0 2006-05-21 05:26 PM
Download PDF or render in browser window bethkatz17582 OmniWeb General 8 2006-04-10 07:20 PM


All times are GMT -8. The time now is 03:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.