The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OmniFocus Web App alive and kickin'! Thread Tools Search this Thread Display Modes
I get prompted for a username and password when I go to http://localhost:3000/. I have no idea what to put. (Blank doesn't work.)
 
ah -- found it in config/Settings.plist: evan/t0mahawk
 
I am so close...

I can get to the point where I put in http://localhost:3000 and that works great! I just can't figure out how to set up my airport to do the right thing. I'm sure I've set up the dyndns part correctly.

How do you set up the airport express to port map correctly?
 
Thanks Evan!

This is great to hear and will be using your web app. If only I was a bit more knowledgeable in Ruby I'd help you out.

Keep up the good work!

Bill
 
Quote:
Originally Posted by tehprince View Post
If only I was a bit more knowledgeable in Ruby I'd help you out.
I feel the same way. I started using the web interface last night and have quickly found it indispensable.

Unfortunately I know no Ruby but am good at breaking things.

If you need someone willing to test releases pop me a msg here or whatever.

Thanks for working on this project!
 
Quote:
Originally Posted by euchomai View Post
I am so close...

I can get to the point where I put in http://localhost:3000 and that works great! I just can't figure out how to set up my airport to do the right thing. I'm sure I've set up the dyndns part correctly.

How do you set up the airport express to port map correctly?
I don't have an Airport but this sounds exactly like you're not mapping the port to forward correctly to your machine.

There should be a setting that says something to the effect of 'Take anything coming in on port 3000 and send it to this (local) IP address on the LAN.'

Edit: Some quick Google-fu turned up this guide:

http://www.mac-connect.com/wire_step4.php

Public port = 3000 (or some other port if you wanna change things up when using it in the outside world but why complicate things), Private IP address = your local IP address of your mac when plugged in, ususally 192.168.something.something or 10.0.something.something, and Private port = 3000.

Last edited by Eleventeen; 2008-01-04 at 07:58 PM..
 
Quote:
Originally Posted by Eleventeen View Post
I don't have an Airport but this sounds exactly like you're not mapping the port to forward correctly to your machine.

There should be a setting that says something to the effect of 'Take anything coming in on port 3000 and send it to this (local) IP address on the LAN.'

Edit: Some quick Google-fu turned up this guide:

http://www.mac-connect.com/wire_step4.php

Public port = 3000 (or some other port if you wanna change things up when using it in the outside world but why complicate things), Private IP address = your local IP address of your mac when plugged in, ususally 192.168.something.something or 10.0.something.something, and Private port = 3000.
This is exactly what I have done and I just can't punch through at all. Has anyone here successfully used an airport express base station to pull this off? I've got to figure this out.

Last edited by euchomai; 2008-01-04 at 09:08 PM..
 
I could be wrong about this, but I believe it's also possible for your ISP to block this sort of thing. Maybe that's the trouble you're running into.
 
'm on Leopard with the Development environment installed.

I try both from the zip and from a fresh checkout and got the following error:


Exiting
./script/../config/../vendor/rails/railties/lib/commands/servers/mongrel.rb:15: warning: already initialized constant OPTIONS
./script/../config/../vendor/rails/railties/lib/commands/servers/mongrel.rb:18: undefined method `options' for []:Array (NoMethodError)
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:32:in `gem_original_require'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:32:in `require'
from ./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:495:in `require'
from ./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:342:in `new_constants_in'
from ./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:495:in `require'
from ./script/../config/../vendor/rails/railties/lib/commands/server.rb:39
from script/server:3:in `require'
from script/server:3

I'm quite experienced in programming but don't know anything about ruby... but I would be happy to learn.

Thanks for your help.

Here is the full stack trace.

ruby script/server
=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Ruby version is up-to-date; cgi_multipart_eof_fix was not loaded
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment...
LOAD_PATH = ./script/../config/../vendor/rails/activesupport/lib/active_support/vendor./script/../config/../vendor/rails/activesupport/libscript/../config/../app/controllers/script/../config/../appscript/../config/../app/modelsscript/../config/../app/controllersscript/../config/../app/helpersscript/../config/../componentsscript/../config/../configscript/../config/../libscript/../config/../vendor/Applications/omnifocus-ui/svn/trunk/vendor/rails/railties/builtin/rails_info/script/../config/../vendor/rails/railtiesscript/../config/../vendor/rails/railties/libscript/../config/../vendor/rails/actionpack/libscript/../config/../vendor/rails/activesupport/libscript/../config/../vendor/rails/activerecord/libscript/../config/../vendor/rails/actionmailer/libscript/../config/../vendor/rails/actionwebservice/lib/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/fcgi-0.8.7/bin/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/fcgi-0.8.7/lib/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/daemons-1.0.7/bin/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/daemons-1.0.7/lib/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/fastthread-1.0/bin/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/fastthread-1.0/lib/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/bin/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/bin/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/lib/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/cgi_multipart_eof_fix-2.2/bin/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/cgi_multipart_eof_fix-2.2/lib/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/Library/Ruby/Site/1.8/Library/Ruby/Site/1.8/powerpc-darwin9.0/Library/Ruby/Site/1.8/universal-darwin9.0/Library/Ruby/Site/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/powerpc-darwin9.0/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin9.0.
Environment:
MANPATH = /usr/share/man:/usr/local/share/man:/usr/X11/man
TERM_PROGRAM = iTerm.app
TERM = xterm-color
SHELL = /bin/bash
TMPDIR = /var/folders/f+/f+4JTe3FEUS87oJtNZATjU+++TI/-Tmp-/
Apple_PubSub_Socket_Render = /tmp/launch-Cl4Ifc/Render
USER = chris
COMMAND_MODE = legacy
SSH_AUTH_SOCK = /tmp/launch-SaRXb5/Listeners
__CF_USER_TEXT_ENCODING = 0x1F5:0:91
PATH = /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin
PWD = /Applications/omnifocus-ui/svn/trunk
SHLVL = 1
LMILAUNCHAGENTFIXER_GOODGUISESSION = 1
HOME = /Users/chris
LOGNAME = chris
DISPLAY = /tmp/launch-Yy8LcS/:0
_GOOGLE_GILD_RUNTIME_FRAMEWORK_ABSOLUTE_PATH_ = /Library/Google/Frameworks/Gild.framework
SECURITYSESSIONID = d073e0
OLDPWD = /Applications/omnifocus-ui/svn
_ = /usr/bin/ruby
RAILS_ENV = development
Exiting
./script/../config/../vendor/rails/railties/lib/commands/servers/mongrel.rb:15: warning: already initialized constant OPTIONS
./script/../config/../vendor/rails/railties/lib/commands/servers/mongrel.rb:18: undefined method `options' for []:Array (NoMethodError)
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:32:in `gem_original_require'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:32:in `require'
from ./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:495:in `require'
from ./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:342:in `new_constants_in'
from ./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:495:in `require'
from ./script/../config/../vendor/rails/railties/lib/commands/server.rb:39
from script/server:3:in `require'
from script/server:3


P.S.: This is a cross-post with the ruby sourceforge forum, but because the trafic seems to be very low there, I decided to also post it here.
 
Quote:
Originally Posted by euchomai View Post
This is exactly what I have done and I just can't punch through at all. Has anyone here successfully used an airport express base station to pull this off? I've got to figure this out.
Is your Airport Express Base Station your internet gateway/router? I suspect not. If so, that may be part of your problem. I suspect your network looks like:

cable modem/router -> airport -> mac

If so, the modem/router needs to forward port 3000 to the airport which in turn needs to forward it to your mac. Also, for this to work, you need to give your airport express and your mac a static IP address on your network. Most home network software defaults to DHCP -- a protocol for dynamically allocating you an IP address.

Hope this helps.

Evan

P.S. Feel like an idiot. Didn't subscribe to this thread so didn't realize that people were chatting here! Also, feel free to use the forums and/or mailing list on the RubyForge page linked above. Likewise, if you find bugs, submit a trouble ticket via the "Tracker" on the RubyForge page.

P.P.S. I've been a goof off lately, playing way too much Xbox. However, now that I'm back to working a 9-5 again post holidays, I'll get back to hacking.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Excellent! Will now solely use Omnifocus 2 only with my IOS Omnifocus products kerryd OmniFocus 2 for Mac (Private Test) 7 2013-04-17 04:47 PM
Omni Sync Server: it's Alive! Brian Syncing via Omni Sync Server 0 2012-03-05 02:02 PM
Beginners guide - using omnifocus to find a personal strategy of how to use omnifocus wayne4 Applying OmniFocus 7 2008-11-14 07:22 AM
OmniWeb RSS - Dead or Alive? BwanaZulia OmniWeb Feature Requests 1 2007-05-24 04:34 PM


All times are GMT -8. The time now is 12:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.