The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

1.0.3 Update do I have to create a new database?!?!?!?!?! Thread Tools Search this Thread Display Modes
I dont have MobileMe, nor do I have it backed up to a webDAV server. It is "synced" with itunes - does that mean I do not need to create a new database? When it syncs to itunes, I still get the prompt to create a new database when I start OF. Please HELP!

This is a bug that some people are reporting with the iPhone. It is not supposed to wipe your application data when it installs an update, but sometimes it does. We don't know why or if there is any pattern to when it happens, and it's not limited to OmniFocus - it appears it can happen with any application that saves data on the phone. (It's possible that the bug was fixed in the iPhone OS 2.0.1 upgrade, but we don't really have any idea. Do you have 2.0.1 installed?)

If you have a recent backup of your iPhone/iPod touch in iTunes, you can restore that backup to get whatever data was on your phone at that time. THIS WILL WIPE OUT ALL NEWER DATA ON YOUR PHONE, including any upgraded applications, so if your backup is not recent, it may not be worth restoring from it. If you _do_ restore, you'll need to reinstall any upgrades that you installed after the backup, including OmniFocus, and there is no guarantee that it won't lose your data again when you do that, as we don't know what causes it. (However, if you restore and then set up syncing to get your data backed up to MobileMe or other WebDAV server, then if the upgrade loses your data you can just reconfigure syncing to download the data.)

To restore from a backup, connect your device to your computer, then right-click on it when it shows up in the source list in iTunes and choose the restore option.

I hope that's helpful, and I'm sorry that I don't have better news for you.
I've got 2.0.1 installed and this is now the second time an OF update has wiped my data. And like Souza, I too don't sync with other apps. I grow weary of re-entering data.
Originally Posted by jgovern View Post
I've got 2.0.1 installed and this is now the second time an OF update has wiped my data. And like Souza, I too don't sync with other apps. I grow weary of re-entering data.
To speak to the Omni Group's statement. I have had 1 time where the data got wiped. And on this latest install, where the data was maintained.

It might be a good idea to also send your feedback to Apple so they know this is a potential issue on their side. Customer feedback will probably help them gage impact and prioritize bug fixes if this is on their side.

I feel for you.

Good luck and hang in there.
Godaddy has webdav compatible online storage of 50mb, enough for Omnifocus for only $7/yr. Or you can spend $20/yr for 10GB from BingoDisk.

The best feature of Omnifocus is the sync which backs up your data. Totally worth it.
I just lost my second database with this update as well. I DID back up to a webDAV server, and can confirm that my data is there.. OF just won't pull it down and open it. I've tried everything I can think of, it syncs... downloads.. and I'm sent to an empty omnifocus. : (

I don't think I have another update in me if I'm re-entering all my stuff each time.. Local database loss may not be their fault, but the silent failure of webDAV syncing after that IS. They could at least document how this works so I could troubleshoot why it's failing..
I don't know if it'll help, but have you tried resetting the database from settings before syncing, so that OF really does believe it needs a new database?
Yup, i reset the DB, the last time around I uninstalled and reinstalled OF,
I even dug into webdav, discovered that OF uploads a .client file which is basically an xml plist that marks the last time the client synced.. I removed all of those, (so OF would think it was new to it)

every time, it 'syncs' for a looong time.. (I checked server logs, it's downloading the zip files) then goes to 'opening document' and shows me... an empty database. (not even the default blank database it starts with.. empty.)
Rather than digging around inside the OmniFocus package on your server and removing individual client files, have you tried just starting over from scratch? In other words, follow these steps:
  1. Make a backup of your OmniFocus database on both you Mac and on your server just to be safe.

  2. Go to OmniFocus' preferences on your Mac and turn off syncing.

  3. Delete OmniFocus from your iPhone (tap and hold the OmniFocus icon and, when they all start to wiggle, tap the little "X" on the upper left corner of the OmniFocus icon).

  4. Delete the entire OmniFocus.ofocus package from your server (may appear as a directory if you're viewing it with ssh or an app like Panic's Transmit).

  5. Re-enable syncing in OmniFocus' preferences on your Mac and do the initial sync with the server.

  6. Reinstall OmniFocus on your iPhone by syncing it with iTunes over USB. Make sure that the checkbox next to OmniFocus is checked in the Applications tab in the iTunes view of your iPhone.

  7. Launch OmniFocus on your iPhone. It should prompt you to create a new database or sync with a Mac. Choose sync with Mac and activate the Share Settings mode in the OmniFocus Sync preferences on your Mac.

  8. Once you receive the settings on your iPhone and confirm, the OmniFocus database from your server is copied to your iPhone. Presto! You have a fresh install of your database on the server and on your iPhone.

  9. Enjoy trouble-free syncing.


Last edited by Toadling; 2008-08-14 at 12:03 PM.. Reason: Added step to first backup databases
Dennis, you're making a few assumptions.

1. I own a mac
2. I own omnifocus on said mac.

: )

(i do, actually have a mac mini which i sync itunes on, but I don't have a .mac account, and i don't have omnifocus on that mac.. (I can't freakin afford it!) so that's immaterial)

Hence the necessity of syncing to a webDAV server, which, to date has failed for me utterly.

Thanks for taking the time to spell it all out though! I'm thinking my case must be a bit rare.. : /

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost database after update on IOS and OF S.Gecko OmniFocus for iPad 1 2012-09-20 09:00 AM
Replace your Database and start syncing? after 1.7.4 update Robbie1702 OmniFocus 1 for Mac 16 2009-11-24 11:11 AM
database doesn't update on mac after sync awnathan OmniFocus Syncing 3 2008-08-07 01:18 PM
update 1.0.1 cleared my database hassler OmniFocus for iPhone 25 2008-07-22 10:07 AM
Help! Accidentally told it to 'create new database' instead of sync from mac jenniferp OmniFocus Syncing 4 2008-07-21 06:11 AM

All times are GMT -8. The time now is 02:15 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.